Menus missing

I am building a new system and spent a few hours installing CC3+ as to include Symbol Sets 1 - 4.

The problem is that I don't see the SS3 or SS4 icons on the toolbar. I am not too eager to reinstall all of this and I was hoping that there was a quick fix.




  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    Have you installed the latest update (currently 19) AFTER installing the add-ons? Among other things, the update fetches the latest menu files from the internet and updates the menus, so this usually fixes it.

    If that doesn't help, you can also manually run CC3menuconfig.exe found in your data directory. Note that this program is silent, when you double click the file, it will just take a few second to do it's thing, without any prompts or messages.
  • CC3MenuConfig did not help.

    And I updated the core application to 19 before installing anything.

  • BTW, I noticed this after installing CSUAC which failed to create toolbar 3. I had backed up prior to the install, so I restored the backup and it was exactly the same (i.e. incomplete).

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    As I said, try to run Update 19 AFTER installing the add-ons (i.e. now).

    Also, try the different menus, see if this only affect one of them or all of them, for example the dungeon menu, the city menu and so on. Sometimes a single menu file may have failed to update.

    If none of the menus contain the SS3 and SS4 icons, also check that the menu files are in the CC3+ data directory, you should have two files called ss3.mnu and ss4.mnu there
  • Monsen -

    I did not think that you could install an update once it was installed - but you can and I did. And that fixed it! Thank you for taking the time to help out!

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    You're welcome.

    The updates are designed so they can be installed multiple times. This is needed, because if you install an add-on after an update, that add-on will introduce new files to the system that might need to be updated, the updater cannot update the files for an addon that hasn't been installed yet.

    Happy mapping :)
  • 25 days later
  • I read this thread and was wondering where you find this menu config file because i don't see it in my cc3 files
  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    CC3MenuConfig.exe is located in the CC3+ data directory.
  • 3 years later
  • Sorry for the necro…

    I've installed all of the CSUAC/Bogie/etc. stuff. As mentioned in the installation guides, the toolbars did not build.

    However, after following all of the directions in each of the installation guides to build them (run the latest update patch, run the "menu_recovery" routine, etc.), I still have only one symbol on the toolbar. It is "Street Tiles," and when I click it the catalog that comes up is empty.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Which add-on menu do you have loaded right now? I can't remember seeing a street tiles button anywhere. The Vintyri built collections only add things to the main add-on toolbars (Overland/Dungeon/City/Cosmographer/SS3/SS4)

  • I've tried Overland, Dungeon and SS4. No joy - they all result in the same (mostly) empty toolbar.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Are the toolbar actually empty, or do you just have invisible buttons (You can test for the latter by hovering over the places where the buttons should be and trying to click)

    Also, you have turned on the right toolbar, right ("Custom Icon Bar 3")?

  • It seems that they're actually empty - hovering over various places on the toolbar did not bring up pop-ups, nor did clicking on different places where the buttons should be have any effect.

    Confirmed, Custom Icon Bar 3 is on. (I even tried turning on 2, but of course that didn't have the desired effect either).

    I also switched back and forth between Overland, Dungeon, City, and the two Symbol Sets buttons. The only effect that had was that I discovered the Overland toolbar is the only one in which the "Street Tiles" button appears on the CSUAC toolbar. When any of the other CC3+ toolbars are active even the Street Tiles button disappears.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    No idea where the Street Tiles come from, I can't find that as part of any of the Vintyri stuff.

    Anyway, do you have everything correctly installed? Menu files are updated based on the existence of other files (it uses this so it can add buttons only if you have the actual product installed)

    For the menu files to be correctly updated, you should have at least a file called menu_recovery.cfg in the root of your CC3+ data directory, and in a subdirectory called menu you should have the following files: vss2_misc.mnc, bogie_redthorn.mnc, bl9_modern.mnc, b11_humanoids.mnc, bl12_dressing.mnc and bl10_overland_symbols.mnc (There will be more, but these are what the menu config tool looks for). Do you have these files in the correct location (Everything needs to be exactly where it is supposed to, any additional or missing sub-directories will cause the system not to be able to find them.)

  • edited August 2022

    Yes to all except the menu_recovery.cfg. I have a menu_recovery.bat, but not a .cfg.

    Is there a way for me to get just that file and put it in the proper place, without going through all of the installation again?

    I installed everything to the default directories - nothing custom.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Have a look in the System subdirectory if you see the menu_recovery.cfg there. I was a bit hasty since I had one in the root myself, but the System directory is the correct location for the one called by the .bat file

    You can also open it up in a text editor to make sure it looks sane.

  • Yep, it's there in the System subdirectory. As far as I can tell it looks like it should… I'm no programmer, but there are lots of lines to add various .mnu files and their associated bitmaps (which I assume are the buttons?).

  • Yes, it fixes menu options for those symbols.

  • Except in my case it didn't :(

    I know I can still get to the symbols "the long way around," but would love to be able to just press a button and get there.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    edited August 2022

    I did a new test install myself with the latest files from the Vintyri project site (February 2021 versions) and there doesn't seem to be any problems or compatibility issues with the newest CC3+, everything installed just fine for me. I still needed to run the menu_recovery.bat once after installing, but that was it.

    So, there seems to be something different with your installation, so just to clear up a few things to make sure we're on the same page:

    • You did update CC3+ to the most recent version (3.98)?
    • You did install the Vintyri/CSUAC/..../etc into the CC3+ data directory and NOT the installation directory (i.e. into ProgramData, NOT Program Files)
    • Have you tried disabling your antivirus software before running menu_recovery.bat?
    • When you ran menu_recovery.bat, you did see a black command window pop up that lasted for a second or two? You can make it hang around longer if you open menu_recovery.bat in notepad, and add a third line just saying pause at the end. This will also let you spot any error messages that may be thrown when you run it.
    • Is your CC3+ data directory in the default (c:\ProgramData\ProFantasy\CC3plus) location, or a custom one?
    • Do the symbol catalogs show up in the catalog settings window ( -> Advanced, set catalog settings filter to * and master filter to Bogie and hit find now). Should list about 20ish catalogs. Do the previews work? (i.e showing the symbols and not red X'es.)

  • edited August 2022

    CC3+ version 3.98 - Check*

    Vintyri/etc. installed in ProgramData - Check

    Antivirus Software disabled - Check

    menu_recovery.bat produces command window - Check (but doesn't appear to be running correctly; see attached pic)

    CC3+ data directory installed to default location - Check

    Symbol Catalogs show in settings window - Check

    *There were some oddities in my installation. Running the latest update patch updated to version 3.98 (confirmed in the Help/About CC3+ window from within the program), but after I ran it the "patch.ini" file was no longer there. I had to manually put one in with the "28" line in it to get the add-ons to recognize that I had the latest update. Once I did that everything appeared to install correctly - I had no more errors.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Seems like you're missing more files than just the patch.ini file. Not sure what happened, but as you see from the error messages, you're missing the cc3menuconfig.exe file. This is the executable that does the actual menu updating, so without it, menus can't get updated.

    Not sure if just reinstalling the latest update will fix that, you may need to run a repair install using the CC3+ installer.

  • Well, that didn't work, and scared the poo outta me - when I ran CC3+ after doing the repair install it said my license was invalid and saves are disabled. I ran the update anyway, which prompted me to enter my serial number, and appeared to run correctly.

    However, neither the patch.ini file nor the cc3menuconfig.exe file are present even after the repair install.

    This is starting to seem like a tech support issue, maybe?

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Well, I guess it is either a full reinstall or tech support. Probably not a bad idea to let tech support look at it though.

  • Jeff BJeff B Betatester 🖼️ 37 images Surveyor

    This my sound like a dumb question but is your program data folder on either a network drive or a drive / folder that gets backed up automatically ie dropbox , one drive etc.? If so that could be your issue because the files keep changing status as they are backed up.

    Just a thought I have seen a similar issue when the data files are on or in an automatically backed up drive or folder.

  • Some of those symbols when I installed, worked for me. But some I got befuddled and did them wrong.

    I had missed a few sentences in one of the Vintyri pdfs.

  • Thanks for your help, Remy - I appreciate it!

    I've got an external hard drive that I plan to use to back up my laptop drives, but haven't started yet. My data folder in in the C: drive on my laptop, installed to the default path.

  • OK, this is weird…

    Just for kicks and giggles I ran the installer in repair mode again. Both the patch.ini file and the cc3menuconfig.exe file are there! Then I installed the update again, and they were both gone!

    What the heck!?

  • BUT, before I ran the updater I made copies of the two files in question. When I pasted them back into their proper place and ran the menu_recovery file, the Vintyri toolbars appeared in their proper place.

    Problem solved, but I still don't know why the updater is messing up my program, or what other files might be disappearing...

Sign In or Register to comment.