WINE installer error -any ideas?

Anyone tried this?

Due to complications with remote access to my work PC (from my Mac 2019 running Sonoma), I need to reinstate a WINE environment to run CC3+ natively. I can't justify the cost of Crossover, though I used it prior to upgrading to Big Sur, unfortunately that upgrade and Crosover 19(I think) were incompatible, and found it good for the most part.


  • Well I had a go at this and got a Runtime error message; I then tried WINE directly via various methods with exactly the same result each time.

    Was trying to avoid having to use Crossover - it seems counterintuitive to me to pay for software to use free software (WINE)...perhaps that's just my Scottish heritage rearing it's cheapskate head...

    Here is the error message. Any ideas? I used to be good at this stuff but technology has moved far to rapidly for me it seems...

  • Hello. Did you install the Visual C runtime? I seem to recall having to do that.

  • Thanks Kertis. Never saw that mentioned anywhere...even when I googled the error.

    I just Googled this and after a bit of TLDR, I can't be bothered. It's too much hassle. I was trying to avoid installing CC3+ on my work laptop because I prefer the large screen and the laptop's not that great - but other than going back to running CC3+ via Bootcamp (and an unlicensed, though legal version of Windows) I don't see that I have much choice...

  • I don't understand your position. The VC runtime is a small download that can be installed easily in WINE.

  • Apparently, it's not that straightforward

    The same issue occurred with the trial version of Crossover...

    Years ago, I had the patience and was OK with this kind of stuff, now I don't have the time nor mental capacity for it. I expect "stable" software to work and do as promised on the "tin". Unless there are clear, up-to-date instructions for how to do this on a 2019 iMac I5 w/- 16GB RAM running OS Sonoma, it will be far easier and quicker, for me at least, to use Bootcamp on my Mac or my work laptop...or sort out my remote desktop access....which will incur a cost - something I am trying to avoid.

  • (This is for future people searching for this topic. I don't want CC3+ to come across as anything but stable to those looking in from the outside.)

    1. Yes, it was exactly that straightforward for me.
    2. The "tin" never promised WINE.
    3. CC3+ has been very stable for me in a few different situations including WINE on a Macbook. Actually, it's been 2 Macbooks, since I migrated CC3+ to a new model recently.

    Again, this is for future people searching for "CC3 in WINE." It works well for me.

  • edited March 13

    @Kertis Henderson

    You misunderstand me (refer to my intial post).

    I have absolutely no issue with CC3+ (other than it is not a cross platform application😉) and have used it for commercial and personal projects, as my gallery will attest, over the last four or so years. It allows me to make maps quicker and of far superior quality than anything I could produce using traditional or digital (Photoshop, Illustrator and the like) drawing tools.

    My comments refer specifically to WINE, that is the ‘stable’ version I mention. To be fair, they are a bit harsh as the WINE documentation makes it clear it may not work with all programs. In my opinion, the latest 'stable' version of WINE should include the installation of additional components, particularly those required for known issues. If it does not, there should be comments to that effect, i.e "Note: Some versions of InstallAware may generate a run-time error, if this occurs please download and install VC Runtime blah blah blah".

    As I said, I am no longer as computer 'savvy' as I once was, hence my comments. After your suggestion to download and install VC Runtime I Googled it and came across the post I linked. After reading that post, I decided that it was 'too' hard for me.

    I am currently working with our IT support company to resolve my remote access issues, which if successful, will make this whole discussion moot.

  • Out of curiosity @jmabbott , what's the WINE stable version number in MacOS Sonoma?

  • Not sure, I deleted it. but I used the latest version from WineHQ 9.something?

    I also downloaded and installed VCRUN2019 before re-installing the trial version of Crossover and got the same runtime error.

    The wife and I are away for the weekend; I’ll try CC3+ on the laptop and see how that goes.

  • suntzusuntzu Betatester Traveler

    this may be a wine problem on your computer , just downloaded and installed on my linux box under version 9 of wine without any problems

  • I was thinking something along those lines. But I know very little about Macs, so I don't know where to start helping jmabbot on this issue.

    Oh, and for the record, I haven't had the need to worry about VC runtime on linux. It's possible my distro just takes care of that, but it's worth mentioning nonetheless.

  • I have been thinking about this. I don't have VC runtime in my folder of installers, so this might not be the problem. I do see that I'm using a 32-bit version of WINE. I suppose a 64-bit version of WINE might throw this error.

  • Thankfully, my Remote Desktop issues have been sorted, so I can leave things as they are.

    Royal Scribe
  • Yeah, we get it.

    roflo1 and suntzu, would you mind sharing your WINE versions, please?

    I just noticed that I'm running wine-6.0.2 on WineskinCX 21.2.0. I think that's pretty old, actually. Maybe that's important. I'm curious about what other people use.

  • suntzusuntzu Betatester Traveler

    mine is the latest download from winehq , version 9

  • edited March 17

    Well, I'm going to say my issues were likely 70%-30%, maybe 80%-20%, user v machine. My Mac does suffer from performance issues and has done since new (my new HP mini desktop at work is blisteringly fast in comparison); I think it's time to do a complete re-install of the OS and them migrate selected APPs and data from my Time Machine Back-up.

    Part of the problem I think is that I copied my old Mac in it's entirety when I set up the new one so there's probably lots of rubbish in places I'm unaware of causing issues. I timed the startup process after a shutdown last week and it was well over 4 minutes - that's not right.

    Must've had a power outage at work over the weekend, as my work PC was off. So, to ensure I have reliable access, I installed the base CC3+ on my work laptop last night as a test and it's fine, I'll be doing the full install. Just have to get used to the smaller screen - there'll no doubt be lots of zooming in...

  • Does this version have an exe named "wine" or "wine64" or both? Which one do you use?

  • suntzusuntzu Betatester Traveler

    since i am running wine from a linux box files have permissions like read , write and execute so the system decides what to do , it does not need to know the extension in order to run a program , linux is fundamentally different from windows and macos is different from windows as well

  • I'm currently running version 9.1-1. Although, I installed CC3+ when the latest version was 7.12, and have been upgrading since.

    I use the 64-bit version. I don't think I've used the 32-bit version in a decade.

  • When it's running, go to a shell and type: "ps wax | grep -i wine" and see if it shows wine or wine64.

  • suntzusuntzu Betatester Traveler

      5947 ?    Ss  0:00 /usr/lib/wine/wineserver64 -p0

      5959 ?    Ssl  0:00 C:\windows\system32\winedevice.exe

      5968 ?    Ssl  0:00 C:\windows\system32\winedevice.exe

      6058 pts/0  S+  0:00 grep --color=auto -i wine

    these are the results

  • Thanks. So it works on wine64 then. Also, the executable name changed a bit. My knowledge is old. I learned something!

  • OK. I've had another crack at this and got the same InstallAware error.

    I'm using an iMac 27", 2019 3GHZ 6-Core Intel Core i5 processor. 16GB RAM OS: Sonoma 14.4

    Before starting I backed up my system, erased the hard drive, reinstalled a fresh copy of Sonoma and then migrated my User Account from the time machine back-up - I also took this opportunity to clean up my documents folder...

    I then downloaded and installed wine-stable-9.0-osx64.tar.xz from the Github page; double clicked to unpack it, moved Wine to the Applications and ran it. I then ran the CC3+ setup exe and got the error message.

    Is there something I've missed. Do I need to install XQuartz? The Youtube video I watched (only a month or 2 old) did not do this.

  • suntzusuntzu Betatester Traveler

    ok here is a thought , when i installed cc3+ on my linux box the linux install allows 32bit applications to run however macos sonoma is 64bit only , now crossover has some special parts in it to allow 32bit windows applications to run which would not normally run , perhaps download a trial version of crossover to see if that solves your problem

  • I did that previously and got the same result…but will try again tomorrow.

  • So.. I should clarify again that I'm very unfamiliar with Mac, but perhaps my ramblings help somehow.

    There's something off (which may be just me not knowing Mac). I'll try to guide you through my thoughts...

    I then downloaded and installed wine-stable-9.0-osx64.tar.xz from the Github page

    I web to the WineHQ page for MacOS and they recommend installing via brew(homebrew). Have you tried that? If it just so happens that the issue you're having is with a dependency, a package manager would solve that.

    The second thing that threw me off... is that (after about 10 minutes of clicking) I can't find the Github page for WineHQ. Nor a place to download the tar.gz file you mention.

  • Hi Roflo1,

    Here is the link to the Github page - you need to scroll down to verison 9.0 it's under the assets tab.

    I tried using Hombebrew previously and the trail version of Crossover (before the erasure and re-installation of the OS) and got the same error message.

    I'll just make do with my remote desktop connection for the moment; I have a commission I need to get finished. I'll come back to this once that is done.

    Perhaps I need to install XQuartz...

Sign In or Register to comment.