Very odd but persistent problem in Campaign Cartographer 3+ on Windows 11

edited September 9 in Community Support

Hey folks! First time posting.

I enjoy ProFantasy's products and have for many years. Recently I've been getting more into Campaign Cartographer 3, after having spent many more years playing around with Fractal Terrains. I recently completed a map for an RPG campaign I'm working on that I'm very happy with and which encourages me to use the program more.

However, I have suddenly and rather inexplicably run into a problem. Merely having CC3+ installed on my laptop (Windows 11, Lenovo Legion Pro) appears to cause File Explorer to crash... repeatedly. Without end. Until I uninstall CC3+.

I at first thought the problem was a graphic driver issue or possibly something that had been installed on my computer recently. But I've done no fewer than three clean re-installs of Windows 11 from scratch to no avail. The only thing that reliably, for sure removes the problem is uninstalling Campaign Cartograph 3+. And when I try to reinstall it, shortly after it finishes the installation process the problem crops up again, causing Explorer to crash until, once again, I uninstall CC3+.

This is quite frustrating and more than a bit puzzling. I can't think of any reason why CC3+ would be causing the issue, especially since it doesn't seem to matter whether it is running or not only that it is installed. In pretty much every case where Explorer was crashing, CC3+ wasn't running, not even as a background application, but nonetheless its presence as an application on my hard drive seemed to force Explorer into its recurrent crash cycle.

At the moment, the only thing I can think to do is to either install it on a completely different machine (and who knows if that would cause the same issue or not) or try partitioning my hard drive with another version of Windows or something like Linux and trying to run the program on that instead.

In any case, since this appears to be a CC3+ compatibility issue with Windows 11 or Lenovo Legion Pro hardware rather than something specific to either of those I figured I'd post here in the hopes that somebody has some idea of how to solve the problem. In the mean time, I may look about trying the above solutions.


  • LoopysueLoopysue ProFantasy 🖼️ 39 images Cartographer

    Hi Nivenus :)

    I'm not a tech expert by any stretch of the imagination, so for more detailed help you might have to wait until someone more tech-savvy arrives on the thread. But I do have a shared experience that may or may not be relevant.

    A couple of months ago I had massive issues with Explorer crashing in Win 11 and then continually failing to restart, so that all the monitor could do was flash about twice a second leaving no time for me to do anything at all except hit the restart button on the PC. It was so severe that I had to ask for help from the PF team and from the PC manufacturer to try and sort it out. (My machine is only 9 months old)

    In the end I had to uninstall a piece of third party software that allowed me to place the Start bar where I like it at the top of the screen (Win 11 is totally inflexible and places it at the bottom of the screen whether you like it or not), and prevent the optional Win 11 updates. That means switching off the "Get the latest updates as soon as they are available" option in the settings under "Updates". These optional updates are a kind of beta release (as I understand it) and can sometimes be a bit buggy.

    Since doing those two things I haven't had any problems with Explorer at all.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    CC3+ doesn't install anything that even integrates with explorer, so I am really struggling with coming up with any case where this would be caused by CC3+. Certain 3rd party programs that changes explorer behavior, like Sue mentioned, can certainly cause this behavior, but there are no components installed by CC3+ that explorer would refer to, so when CC3+ isn't running, it is like it doesn't even exist as far as explorer is concerned.

    The only "integration" that exists is the file type mapping that causes explorer to recognize the .fcw file type, displaying the right icon, and allowing CC3+ to start when you double click the file. But that is core explorer functionality, and all CC3+ really does is tell it where the executable is by giving it a text string, it isn't an actual add-on to explorer itself, and CC3+ does it exactly the same way as any other program.

    When it comes to Windows 11 and Lenovo Legion Pro, I have that combination myself (A Lenovo Legion Pro 5i [2023]), and CC3+ works perfectly fine on it.

    When you did your clean reinstalls of Windows, did you install anything else before CC3+, like a custom virus checker or something? (I have to admit, that 6 month trial of whatever Lenovo shipped with my machine went out the window almost immediately, I prefer Microsofts own, and I certainly don't want something I have to start paying on in a few months). Most antivirus software works absolutely fine with CC3+, but I am just trying to find some commonalities that could be a probable cause.

  • Interesting. Yeah that sounds super super similar, though the trigger appears to be slightly different. I do suspect a Windows update may be related since a new one was released not that long ago and it might not have installed on my system until a couple days ago. I did try rolling back to a previous version from the boot menu but it then just installed the new update right on top of that anyway so I don't know for sure if it had an effect or not.

    Yeah it's really bizarre. I honestly don't know why it would be having a problem with Explorer especially since it seemed to work fine until just a couple days ago but I do suspect somehow the most recent Windows update is involved, as described above.

    So I went ahead and gave it another try to document when exactly it begins to glitch up and cause the recurrent Explorer crash/restart/crash problem. During installation, I selected the following options:

    I wasn't able to catch a screen of the glitch because of its nature interrupting the "Print Screen" function but it began to occur as the installation said it was "removing backup files." No idea what that refers to but it could possibly be related.

    I then went ahead and did an uninstall to remove the problem and watched carefully for when it stopped. It appears it stopped when it got to the stage of the installation that said "removing shortcuts." By the time it got to the next section below, I could take a screenshot again.

    Thanks for the quick replies all. I was not expecting support this quickly since it seems as though CC3+ is a pretty niche product! But I appreciate it.

  • LoopysueLoopysue ProFantasy 🖼️ 39 images Cartographer
    edited September 10

    You're welcome :)

    We're usually around the place quite a lot.

    Was everything ok once you finished installing it?

    EDIT: Stupid question. I wasn't really all that awake when I asked it. I take it you haven't yet managed to install CC3+?

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Did you try rebooting your computer after the installation to see if the issue continued after that? I obviously have no idea why this is happening to you, but if something is being done during installation for some reason causes explorer to start crashing, a reboot will at the very least restart every part of Windows.

    You should also contact customer support through your registered user pages. Maybe they'll be able to work out something with you, like trying an alternate build of the installer.

  • Jeff BJeff B Betatester 🖼️ 37 images Surveyor

    Have you tried doing a disk check/repair? This sounds like a bad directory structure or bad location on the drive or SSD that keeps being written to.

  • Nope. Haven't been able to install it yet without the issue.

    Restarting was the first thing I tried, before anything else, since I was hoping that would fix it. But nope.

    The idea to contact customer support is a good one though. Thanks.

    I did look into a System File Check, but it didn't pick up anything. Haven't tried a disk check though so I'll give that a look.

    Thanks for the continued feedback folks.

Sign In or Register to comment.