Tool control background fill color

MavrykGMMavrykGM Newcomer

I am brand new to using the software. When I load a new Overland map the interface control background fill color is beige (see image_1). When I load a new Dungeon map the interface control background fill color is too dark to actually read the text (see image_2). Tooltips also use the same color, which makes learning quite challenging.

Is there a setting somewhere for this, or is this something for which I should contact support?


Answers

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    At first I was going to suggest that it might be just the View Window colour setting, which you can get to via the View menu, but I tried setting mine to black and the coordinate window remained white. I don't think I've ever seen that before, so unless Remy (Monsen) knows what it is I would suggest contacting Tech Support.

    I would give Remy time to look at this first though.

  • MonsenMonsen 🖼️ 45 images Cartographer Administrator

    Looks like the display have been corrupted somehow, this is not normal.

    Does quitting and restarting the program help (it should automatically reload the last open map)? If so, you have a workaround, but you should probably still contact support.

    Loopysue
  • MavrykGMMavrykGM Newcomer
    edited December 2020

    @Monsen No, it does not. Also, I went to the View Window Color after reading @Loopysue response (just to see what it was, from her statement i knew it wasnt right for the situation) and when I click it nothing happens, so I'm prone to believe something is corrupt.

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    Remy is right.

    Just as a side note here - the view window colour setting requires input from the user to do anything. You have to give it the number of the colour you want from the palette. For example 15 is white, and 0 is black. I wouldn't worry about that right now though, since the view window colour isn't anything to do with the real problem.

    MavrykGM
  • MavrykGMMavrykGM Newcomer
    edited December 2020

    I also tried repairing all the individual components to no effect, unfortunately.


    As a side note, why does it matter which "template" I use? It seems that all the objects I would place are available if I click the Dungeon Menu while in an Overland template, no?

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    While it is true that you can get hold of any symbol set you want from any map file, a template is more than just a collection of symbol catalogues. Each template has it's own sheets and effects and its own layers. The drawing tools specific for that kind of map are also linked with the template file (though you can manually switch between drawtool sets). All the seamless textures are also readily available in the template for that style, whereas you would have to import them into a file that is based on a different style template.

    Templates might seem like they are a bit pointless to start with, but as you get to know more about the way CC3 works you will begin to understand that they are really quite an important part of providing all the tools and resources to make a map in a specific style.

  • @Loopysue I ended up submitting a tech support ticket. Thank you for both your help and your insight. I look forward to using the program - I've literally been eyeing it for years and never pulling the trigger. The Humble Bundle package was too good to pass up though, so I'm glad I finally did and I can't wait until all this is behind me. :)

  • 9 months later
  • I seem to have the same issue. @Loopysue did you get a solution from tech support?

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    @DeUsis I don't know. You would have to ask @MavrykGM. It was his Tech ticket.

    DeUsis
  • jslaytonjslayton Mapmaker Moderator, ProFantasy
    edited September 1

    The most likely problem here is that palette color 19 has been changed from its normal color to something else in that particular template. Using Color 19 for the background of is one of the colors used to draw the user interface and is a relic / feature of the days when 256-color displays were what was available. Based on the look of the buttons on the toolbar, at least one other color was changed as well (what should be the lighter color on the left edge to make the buttons raised was set darker, making them appear pressed).

    If you try to manually change color 19, CC3+ will tell you that color is one of the special colors used to redraw the GUI (16, 17, 18, 19, and 20 all fall into this category). CC3+ flat out won't let you change change colors 0 (black) or 15 (white). Color 31 is a special color used for internal work, so don't change that one, either.

    To change the colors in the current palette, use Tools>>Set Properties>>Color (or COLORDLG command or click the color patch on the toolbar) to bring up the color dialog. Pick the color to change, click Define Color, and then use the Windows color picker dialog to get the color that you want.

    After changing colors in the palette, use the SAVEPAL command to save the custom palette to the current drawing.

    @DeUsis - do you remember which template had this problem?

    LoopysueJimP
  • 14 days later
  • @jslayton I'm starting to think I hooked on to the wrong topic. In my case it's the colour of the tooltip text and some unselected menu options that are in a beige or gray colour?

    I still can't seem to find how to change that though. And I'm not able to find a topic on this issue either.

    Are you able to help out with this? Should I ask my question somewhere else?

    Thanks in advance :)


    ps: Apologies for the slow reply, I didn't see i had replies until just now.

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    Have you tried closing and reopening CC3? If any of the palette colours have been edited that will reset them all to default, or to the palette attached to the style template.

  • Hi Loopysue! Thanks for replying :)

    Oh I have, several times. Today I updated to the public beta, hoping some settings would be overridden.

    I thought that maybe changing the value in -Pick cursor aperture- would do something, but alas. Also tried checking that off, restarting the program; no difference. tried that several times with different values.

    Every map i open gives the same colour in the tooltip.

    Any ideas? :)

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy
    edited September 15

    Could you open your colour palette and show us a screen shot of it?

    To do that you click the colour swatch in the top bar. This is the colour palette I am working with right now in the Marine Dungeon style. It is a little different to the one you will have, but the important colour is colour 0 (zero), top left. That one should be black.


    DeUsis
  • Is this the same palette throughout the whole program?

  • I'm going to try and change the topleft colour now :)

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    I can see the problem straight away.

    Colour zero should be black.

    Does it go black if you click "Use Default PAL"?

    DeUsis
  • edited September 15

    YES! that did it! I selected the topleft box, clicked the Use default Pal and voila.


    Many thanks!


    EDIT: AHH this makes life so much easier. Really, thanks for taking the time :)

    JimP
  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy
    edited September 15

    You're welcome :)

    Now click the Drawing Properties button and then click the Attach to Drawing button in the dialog that appears and save the file.

    We might never know how that happened, but if you get into making your own palettes in the future those top 2 rows must always be left as they are because they affect the colours of the interface.

    In answer to your question - the default palette is used in the vast majority of templates, though there are a few styles that have their own variation of the palette, like the one I just showed you.

    DeUsisJimP
Sign In or Register to comment.