Selecting Offset from the menu doesn't work

It seems that Offset... doesn't work from the menu. Using a solution from an old 2015 post I got around this by typing in OFFSET1 into the command line. Has this been fixed and I'm missing something?

Comments

  • RalfRalf Surveyor Administrator, ProFantasy
    That's weird, clicking Offset in the menu starts the OFFSETD command for me. Which version of are you running (see Help > About). Does the same happen when switching to another add-on?
  • I'm running version 3.93 which is the latest version as far as I know. Offset works in CC3+ but not DD3.
  • RalfRalf Surveyor Administrator, ProFantasy
    If you open your dungeon menu file (dungeon.mnu in C:\Programdata\Profantasy\CC3Plus) and look for OFFSET, what is the line that contains it? It should be:
    &Offset...:|OFFSETD;
  • Yep the file contains the said values.
  • I did just recently install all the add-ons from the "Vintyri™-distributed Add-Ons for CC3+" collections. Could that have screwed this up?
  • edited March 13
    Also the command is doing something, just not showing it. As when when I hit undo it undoes something, as in it doesn't undo the guide line I'm trying to offset which I drew immediately before trying the offset command. I've also gone through every sheet to see if it landed somewhere odd with no result.
  • LoopysueLoopysue 🖼️ 9 images Mapmaker ProFantasy
    Try reinstalling the most recent update.
  • MonsenMonsen 🖼️ 12 images Mapmaker Administrator
    Note that the offset command can be a bit weird at times, it doesn't always show the result until you issue a redraw (or scroll/zoom)
  • No luck with installing the latest update, and redraw does nothing.
  • 5 months later
  • CrazyantCrazyant Newcomer
    I have the same issue as huntergreenoz - Draw -> Offset -> Offset Copy does not seem to work.

    I open a new Floorplan map and draw a simple Smooth Path. I navigate Draw -> Offset, select the Offset Copy option, specify a distance, select the path and click to one side. Nothing appears, even after clicking Redraw. Info -> List shows only the original entity.

    I tried the OFFSET1 line command with the same distance parameter, on the same map. An offset path appears after I click Redraw. It also appears when I use Draw -> Offset -> Offset One.


    I checked the dungeon menu file as advised above and the value is as specified. I am running CC3+ version 3.94. I installed City Designer a few months ago and have downloaded a number of Annual files, none recently. I am working my way through the Tome and found the issue when working through the Simple Rails example. This is the first time I have tried to use Offset, maybe I have missed something.

    The issue is not a big deal for me but I thought Profantasy would be interested that it is affecting more than one user.
  • LoopysueLoopysue 🖼️ 9 images Mapmaker ProFantasy
    Hi Crazyant :)

    I would like to see if I also have this problem. Please can you tell me what style you were using, so that I can make a similar map for myself?
  • CrazyantCrazyant Newcomer
    edited August 22
    Hello Loopysue,
    I was using the CC3 Mike Schley Overland style.

    I ran some tests with a sample of syles ....
    - Create a new map
    - Select a style
    - Accept default drawing parameters
    - Pick an easily visible colour
    - Draw a Smooth Path
    - Try Draw -> Offset -> Offset Copy
    - If no new entity appeared, use Info -> List to confirm none was created

    Results
    'success' means the offset line appeared
    'fail' means no new entity was created
    ---------
    Dungeons
    - CC3 Dungeon - success
    - CC3 Dungeon metric - success
    - Annual Jon Roberts - fail
    - Annual Naomis Floorplans - fail
    Cities
    - CC3 City Basic - success
    - CC3 Bitmap A - success
    - Annual Jon Roberts - success
    Floorplans
    - Annual Scifi Base - fail
    Overland
    - CC3 Mike Schley Overland - fail
    - Annual Worlds of Wonder - fail
    - CC3 Overland Vector BW - success
    It appears that Offset Copy generally works with styles included with a product and fails with styles from the Annual. But there are exceptions: Overland - CC3 Mike Schley fails and Cities - Annual - Jon Roberts succeeds.
    Interesting.
  • LoopysueLoopysue 🖼️ 9 images Mapmaker ProFantasy
    edited August 22
    Thank you so much for taking the time and trouble to analyse the scope of the problem, Crazyant.

    I recommend that you contact Technical Support via the last tab on your account page, and give them a link to your comment (http://forum.profantasy.com/comments.php?DiscussionID=9785&page=1#Item_12) so that they can examine your list and run parallel tests.

    While I am sure that Tech Support already know about it, they might not have seen the work you have done here.
  • CrazyantCrazyant Newcomer
    Thanks for the advice Loopysue. I have sent the info to Tech Support, as you suggested.
  • RalfRalf Surveyor Administrator, ProFantasy
    We've reproduced the problem and put it on the list of things to fix - it's a weird one. As a workaround for now, you can use the Offset One command, using Extract Properties on the entity you want to offset first. That way the new entity will have the same properties as the original.
Sign In or Register to comment.