Cosmographer Traveller Sector Import

I upgraded my CC3 to CC3+ and have the latest patch (along with the latest CC3+ Cosmographer). I tried a Traveller sector import and have noticed something strange. Some of the underlying data formats might have changed (it's been a year or more since I last imported a Traveller sector) because I don't recall having this problem before. The Allegiance codes sheet and layer is pulling in the first two characters from the Ex field in the data, the travel zones are not being added, the gas giants are not being added, and the bases are not being added. There may be other oddities, but those are the ones that jump out at me.

Cheers,

Ovka

Comments

  • 21 days later
  • I finally got this figured out. I took the Example.cfg file provided in the System/Traveller directory and modified the first two lines at the top from

    msec source = http://www.travellermap.com/MSEC.aspx?sector
    sec source = http://www.travellermap.com/SEC.aspx?sector

    to

    msec source = https://travellermap.com/api/msec?type=MSEC&sector=?sector
    sec source = https://travellermap.com/api/sec?type=SEC&sector=?sector

    Now, as log as I select that configuration file when I import the data, it works as it should.

    Cheers,

    Baron Ovka
  • MonsenMonsen 🖼️ 44 images Cartographer Administrator
    Thanks. This will be usefull for later.
  • Well, I just checked with the owner of the TravellerMap site. He said his fresh install of cc3 doesn’t require any extra work. It’s just cc3+. I did notice that if the file I specified wasn’t available, cosmographer still found a file from the TravellerMap site (right sector, wrong file format). Perhaps the issue is error checking gone awry?

    Cheers,

    Baron Ovka
  • 2 months later
  • edited March 2018
    I just tried to import Amderstun sector with CC+

    It breaks off after two messages.
    First being
    "No definition exists for: Atmosphere_V
    And immediately afterwards
    Campaign Cartographer 3 does not understand the command:
    1

    Like I said... I have CC+ (incl. COS)
  • RalfRalf 🖼️ 16 images Mapmaker Administrator, ProFantasy
    Atmosphere V is apparently that we missed when designing the Traveller Sector Import. Since it crops up only now, it seems to be extremely rare in the sector data. Does anyone know what it stands for, in the Traveller UWP data?

    To fix this yourself, do the following:
    - Navigate to C:\ProgramData\Profantasy\CC3Plus\System\Traveller\Symbols and open the catalog file Traveller.FSC in CC3+
    - Open the Symbol Manager and clone any of the Atmosphere symbols, naming it Atmosphere_V
    - Do the same to one of the Water_Planet symbols, naming it Planet_Water_V (this will crop up as an error if you only create the Atmosphere symbols).

    And there you go, the sector should import correctly now.

    Ciao,
    Ralf
  • Perfect !
    Thanks
  • In Classic Traveller, Atmosphere goes from 0 through C, no V. So the V is likely 5th edition Traveller which I don't have.

    Digit Description
    0 No atmosphere.
    1 Trace.
    2 Very thin, tainted.
    3 Very thin.
    4 Thin, tainted.
    5 Thin.
    6 Standard.
    7 Standard, tainted.
    8 Dense.
    9 Dense, tainted.
    A Exotic.
    B Corrosive.
    C Insidious.
  • pvernonpvernon 🖼️ 34 images Traveler Betatester
    I have T5, and will look it up after tonight's game. Will post tomorrow, USA Mountain time.
  • RalfRalf 🖼️ 16 images Mapmaker Administrator, ProFantasy
    Or it is just an error in that sector's data, as the Traveller wiki doesn't list a V for atmosphere.

    The culprit is the world Rainbow Sun.
  • MonsenMonsen 🖼️ 44 images Cartographer Administrator
    Yep, that world seems to be bugged. Note that on the Traveller map site, that is the only planet you cannot click on to get information on it, the infobox simply doesn't load the data. And you can search for it, but again, the infobox doesn't display the data.
  • This is sounding more and more like an adventure seed. The mysterious world that nobody knows anything about, and all the official databases are . . . mysteriously empty.
  • Posted By: taustinocThis is sounding more and more like an adventure seed. The mysterious world that nobody knows anything about, and all the official databases are . . . mysteriously empty.
    Sounds like a good idea. I came up with several additional government types for my ATU. ( Alternate Traveller Universe)

    I also moved my Starship Wanderer, bussard ramjet starship, to my Traveller site. Cubic miles in size. Why you could park the Starship Enterprise in the docking bay. :-)
  • 3 months later
  • AndyStaplesAndyStaples Newcomer
    edited July 2018
    I've discovered an issue importing Gvurrdon and Reft Sector - the state borders draw properly, then ALL the worlds are drawn on the lowest left hex.

    Using CC3+, .Net 4.7.

    Does anyone have any idea how to fix this (other than drawing the sectors manually).
  • pvernonpvernon 🖼️ 34 images Traveler Betatester
    Andy, unless you really need to build the sectors from scratch, go to programdata, profantasy, CC3Pluse, examples, cosmoghrapher, Traveller charted space.
    There you will find all of the sectors in charted space.
  • RalfRalf 🖼️ 16 images Mapmaker Administrator, ProFantasy
    I think that's what Andy is trying to do - importing either of those sectors into CC3+ via the sector import.

    I can reproduce the problem, but I fear it's something in the data from those sectors that doesn't mesh without import utility and it's not something that I can quickly fix.
  • Hi pvernon - the sectors in the Cosmographer examples are built with older data from travellermap.com, with political borders following the Fifth Frontier War.

    Travellermap now provides data for 1105, the Classic Traveller era, which I prefer, and has update4d and errata checked many sectors in line with the T5 Second Survey.

    So I'm building up new maps of Charted Space using the Traveller Sector Import tool.
  • pvernonpvernon 🖼️ 34 images Traveler Betatester
    ahhh, ok
  • 8 months later
  • Hi - sorry for resurrecting an old thread, but this may be an issue relevant to future issues with the sector importer...

    At present, I'm trying to import the Sector Deneb (following the tutorial step by step - and because I want the Deneb material!!!). I'm getting an error to the effect: "The sector data could not be downloaded".

    When I went digging into the example.cfg file present in the folder: C:\CC3\System\Traveller - I found these two lines to be helpful in suggesting where the problem may lie:

    Actual lines in the example.cfg file:

    msec source = http://www.travellermap.com/MSEC.aspx?sector
    sec source = http://www.travellermap.com/SEC.aspx?sector


    actual URL for the files being sought?

    https://travellermap.com/api/msec?sector=Deneb
    https://travellermap.com/api/sec?sector=Deneb&type=SecondSurvey


    I did try the url without the added part of &type=SecondSurvey - and it did find the file without issue. So - I don't think it matters if the URL reads as:

    https://travellermap.com/api/sec?sector=Deneb&type=SecondSurvey

    or

    https://travellermap.com/api/sec?sector=Deneb

    They both reach the same file and open it in the web browser.

    Is there any way to get around this issue? I am dead in the water so to speak. :(
  • jslaytonjslayton Mapmaker Moderator, ProFantasy
    Make sure that you download the most recent CC3+ update from the ProFantasy website. Some work was done on the Traveller sector importer in October 2018 to resolve these issues, if I recall correctly. I was able to import the Deneb sector and generate a map from it.
  • 2 years later
  • FrostvargFrostvarg Newcomer

    And if i want to get the map for a different setting like the 1248 setting. How would i edit the scriptfile then?

Sign In or Register to comment.