The latest CC3+ update is 28 (version 3.98, released June 1st 2022). Download it from your Registration page.

Forgotten Realms and Win 10

Any known issues between the forgotten realms atlas and Windows 10.

I am trying to install it on my new laptop, and the setup just starts, then error message, no install dialog or anything.


  • I don't know if the things works under Windows 10 or not, but two things you should try:

    1) Temporarily turn off your anti-virus program. (Stay out of the Internet while it's off!)

    2) Run Setup as an Administrator.
  • MonsenMonsen 🖼️ 46 images Cartographer Administrator
    Except for what Mark said above, I don't know what could be wrong, but I do know it runs fine under Windows 10 though.
  • edited January 2016
    One simple fix to all these issues, which has been an issue since Windows Vista, is to not install anything on the windows default folders.

    Windows, since Vista, has placed read and write restrictions on the Program Files(x86) and the Program Files folder. Most programs during installation attempt to create their binaries/executables in these default locations. However, when you save your work, if the program saves it to those default locations then permissions issues arise and it creates a mess.

    The most efficient way to install all your programs and not have these issues are to do the following.

    1. Create a folder that you will use for the installation of all your software (this is a replacement of the Program Files folders). I call mine utilities and keep it outside of the system drive (c:) so mine is E:\utilities.
    2. Always install your software by right clicking it and running as administrator.
    3. At the time the software asks you where you want to install, select the folder you created on step 1, and append the specific software name (e.g., e:\utilities\ProFantasy\CC3)

    That's it. From this point on software that you install will never collide with the built-in Windows UAC.

    Hope that helps.

    NOTE: On my machine I have all my ProFantasy software on those folders and I've never encountered any issues.
  • I certainly have to agree with Dkarr. I do the same. The program files folder was a great Microsoft idea that seldom is implemented properly. The result is that many users of many programs who unwittingly install there have problems. I install all of my programs in F:\Programme (which is German for "Programs"). I never have any of these issues. The modern Windows versions also place some restriction on what one can do on Drive C, the drive of the Windows installation. That's the reason why it's often wise to install things on another drive or partition.
  • JimPJimP 🖼️ 251 images Cartographer
    edited January 2016
    I have the FR Atlas and put it outside the program files folder like I do many software installs. The headaches aren't worth putting it in that folder.


    Oops. I have Win 7 and 8.1, not 10. My post above implies I have 10 which I don't.
  • All the fonts don't display and some won't show up in Vista and up even if you have them installed correctly. (No duplicates exist, fonts are installed, & registry entries are correct and pointing to the right fonts) this is due to a change Microsoft started with XP and up regarding Font Metadata.

    The font install also doesn't work right too normally on Vista and up. (I made long post in another thread about font install issues and font problems on Vista and up and how to fix them.)
  • 2 months later
  • I couldn't get it to install. By default these days, I don't install anything in the default Windows directories, so I know that wasn't the problem. What I wound up doing was just copying all of the maps off the CD Rom onto my PCs hard drive so I can access them in CC. I don't care if I have the FR viewer program, so that worked for me.
  • Now that I'm back on my Vista desktop... I see I have the FR Atlas in a folder C:\FRAtlas outside program files. While I've looked at the maps for ideas, I haven't checked to see if the fonts installed correctly.
  • Jay_NOLAJay_NOLA Traveler
    Jim, with the FR Atlas fonts in Vista and up two issues exit with them to be aware of.

    1.) The Installer doesn't install them correctly so registry entries don't get made for them and they don't show up.

    See this thread and the posts I made on how to handle this

    2.) I mentioned the metadata problem due to changes Microsoft started to make to fonts so only Forgotten Uncial and none of the variations i going to show up even when correctly installed. Windows, is going to show some of the variations like bold, etc. The fonts are all in the same font family and Windows can't tell that they are different fonts and not the same one do to the Metadata change, which is why only one of them is going to work.

    The fix is to update the font to a newer build with updated metadata, but I haven't seen an updated version of the fonts with the metadata updated to reflect the Microsoft metadata changes regrading font families, so they will work.
  • 4 years later
  • EogenEogen Newcomer
    edited March 2021

    Sorry for the resurrection, but this post is where google goes. :)

    Find Setup.exe on your CD, set to run in Windows 7 Compatibility Mode (Right Click, File Properties -> Compatibility Tab)

    Run as Administrator (Still on Compatibility Tab)

    Double Click to run. If it runs, but nothing happens after User Access Control prompts you to allow it to modify your system, start Task Manager, and find the Process named something like Setup 32 bit installer -- should be top in your background processes.

    Right-click in Task Manager and select "Go To Details". Find the running process (it will not be using any CPU).

    Right Click on the Process and select "Analyze Wait Chain" -- it will be hanging, waiting on another process. Terminate that other process, and your installer will come up.

    Again, sorry to resurrect an old thread, but it may save someone some time. I am just happy that I saved the CoreRules2.0 and Forgotten Realms Atlas disks from two decades ago. :)

  • 5 months later
  • @Eogen,

    Your advice indeed saved me a lot of headache and time. On Windows 10, I didn't have to modify the compatibility settings, but following the rest of your advice allowed it to install and run on my Windows 10 machine perfectly. It also works for the three updates. Thank you very much!

  • 1 month later
  • @Eogen,

    Thank you for the specific instructions. Was able to get my installation completed. I too am glad to have saved my disk.

    Pleasant journeys to all.

  • @Eogen

    Much thanks for posting that info. It worked for the FR Atlas and the Dragon Magazine Archive (still trying to figure out Core Rules 2.0). I just wish I'd found it before wasting a whole lot of time. Thanks again.

Sign In or Register to comment.