Running CC3 on Mac using Wine via Wineskin Winery

Hello all,

I've successfully installed CC3 on my Mac OS 10.8.2 system using the following technique:

1. Download and install XQuartz.

2. Download and install Wineskin Winery

3. Open Wineskin Winery and configure a New Blank Wrapper
- add wine engine WS8Wine1.2.3
- add wine engine WS9Wine1.5.13 (or latest if newer version is available)
- highlight WS8Wine1.2.3 to use that engine for your CC3 wine install (we will change this after it is installed)
- choose Update under Wrapper Version to download the latest version
- click Create New Wrapper and save your wrapper as "Campaign Cartographer"

4. Open the file Campaign Cartographer wine wrapper.

5. Choose Advanced to configure your installation with the following options
- Options > Force use of system installed XQuartz instead of using built in WineskinX11 (prevents Mission Control bug)

6. Click Install Software to install CC3 into this wrapper
- Choose Setup Executable
- browse to your downloaded CC3_Install.exe and open it
- you will walk through the CC3 installer process
- at the end of the process, do not check "launch CC3 now"

7. Back at the Wineskin Advanced page, finalize the wrapper configuration
- Configuration > Windows EXE > Browse, find the fcw32.exe installed into your wine dos_device c drive. It will be nested inside Campaign Cartographer
- Tools > Change Engine Used > choose latest version, as of this document it was 1.5.13.

8. Choose Test Run
- CC3 should open.

9. Click around and go into Help. Wineskin will download and install the gecko framework to view html files inside CC3 (Help files)

I just got this up and running and will report any serious bugs and instructions to install Symbol Sets, Annuals, and expansions.


  • To install expansions such as Annuals, Symbol Sets, or otherwise do the following:

    1. Browse to "Campaign" and right click the file. Choose Show Package Contents

    2. Open at the top of the package contents folder.

    3. Choose Install Software and browse to the expansion .exe

    4. Install as normal.
  • I love you man! You're beautiful!
  • RalfRalf Administrator, ProFantasy 🖼️ 18 images Mapmaker
    Excellent, thank you very much for posting your experience.
  • 4 months later
  • First, thank you sturtus for your excellent instructions. They've worked flawlessly for me for a while.

    Today, though, I've been struggling to install the 2012 Annual . . . and consistently failing. The InstallAware program starts up well, but when I click on Next, instead of receiving the license page and a chance to input my serial number, I get External Exception 80000100, then a series of Access violation errors. I'm wondering if anyone else has had similar problems and, if so, how you've resolved them. I'll keep working at it myself, and if I succeed I'll post the steps that led to my success, but I'd definitely be interested in others' experiences.
  • I have found a workaround: I set Wine to use an earlier engine (1.3.?; I'm afraid I can't remember which exactly, but a little experimentation should do the trick). With that earlier engine chosen, I was able to run the InstallAware program for the 2012 Annual without difficulty. I then set Wine back to the current engine, and all is good!
  • 1 year later
  • edited April 2014
    Excellent tutorial. Works like a charm.

    I am installing the full monty of CC3 products (CC3, DD3, CD3, CA3, Annual Vol. 1-7, SS1-4, Source Maps and TUM on Wine on a MacBook Pro 2011.

    Like stated above by jbbb, you need to change the engine for all add-ons released 2011 and later. I used current version 1.7.4 for Annual Vol.5,6,7, as well as SS4.

    Only issues encountered so far: broken menu icons (no problem) and all fonts on the example maps are messed up (probably due to system fonts, not available on Wine). All fonts are much bigger.

    Please beware the Annual Vol. 2-4 have issues in the installer with the fonts. The installer still works, but the describing text is shown in Dingbats. I guess an engine in the middle range between 1.2.3 and 1.7.4 would fix that issue, but I haven't tried this.

    I am still waiting for CA3 to download, and please note that the webdownloader version does not work on Wine. I am currently downloading the full versions ZIP (3GB) to see if that works. I will install it on the 1.7.4 engine and report back if I have any issues.

    Performance is compared to bootcamp version much better. Loading time for sheet effects have doubled and mouse movement which was a struggle on the touchpad in bootcamp is not an issue in the WINE version. Even zooming from touchpad works.

    Thx again for posting this tutorial. It saves me a complete bootcamp partition with Windows 7 (I used only for CC3). :)

    EDIT: Can't get CA3 to work. Wine crashes on both 1.2.3 and 1.7.4. Will try to create a seperate wrapper with only CC3 and CA3.

  • 9 months later
  • Hi all.

    Is this a better method than running CC3 (plus add-ons) in a virtual machine? Presently, I have CC3, DD3, CD3, SS1-4, and two annuals installed on Windows 8.1 on my rMBP running Yosemite and Parallels 10.

  • Not a better method, but if you prefer not to have a VM the solution is good.

    I am currently trying to get it to work with CC3+, but visual C++ 12 is needed for the installer, and that doesn't work well with Wine. Anyone who has had success with installing CC3+ in a Wine wrapper?
  • 13 days later
  • suntzusuntzu Betatester Traveler
    Personally i use crossover for cc3 and cc3+ , i have found it to be the best of the bunch of wine engines and has a bunch of add ons to help with difficult installers

  • 3 months later
  • Everything ok with everyone? I haven't looked at this forum in over a year and my friend Steve mentions this post in the blog today. I need to get back into CC3 again. Photoshop has taken over so much of my work as I love to sketch by hand. However, CC3 saves a lot of time for mapping.
  • 6 months later
  • I seem to have been able to install CC3, two annuals and Cosmographer 3, and everything looks great except the add ons don't show up in the Add On menu? It's there, because I can load menus using the Menu... command, but just wondered why it's not recognizing what is installed?
  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    edited November 2015
    Make sure your installation is up to date with the latest update, then run CC3MenuConfig.exe in your CC3 installation directory. Note that running this file does not provide any feedback, you just have to repoen CC3 to check the results.
  • Have you reinstalled the latest update after you installed the add ons? You always run the latest updater even if it is installed as often needs to add extra files for the add ons. It may need to uninstall the update first, if so just reinstall it.
  • edited November 2015
    I tried running the latest CC3 update last, then the CCMenuConfig.exe. That gives me the a log with this error:
    err:module:import_dll Library MSVBVM60.DLL (which is needed by L"C:\\Program Files\\ProFantasy\\CC3\\CC3MenuConfig.exe") not found
    err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\ProFantasy\\CC3\\CC3MenuConfig.exe" failed, status c0000135

    Looks like I need a library?

    EDIT: Ran Winetricks vb6run. and reran CCMenuConfig.exe. No errors. Everything is perfect now. Thanks.
  • 3 months later
  • Here's how I solved the Visual C++ 12.0 error:

    (a) Start Wineskin from inside of the newly created Wine wrapper
    (b) Go to Tools, choose Winetricks
    (c) Press the Update Winetricks button
    (d) At the top type xml in the search, expand the dll group and put a check in msxml3, then click Run to install MS XML Core Services 3.0
    (e) At the top type vcrun in the search, expand the dll group and put a check in vcrun2013, then click Run to install Visual C++ 2013 libraries
    (f) Now install CC3+ using the guide posted at the top of the thread

  • 8 months later
  • Thanks Pion!

    I also found that on my El Capitan Mac that there was a black box that followed the hover mouseover tooltip. I was able to resolve this in the latest version of Wine Engine 1.9.21:

    1. Browse to "Campaign" and right click the file. Choose Show Package Contents

    2. Open at the top of the package contents folder.

    3. Choose "Advanced"

    4. Choose "Set Screen Options"

    5. Check ON "Use Mac Driver instead of X11" and "Use Direct3D Boost (if available)" and click Done

    6. Check OFF Options > "Force use of system installed XQuartz instead of using built in Wineskin X11" and "Force use of wrappers quartz-wm for window decorations and not what is on the system".
Sign In or Register to comment.