How do I stop lines from bitmap fills?

I am using Cthulhu City. The style just uses colored bitmap fills. Most of the time it is fine, but not with the forest. Those have very noticeable gridlines from it repeating the bitmap tile. The other fills also do this, but you usually cannot notice. Is there a way to minimize that in appearance?


  • LoopysueLoopysue ProFantasy 🖼️ 39 images Cartographer

    Do you have a screen shot of what you mean?

  • You can adjust the fill scale to be larger, and/or add a blur effect. The forest fill isn't really intended for large areas of course, given this is for a 1920s-1930s style city map, so you could also try drawing the forest areas in smaller patches.

  • Blur works, but it messes with some effects. I can play around with it.

    In any case, here is what I am talking about to see if there are other suggestions.

  • LoopysueLoopysue ProFantasy 🖼️ 39 images Cartographer

    I think Wyvern has the answer above. Draw the forest in smaller patches and increase the scale of the bitmap fill. You do that by opening the Fill Style Properties dialog (click the status bar where you see "FS:...."), pick the Bitmap Files tab, then find the fill you want to scale up in the dropdown box. The scale in the hieght and width boxes is in map units, whether that happens to be feet or metres.

    Don't scale the fills up too much or you will end up with pixelation, which is where the fill shows it's pixels as squares.

  • JulianDracosJulianDracos Mapmaker
    edited January 26

    So if I change the scale in the bitfmap fill then it will change it for the tools as well? I thought it only affected the polygon fills.

    Interesting enough, simply turning off the scale pretty much solves the problem. Looks fine with I think only one spot with a partial line that you can only notice when you zoom in.

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer

    Yea. The tools are only a quick way top draw polygons using the fill, but they are just the same as regular polygons and affected by changes in the fill setting the same way.

    Note that by turning OFF scaling, it means CC3+ won't keep a consistent scale between zoom levels, and screen and export. With scaling off, what looks nice on screen may not look as nice on export.

  • Good to know about how scaling works. I exported a map to check, and it looks fine. Thankfully, the actual size of the tiles is 4 times the size of what the default scaling is on the map so they are well suited for the size of map I am using with the scaling turned off.

Sign In or Register to comment.