Custom Toolbar Buttons issues

Hello,

I started working with CC3+ recently and still learning basics. To do so I'm following "Hanin's Chapel - A Cartographer Annual 46 Tutorial" by Joachim de Ravenbel.

The author sets some custom buttons for the toolbar related with some macros added in a custom version of Fcw32.mac file (namely myFcw32.mac) and with some Icons in .bmp format, the first put into the C:\ProgramData\Profantasy\CC3Plus folder, the latters put into C:\ProgramData\Profantasy\CC3Plus\Bitmaps\Icons folder. Then I modified the dungeon.mnu file with the rows referring to the toolbar buttons as in the following example:

#27,#Bitmaps\Icons\CONS.bmp:[Construction sheet/layer]{}|MCONS;

Filename and path are correct, button squares appear, macros onclick work, but the bitmap is not visualized (every new button is blank). I also tried to create different version of the .bmp following an advice found on this forum and so now I have CONS.bmp, CONS24.bmp, CONS32.bmp and CONS48.bmp in the Icons folder, but still nothing, it only works with "standard codes" as for example:

#27,PERIWALL:[Construction sheet/layer]{}|MCONS;

Any advices? Maybe I missed something

Thank you very much in advance,

Regards

Comments

  • MonsenMonsen Administrator 🖼️ 46 images Cartographer
    edited January 22

    The issue is probably the #-character, which refer to the installation directory, you want the @ which refers to the data directory, like this:

    #27,@Bitmaps\Icons\CONS.bmp:[Construction sheet/layer]{}|MCONS;

    (@ was new with CC3+, which means older instructions use # because everything was in the install directory then)


    And yea, you also need those number suffix files, those are for different toolbar sizes.

    Cenere
  • JimPJimP 🖼️ 274 images Cartographer
    edited January 22

    Hmmm... I'm not sure, but you might try typing

    ffix on the command line and pressing the enter key.

    If you get a list of path updates, it was needed. If you don't get such a list, the problem is something else.

    If you get the list, save the map,exit the program. Then load it again.

    Cenere
  • Hi, thanks for helping.

    Problem solved🙂

    After replacing "#" with "@" some of the buttons became visible, some did not.

    Then I investigated why: I noticed that the dimension of "not working" bmp was different and bigger than "working" bmp, so the issue was related to the online tool I used to rescale the custom 16x16px which was adding some "unrequested content" to the converted files.

    After few attempts I found a converter without this problem and everything worked out.

    Thank you for your time.

    JimPRalf
Sign In or Register to comment.