The latest CC3+ update is 28 (version 3.98, released June 1st 2022). Download it from your Registration page.

FT3 to CC3+ - issue with changing the Fill Style of a landmass

Hi everyone,

Newbie mapper here! Sorry to bother you with this issue I'm facing right now.

So I followed the amazing tutorial on youtube (https://www.youtube.com/watch?v=ZuhB_LXr3Sg) and I've been able to create a couple of overland maps with this tecnique: it worked like a charme.

Now...I'm stuck with a map that keeps crashing my CC3+ instance each time I try to use a bitmap in a Fill Style

  • I've attached the ".fcw" exported from FT3 so everyone can test it.
  • I've exported the "view" using the "Coastline Only" preset in FT3 cause I don't need anything else.
  • The attached map is as it comes out of FT3.

To reproduce the issue:

  1. Explode the object to get from a Multipoly to a Polygon
  2. "Change properties" => select the bigger landmass and change its Fill Style to any bitmap you want, like "Grassland bitmap".
  3. CC3+ crashes


Is it a problem of my computer/installation?

Is it a problem in the object I'm trying to fill? Is it something that can be fixed? So I know what to do in the future.

If you need more information, just ask and I'll reply asap.

Thank you so much!

------------------------------

FT3 v.3.0.21

CC3+ v.3.98

Comments

  • jslaytonjslayton Mapmaker Moderator, ProFantasy

    There are likely some cusps in the polygons that are confusing the CC3 bitmap rasterizer. Try using SIMPLIFY 1 on the problem entities before changing the fillstyle to reduce the number of nodes without significantly altering the appearance of the paths (SIMPLIFY 0.1 might also work, but I didn't try that).

    FT3+ automatically includes a "SIMPLIFY 0" equivalent during its exports to reduce the likelihood of this sort of problem.

    arsenico13
  • Oh yes! Thank you so much!

    That did the job!

    I'll remember this trick in the future, thank you!

Sign In or Register to comment.