The latest CC3+ update is 28 (version 3.98, released June 1st 2022). Download it from your Registration page.

How to fix a botched map resize?

roflo1roflo1 Surveyor

When I want to resize a map, I usually do a manual stretch on the SCREEN, MAP BORDER, and BACKGROUND layers (late edit: meant to say sheets). And every now and then, I manage to break something.

For instance on my current map, even though I do have a properly sized 2D polygon on MAP BORDER, tools configured to Restrict to map border will not respect my intended map border.

I do seem to recall that there are some special entities (2D points and lines, IIRC) but I'm still not sure what they actually accomplish (or if they're just a thing to be used on templates).

I don't know if it helps, but this is the result of Info->List on MAP BORDER:

fslod entity: color 0 (black) layer 0 (MERGE)
  line style 0 (Solid) fill style 0 (Hollow)
  line width 0.00000 tag # 0 pen 0.000 mm 2nd color 0

+--Sheet: MAP BORDER ----------------------
|
|2D Polygon: color 0 (black) layer 257 (MAP BORDER)
|  line style 0 (Solid) fill style 0 (Hollow)
|  line width 0.00000 tag # 11520 pen :0.000 mm 2nd color 0
|  smoothing method: No Smoothing
|  start parameter 0.00000, end parameter 4.00000
|  length 297.00000, area 4567.50049, with 4 nodes:
|    node 1 at 0.00000,0.00000
|    node 2 at 0.00000,105.00000
|    node 3 at 43.50000,105.00000
|    node 4 at 43.50000,0.00000
|
|~unknown entity type=4 xp=-24572 xt=6: color 0 (black) layer 0 (MERGE)
|  line style 0 (Solid) fill style 0 (Hollow)
|  line width 0.00000 tag # 0 pen :0.000 mm 2nd color 0
|
+-----------------------------------------

How can I fix my map's borders?

Best Answer

  • MonsenMonsen 🖼️ 46 images Cartographer Administrator
    Accepted Answer

    Looks like your dungeon menu file isn't properly up to date. I have that option with the Naomi dungeons. Try running the latest update again (In any case, the command isn't restricted per style, you can always just switch to another menu temporarily.)

    As for your map, your MAP BORDER layer is spammed with entities. All those green, purple, and orange shapes are on that layer. They're the ones messing up the restrict operation.

    roflo1Loopysue

Answers

  • My map border, on my currently open map

    Shows the color 2 is on sheet background, and the later Map Border.

    It is in 4 parts, one per side. So those can be moved to make the Map Border larger. If this means they are no longer touching, that needs to be redrawn.

    Or re-drawn to make it larger.

    If you do the later, I would make a construction layer, and make the larger area. Then once you are satisfied with the new map border, erase the old one, and move the new one over to the Map Border layer.

    Yes, I have had to do this before...

  • LoopysueLoopysue 🖼️ 35 images Cartographer ProFantasy

    I can't say if this is one of the issues or not without seeing the FCW, but before you scale lots of things all at the same time on key sheets like that, check that the layers they are on are not frozen.

    Resize Drawing Area in the File menu should do the job automatically next time you need to do the same job.

  • Thaw all layers is what I try to remember. I don't always.

  • roflo1roflo1 Surveyor

    I'll try to follow up...

    It is in 4 parts, one per side. So those can be moved to make the Map Border larger. If this means they are no longer touching, that needs to be redrawn.

    I'm not sure I follow. I do have a single closed 2D polygon on my MAP BORDER, and I can see that it is indeed placed as I want it.

    I can't say if this is one of the issues or not without seeing the FCW, but before you scale lots of things all at the same time on key sheets like that, check that the layers they are on are not frozen.

    Yeah, I did thaw the layers beforehand. It's not hard to see visually if everything went ok. The hardest entity would be the Screen/Collar, but since I can change the window color, it's not much of a problem.

    Resize Drawing Area in the File menu should do the job automatically next time you need to do the same job.

    Ah, the thing is... not all styles offer that option. I'm currently working with Naomi's Dungeon Floorplan. Unless there's something wrong with my installation, it's easy to replicate; just create a blank map using that style and you'll see.

    This is my File menu for the relevant map:

    And this is what I see for a Schley map:

    I did try to create the "Resize" map note (with a value of "STRETCH") in my Naomi map, but the menu option still doesn't show.

  • roflo1roflo1 Surveyor

    Another update and test case.

    Here's a simplified FCW of the map I'm working on around the first time I stumbled into the problem (I removed a bunch of stuff, to make it easier to showcase the problem I'm having):

    If you want to give it a try, open any drawing tool that is set to Restrict to map border, and give it a go.

    For the following screenshot, I chose one of the Wall tools (since it's just a black line) and as you can see, it's restricted to a square in the middle:



  • MonsenMonsen 🖼️ 46 images Cartographer Administrator
    Accepted Answer

    Looks like your dungeon menu file isn't properly up to date. I have that option with the Naomi dungeons. Try running the latest update again (In any case, the command isn't restricted per style, you can always just switch to another menu temporarily.)

    As for your map, your MAP BORDER layer is spammed with entities. All those green, purple, and orange shapes are on that layer. They're the ones messing up the restrict operation.

    roflo1Loopysue
  • roflo1roflo1 Surveyor

    Ah, yes.

    Yet another time I confuse layers with sheets!

    You're a lifesaver!

  • My most recent map, the green lines for the map border are 4 separate pieces. In other maps they are one piece.

    roflo1
Sign In or Register to comment.