The latest CC3+ update is 28 (version 3.98, released June 1st 2022). Download it from your Registration page.

Ferraris Style; Ramparts Not Working

In this style, there are two ramparts. Level one works fine. It seems to be drawn on the Dyke base sheet. Rampart 2 is drawn on the Rampart sheet. When I use the rampart 2, it has a pitted effect. It looks like worn stone that has been shot at. At first, I thought this was intended. But when looking at the The Village of Greythorne sample file, this does not seem to be the case. I want it to work as per the sample file.

The only difference I could find is that the sample file uses Paper Lo while mine uses Paper Hi for the fill. I have changed it, but no change. I have changed the fill from paper to mud and it still has the occasional dent in it. If I turn off the effects, I see the fill style correctly so those files are correct. Presumably, this has something to do with the sheet effects.

I checked and everything is set the same. I even just copied the sheet effects over just to make sure, and it is still an issue.

Finally, I see what has happening, but I do not know why. When it draws the ramparts, a lot of black dots are added. The bevel is indenting all of those black specs. I have opened up the paper files and none have black specs. As far as I can tell, the settings on the ramparts drawing tools are the same. I can also draw correctly on the sample file.

So I am at a loss as to what is causing this or how to fix it. I have attached the map file just in case someone thinks that would be helpful. I made a large rampart 2 that has the pitted effect.


Tagged:

Comments

  • LoopysueLoopysue 🖼️ 35 images Cartographer ProFantasy

    There may be another difference here. In Greythorne there is a polygon of water between the two rampart levels, which effectively resolves the transparency acne you are seeing as the pitted effect.

    As a quick cheat you can copy that pitted polygon to the WATER sheet and just leave it as it is. You don't even need to change the fill. It should do the trick for you.

    ...

    A note on that HI and LO file name difference - those are just different resolutions of the very same texture, used at different zoom levels.

  • I do not think the water has anything to do with it. I can draw on the sample map and it works correctly.

    I am not sure what you mean by copy the pitted polygon. I have nothing to really select. I did not move the rampart to the water sheet. It kept all of the black dots.

    As an interesting experiment, I used the paper fill and just drew a polygon on that rampart sheet. It behaved just like as if I used the tool. I then switched and drew a polygon on other sheets. All of them contained black dots.

    I switched the fill from CA 158 Paper to another paper fill for a different style. That worked correctly.

    So my guess is that this has something to do with the paper fills, but they seem perfectly fine when I open them. Although if that was the case, I would think the sample map would also draw incorrectly.

    FYI, I have also tried making a new map and it has the same issue.

  • LoopysueLoopysue 🖼️ 35 images Cartographer ProFantasy
    edited June 11

    When I opened your map I saw the pits as you described them

    I copied the pitted polygon to the WATER sheet by right clicking the hourglass and using the "Copy to sheet" option to copy it to the WATER sheet.

    And got this result.

    All it does is add a backing to the overlying polygon to separate it from the underlying one. Normally you have to then go and change the copy to be a solid colour that isn't in the texture, but it seems to work fine without that.

    JulianDracos
  • LoopysueLoopysue 🖼️ 35 images Cartographer ProFantasy
    edited June 11

    Transparency acne (the pitting) happens when the same or similar textures are used on top of one another on different sheets and the overlying sheet has either an Edge Fade Inner or one of the bevels on it. The rendering engine finds the edges of the polygon on the topmost of the two sheets by comparing the pixels with those underneath it. Where those pixels are the same it interprets an edge. So if the pixel in the top polygon is the same colour as the underlying one the rendering engine sees a pinhole, and will apply the sheet effects to the edges of that hole. It looks particularly bad with this texture because there is quite a pronounced bevel effect on the upper sheet, which is being applied to all those little pinholes right across the polygon.

    The reason these pinholes tend to shift around as you zoom in and out is because CC3 is switching between the different resolutions of the textures and the pinholes will appear in different places on the different resolutions where different pixels suddenly match colour and others become different again.

    The copy polygon is a backing sheet to separate those two to make sure the pixels don't match. Normally, and logically, you then use change properties on that copy to make sure it's a different colour so that none of the pixels match, but sometimes a straightforward copy is all it takes

    JulianDracosJimPWyvern
  • Weird. I got that to work. Also, if I just draw water then it works as well.

    Since people are likely to put rampart 2 on rampart 1, then perhaps there should be some note added to the PDF for the annual? I haven't run into this before. I can actually see the pitted texture possibly being useful, but not here.

    Loopysue
  • I can actually see the pitted texture possibly being useful, but not here.

    Unfortunately, as Sue mentioned, the appearance of the acne-pitted texture changes as you zoom in or out to the map, and you may find too that it appears different again when you prepare an exported image (resolution-dependent). This makes it difficult to rely on this appearance when drawing maps.

    JulianDracosJimP
  • But I do think that one of the mountain bitmap fills, which is basically bumps of different shapes in the fill, is an excellent idea.

Sign In or Register to comment.