Problems uploading to Gallery

edited February 19 in Site Matters

As mentioned when I posted the maps for my contribution to the Community Atlas 500th-map contest, I intended to upload higher-res images of the various maps to the Forum's Gallery. However, I've run into serious problems trying to do so. I should say first of all that the maps were all jpgs, of maximum resolution 1920, and all well under the 5 MB limit each.

Initially, I tried to upload the whole set in one go, but the system sulked at me, and refused to cooperate with that at all. So I thought I'd try one at a time, and managed to load the first image fine, but when I tried loading the second, the system crashed, to the point where I couldn't even access the browser window. One restart later, another try, and the same thing happened again.

Then the system repeatedly failed to load the next image file, and while I was typing in these notes for a fresh Forum topic, the system glitched on me, I lost part of my draft, but the image that wouldn't load was suddenly in-place!

I've since tried - and repeatedly failed - to upload another image. The two images the system's struggled with were 2.98 MB (eventually loaded) and 3.32 MB (refused). Smaller than about 2 MB, and it all seems fine though, as files below that have gone through both before and after the problem files. Continued experimentation suggests the system isn't handling anything above 3 MB at all, and has only accepted that one file above 2.75 MB now.

Obviously, it's possible it could be my system, but I don't have any upload or download limits in-force, though it's conceivable the system's simply having an off-day.

By resizing the files to 2.7 MB or below, they now seem to upload OK.

If this is a general problem though, maybe the Forum guidelines about the maximum limits on Gallery images need revising, as 2.7 MB very obviously isn't 5 MB!

Comments

  • LoopysueLoopysue 🖼️ 16 images Mapmaker ProFantasy

    I have images in my 5MB city album that in one case download as over 6MB. I don't understand that one, since it was less than 5MB when I uploaded it here. There seems to be some kind of conversion going on when uploading/downloading.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    I just uploaded a 5MB image now to my gallery, as well as several other large images and those went through just fine. Very difficult to comment on anything beyond that. I'll keep an eye out, but unless I can replicated it, it gets a bit difficult to fix.

  • I had wondered if it was something to do with yet another recent Windows update, as I had File Explorer crash on me a few days ago after one, and that's something that was happening repeatedly after an earlier Win 10 update sometime last year, I think.

  • Win 10 updates for the past 6 months have some serious issues. i.e. broken patches.

  • Well, this gets weirder and weirder. I now have three copies of one of the images in my Gallery, none of which is larger than 0.5 MB! I can't even tell which is which, or when they were uploaded either!

    I've managed to work out which one of the three to save, and deleted the other two, but this seems extremely odd.

    Win 10 updates have been a constant worry Jim, I know.

  • 9 days later
  • edited February 28

    Same problem again right now. Tried and repeatedly failed to upload a 3.8 MB image to the Gallery. Clearly, there's some kind of connection issue here, but I can't even guess what it might be, as no one more technically savvy (pretty well everyone else, after all!) has been able to suggest anything to help.

    Tried reducing the file to 2.87 MB, but it still wouldn't upload.

    By reducing it to just 2.52 MB, it finally loaded.

    And suddenly I've got two versions loaded in the Gallery again, one of which is larger than the other! I think it's the 2.87 MB version that's loaded as well, though as I've already overwritten that one to reduce the file a second time, I can no longer tell. Binned the smaller one on the Gallery, at least.

    Honestly, this is pathetic, as the 2.52 MB file's only a marginally higher res than what I can post in the Forum. While I appreciate it may be a problem with my Internet connection (a connection which ordinarily quite happily uploads 25+ MB files elsewhere without a hitch, and downloads files in the gigabytes similarly, however), I can't really see me using the Gallery much beyond this. It's just not worth the hassle.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    For the multiple versions thing, are you sure you actually got a new error message? The error message on the page are persistent as long as you stay on the page, so if you upload one file that fails, and then try another file, the error message from the first one still stays down in the corner unless you have actually closed it. I am wondering if you just read the first error message multiple times? As long as the animated progress rectangles are in their animation the file is still in the middle of uploading.

    As for the size, can you send me one of the files you have problems with? I've been unable to replicate the problem with any of my own test images, which makes it hard to try to fix anything.

  • No, afraid not. I click the "X" to clear the error box each time before trying a fresh upload, so the message has to reappear again when the next upload hasn't happened. And this is every time the animated rectangles have stopped and the red "Upload" button has reappeared.

    Unfortunately, as I overwrite the files each time (as I have a prepared single version ready for the Gallery specifically at the 1620 res level, so I don't confuse it with any others), I don't have the larger originals any more. Even the one that eventually uploaded to the Gallery has gone, so this is the only copy of that one that exists! As that WAS one of the files that got rejected (apparently) however, that might be something to test with?

    About the only thing I could come up with might be to try with a different browser (ordinarily using Chrome), in case that's what's causing the glitch somehow, though I'm unclear as to why that should matter so strongly regarding file size, when all the other down- and uploads I've mentioned have been done using Chrome.

  • I use Firefox. Sadly, they took a bunch of things out of Firefox I happen to like.

Sign In or Register to comment.