Templates showing incorrectly

zace66zace66 Newcomer Betatester

Before anyone says I haven't read the Red X post ... I have!

I have been reinstalling CC3+ and as many extras as I can find on my new PC. Most is working 100%.

The most of the install is in good old c:\programfiles\profantasy\CC3Plus with the rest on D:\Profantasy

When trying to get overland maps working I get this...

and on closer inspection when choosing one I see this...

And yet we can see the vegetation.FSC file on the left. What might I be missing please?

Tagged:

Comments

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator
    edited February 13

    All the templates from your screenshot there are from the Vintyri Cartographic Collection, so it looks like you haven't installed that one properly. Make sure you remember to extract the zip files and not just run the install for that one, as well as make sure the files end up where they are supposed to when you unzip them, it is easy to make an accidentally extra folder in the path with the name of the zip file.

    Check the documentation and their FAQ page for some helpful hints.


    The most of the install is in good old c:\programfiles\profantasy\CC3Plus with the rest on D:\Profantasy

    What do you mean by that? You can't arbitrarily split up your data directory into 2 different locations.

  • zace66zace66 Newcomer Betatester

    Hmmm - I just installed the Bogie setup.

    Split, as in when i installed the original CC3+ as my first product I stated I wanted the install directory to be d:\profantasy

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    I assume you mean "programdata" here and not "programfiles", as I can clearly see references to c:\programdata in your original screenshots.

    You can't split your data directory like that. If you picked d:\ProFantasy as your directory during install, that's fine, but then you'll need to stick to it and keep putting everything there. CC3+ won't recognice the programdata directory in that case (it can only have one data directory), so anything you put there will be guaranteed to make red X'es, because all the templates and symbol catalogs refer to your data directory (which is d:\ProFantasy for you)

    Loopysue
  • zace66zace66 Newcomer Betatester

    but other installs dont give you an option as to where it is installing...

    And yes you were correct, I meant to type ProgramData

    So is my solution to move everything from c:\ProgramData to d:\Profantasy?

    The whole point of doing this initially was that my C: is my SSD for windows and D drive is all applications etc

  • zace66zace66 Newcomer Betatester

    AND, getting back to my 2 screen shots. The template shows that it has a red x for symbols from the vegetation FSC file, and as we can clearly see the vegetation.fsc file is where it needs to be as we can see all the symbols on the 2nd screen shot.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Other installs doesn't give you an option, because they'll automatically use the directory you chose when installing CC3+ (Simply because that's the only location it can be put if it is to work). [Unless the installer is flawed, but I know all the PF installers work correctly, and I am pretty sure the Vintyri ones do too]

    But the Vintyri stuff comes with a bunch of zipfiles wich you need to extract manually, which you of course must ensure ends up in the right place.

    I am a bit unsure about this setup of yours though, when looking at your first screenshot, it does really look like your data directory isn't at d:\ProFantasy at all. What exactly is the contents of d:\ProFantasy and how big is it?

  • zace66zace66 Newcomer Betatester

    Very odd - my first install was to d:\profantasy. Never have I asked it to autoinstall to the hidden c:\ProgramData directory.

    The profantasy directory just has 49 files and is only 23meg.

    The ProgramData\profantasy directory is a wopping 25 gig.

  • Some of the Zip files from Vyntiri I had to browse to my data folder.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Hmm.. That size and filecount basically matches the installation directory of CC3+ (as opposed to the data directory). But you don't get asked about the installation directory during install, the installer only asks for the data directory, the installation directory is ALLWAYS placed on c:\Program Files x86\ProFantasy\CC3Plus (Notice the Program Files (x86) in there instead of ProgramData, they are easy to mistake for each other).

    Did you ever manually move the installation directory to this location during a previous install? (It is possible to do, allthough it is really unnecessary, because as you just saw yourself, it is only 23 megs, so it doesn't really take up any space, even if you have the tiniest SSD in the world for your Windows install moving the install directory doesn't have any impact).

    Are you sure you picked d:\ProFantasy for your data directory when you reinstalled CC3+ this time? Or even if you picked it, maybe you got a dialog telling it was already files here so it couldn't use it and you just ignored it and clicked proceed? (Which would have caused it to revert back to the default dir).

    In any case, the data files should not be installed to the same directory as the installation files.

    At this point, since you were reinstalling, I am not sure if d:\ProFantasy is part of your install at all. You can check this by right clicking on the CC3+ icon on the desktop and choose properties, and see where it is launched from.

    JimP
  • zace66zace66 Newcomer Betatester

    No, this is a new PC and no I didnt move anything and yes, the icon on the desktop is pointing at d:\profantasy.

    Cheers Jim... i will check - but I just installed the Bogie installation which seemed to be a nice small set and not full Vyntiri. Ah well.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Did you use the most recent CC3+ installer? I did a test install using it now, and it behaves exactly as I described above, so if you did use it, I have no idea how the installation files would end up in the dir you picked instead of the data files which should go there. There isn't any option in the installer at all to specify where the installation files go, so for those ending up on d:\ProFantasy doesn't make any sense for me, especially since this is a new computer.

  • zace66zace66 Newcomer Betatester

    Probably NOT the latest installer if Im honest.

    But it doesnt explain why the symbols on the Bogie overland map are red Xs.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    As I mentioned above, all the templates in your screenshot are from the Vintyri Cartographic Collection, they're not related to the Bogie set. I don't think there is anything overland in the Bogie set, that's just dungeon/floorplan level symbols/fills. Maybe they were included in the bogie installer by mistake, or maybe you ran the wrong installer.

  • zace66zace66 Newcomer Betatester

    Which is weird as I havent installed Vintyri.

    So solution seems to be install V and all will be well - lets see :)

  • zace66zace66 Newcomer Betatester

    OK, almost sorted. Is there any way to regenerate the images in my first screenshot above - ie the previews of the map? They come up fine now when I select them.... just all the previews are incorrect

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Yea, the previews are cached. You can try to click the 'Cache all' button. If that doesn't work, you'll have to go into the folder and delete the ~BRINFO.FC$ file in there.

  • zace66zace66 Newcomer Betatester

    OK - getting there...

    the ~BRINFO.FC$ file is there in Templates\Wizard directory - where all the annuals are etc, but there is no ~BRINFO.FC$ file in the \Templates directory, where the overland map templates are.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    It may be a hidden file, make sure you show those. If that file is missing, there are no cache, which should make the thumbs show up fine, although it takes a bit longer to open the dialog

    JimPzace66
  • zace66zace66 Newcomer Betatester

    Thats what I though - but no - no hidden files and all Xs. Very odd.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Weird. I assume you are 100% certain that you are looking in the correct directory, i.e c:\programdata\profantasy\cc3plus\templates\overland maps according to your screenshot?

    And you said making a new map from one of the templates wit the "broken" preview results in a fully working map?

    And if you type opendoc @<enter> on the cc3+ command line, you do get an explorer window pointing to c:\programdata\profantasy\cc3plus right?

    Assuming all those are true, I have no idea what more to tell you unfortunately

  • zace66zace66 Newcomer Betatester

    One thing I didnt do.... reinstall it ... so I tried that...

    mutter mutter - now its working fine. Bogies initial install does have overland - and this timer it fixed it with the proper symbols in the preview!


    Thanks for all your help.

Sign In or Register to comment.