Cave Editing has Stopped Working

When I draw a cave, it puts down floors and walls. I can then go back, press E, and edit the shape. However, this has stopped working. I believe the issue has to do with sheets. I created new caves and placed the floors on a new sheet and the walls on another new sheet. Now when I go to edit, it only edits the floor. It does not alter the walls. In fact, even if I turn the floors off, I did not seem to be able to select the walls and edit them even if that sheet is the only one available.

So how can I get the edit function to work correctly again? I really do not want to have to put everything back on original sheets, edit, and then move each part back separately. That is why I created the new drawing tool to begin with.

Tagged:

Best Answer

Answers

  • Have you checked layers to see if any are frozen ? If they are, you won't be able to select them, except with list.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Also, did you change the layer? The editing only works on the correct layer, to ensure that you select the right entity if you have multiple stacked.

  • The only thing that is frozen is the grid.

    I used list. It says the cave floor is on the floor and the cave walls is on the walls layer.

    I just did another experiment. I placed a new cave down using the new drawing style I made. I can edit that one. I then tried to edit the original cave, and it only changes the floor. I think the issue may have to do with me putting a break in a cave wall for an entrance. But if that is the case, is there anyway to get it working correctly?

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    The edit feature can't handle changes like that. Once you put a break in the wall, it is no longer a polygon, but a line. It might even be more than one line if you have multiple gaps. You can delete the walls, then use change like draw tool on it to bring it back to the original state, then you should be able to edit it, but of course, the gaps will be lost and have to be recreated later. Otherwise you'll have to do with the normal node editing tools.

    JimP
  • I am willing to do that. I am having issues with the change like tool. Here is what I did

    1. Delete walls
    2. Select Change properties
    3. Click like
    4. Clicked another cave

    After I did this, nothing happened.

  • That worked and that is a very useful tool

  • What worked? I think I might have had the same problem in the past.

  • I guess clicking answering the question makes it disappear.

    Deleting the wall and then using this to redraw it: https://forum.profantasy.com/discussion/6943/command-of-the-week-change-like-draw-tool-week-8/p1

    Once the walls were intact, I was able to edit like normal.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    Clicking accept moves the answer to the top right below the question, so new readers can immediately see the answer instead of searching through the thread. It works very fine for self contained answers, but less so when the final answer just provide some additional details like mine here. It is possible to accept multiple answers though, so if a set of comments provided an answer among them, you can accept all of them to have them all appear on the top

Sign In or Register to comment.