How to fix the dreaded RED-Xs?

So, after submitting the maps for Egyptian themed adventure well before Christmas, the line manager finally got back to me and wants some very minor tweaks done; increasing the opacity of the grids on the overland maps and the dungeon maps in proper print scale, I also wanted to add a missing door to one of the dungeon maps, none of this is problematic and very easy to do but...

I recently upgraded the Mac OS to Big Sur, which unfortunately, makes Crossover 19 defunct. Deciding not to spend any more cash, I resorted to creating a dedicated Windows 10 PRO (not registered but legal, you download the ISO file from MS and install it but just don't provide a product key) Bootcamp partition on the Mac, installed the CSUAC, Bogie, Dundjinni and Vintyri stuff all apparently with no problem, took several hours.

Now when I go to edit the maps, the text is way too small and I get RED-Xs for the non CC3+ symbols.

The text I can fix, it's a bit of a P.I.T.A. but doable.

The symbols were originally just put into the User symbol folder as PNGs not created as a catalogue when I did the maps originally (a personal symbol and some of Bogies). Now, they show up properly in the catalogue window but when replacing them in the map they're still showing as RED-Xs. Help!

Tagged:

Comments

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    The reasons Red X'es show up is because you are either missing some files, as is you have forgotten to install something, or they are put in a different place than than before. CC3+ stores the path to the file in the drawing, so if it isn't in exactly the same place as before, CC3+ won't find it.

    Your descriptions make it sounds like you just winged it for your original install instead of installing them properly, which you unfortunately feel the consequence of now.

    There are a couple of ways to approach this, but it does take some work. One way is to first go into the symbol manager and then rename all the red X symbols. The reson for the renaming them is that CC3+ uses the symbol name as a key (each symbol is stored once in the drawing, and each instance just reference this) so trying to place a working symbol with the same name will just result in a copy of the old one instead of what you see in the symbol catalog. Renaming handles this.

    Then, identify the correct versions of your symbols in the symbol catalog and click on it once. You don't need to place it, but clicking on it copies the definition into the drawing. After doing this, you go into the symbol manager again, find a broken symbol, and then hit the replace button and pick the working symbol (This is why we needed to click on them in the symbol catalog first, otherwise it wouldn't be in here to select).

    Note that this method can cause your symbols to shift a bit in your map if you originally used the images directly. That is because a symbol in CC3+ is much more than just that image on disk, but it has additional properties, like the symbol origin point. When you insert a raw image, CC3+ just picks an origin point, and if this doesn't match with the actual symbol, the symbols will shift.

    Another way to approach this entire process is to start by opening up the symbol manager, and for each missing symbol, edit it, then use Numeric Edit on the red X (be aware that the edges of this red X image is a bit weird, so it can actually take multiple tries to select it with numeric edit. I recommend zooming out a bit so that the pick aperture is larger compared to the image) and then in the dialog that pops up, browse to the correct image.

  • Thanks Monsen. I'll try that later tonight. From memory there wasn't a great number involved so hopefully it won't take too long.

    Thankfully, all of my subsequent maps won't have this problem.

  • 6 days later
  • I have another problem now.

    I'm trying to save one of the maps as a high resolution print version (so it prints at the correct scale, i.e. 1 5ft grid square = 1 inch) and I'm getting a mirror image for some reason?

    Any ideas?


  • LoopysueLoopysue 🖼️ 16 images Mapmaker ProFantasy

    What are your settings?

    Can we see a screen shot of them?

  • Hi Sue, I'll take a screen shot & post them when I get home from work. The lower resolution version worked fine which is why I don't understand what's gone awry...

    I'll also try saving a copy to my hard drive rather than Google Drive which is starting to get full...

  • LoopysueLoopysue 🖼️ 16 images Mapmaker ProFantasy

    I've not seen it before either. That's why I'm all curious to see the settings.

    jmabbott
  • Hi All,

    Here is a screenshot of my settings.

    Nothing unusual there, I think...

  • edited February 17

    Do you need the antialias so high? I use 10% or 0%. With a map that big, and DPI 300, then the programme will be a little stressed, I think. Does the map need to be that big? (Depends on what you are using it for). Finally, why not tick restrict to map border, and crop image to aspect ratio. But I don't know why you Red-X out!

  • Thanks Quenten, I don't why the anti-alias is so high either...no wonder it's taking ages to render.

    That wouldn't explain the mirror image though would it?

    I'll give it a go with the anti-alias reduced and crop image set, though the 70ppi version worked fine...

    Monsen already sorted me on the Red-Xs👍️

  • Reducing the anti-alias didn't make much of a difference...still a mirror image. I'm stumped!

  • LoopysueLoopysue 🖼️ 16 images Mapmaker ProFantasy

    Yes, so am I.

    If you reduce the size enough to bring that work size down to no more than 10,000 pixels in both directions, does it still do it then?

  • jslaytonjslayton Surveyor Moderator, ProFantasy

    A vertical flip may be caused by a bad conversion from the intermediate BMP file format (the BMP format has a vertical flip). What final file format are you requesting? Try BMP and PNG to see if there's a difference.

  • Hi All,

    No idea what happened but when I reduced the resolution to keep it under 10,000 pixels in whatever direction, it printed out fine.

    Thanks for your help and comments everyone.

Sign In or Register to comment.