Is there a way to scale hatch fills?

I am using the landform style. When I try to use the rice terrain, I have to make it huge just to be able to see it. I am talking something like a 100x100 size. The rest of the terrains seem to be fine. The normal field will have a square show up in a space less than 5x5. Am I stuck drawing making it huge, then scaling it down, copy, and pasting it, or is there some function that I can use to scale it when I initially draw it?

Best Answer

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator
    Accepted Answer

    Hatch styles aren't defined as fill styles in the map, rather they are actually external drawing files. This makes it a bit more involved, but basically, you have 2 options here

    1. Scale the entity after drawing it, this will affect the fill too, since it is just entities
    2. Edit the fill file. As you can see from the drawing tool property, the fill used is "CA44 Rice". You can find this file stored under @Hatch Styles, and it is a regular .fcw file which you can open up in CC3+. From here you can just scale the contents of the file and save it. Now, you shouldn't replace the original files, that makes it difficult to go back to the original, so you should save it as your own copy with a new name in the same folder. The same applies to the drawing tool, you should make a copy of the original drawing tool (Just select it in the advanced drawing tool dialog and hit New and give it a name, this will make the new one a copy of the old.) You can now edit the color and change the fill style to use your new one

Answers

  • LoopysueLoopysue 🖼️ 23 images Mapmaker ProFantasy

    If you open the Fill Style Properties dialog and pick the Scaleable Hatching tab, then the rice terrain, you can scale the parts of the fill one at a time using the 'Spacing:' box on the sets. As an example this .25 crosshatch has 2 parts, or two sets of lines that make up the pattern.

    Here I have rescaled Set 1 to be .5 instead of .25, and you can see that one set of lines has been rescaled.

    Pick Set 2 and do the same to that one, and you have a rescaled crosshatch fill.

    I haven't used hatch fills in any of my maps, so I couldn't tell you if these changes affect the template, but maybe it would be wiser to hit the New button and create a .5 Crosshatch, instead of modifying the existing .25 Crosshatch.

    JimPJulianDracos
  • I am going to say that I did something wrong when trying this. I cannot access the Fill Style Properties from the advanced function in the terrain feature. I can only change the fill style from there. So after selecting the tool, I used Fill Style Properties from the menu up top. That did open up those options. It says the spacing was already .25. I changed it to .05. It was still huge when I draw it. I then changed it to .01 and it was still huge. So I do not think that changing the options from there is altering how big it is.

  • LoopysueLoopysue 🖼️ 23 images Mapmaker ProFantasy

    Ah. No - sorry. Just click the last little window in the properties bar across the top of the screen where it says "FS:..."

  • If you mean change it from the circiled area, that is where I changed it from. Nothing was changed in terms of the size it was rendered.

  • I was able to resize the Rice hatch symbol. It was 200x200 while all the other symbols were 30x30. However, I cannot see where I can select the hatch style to create a new drawing tool. I created the new drawing tool, but I cannot change it to use the resized file. When I go to the advanced option for the tool, and click on properties, it only gives me the option to select a different fill. It will not permit me to select the hatch style option.

  • MonsenMonsen 🖼️ 44 images Mapmaker Administrator

    The Hatch style is set in the Outline options for the tool.

    JulianDracos
  • That worked. I may need to tweak the size a little bit on the rice file. When I draw it over an area larger than 30x30 it places a gap instead of it being continuous.

Sign In or Register to comment.