Scaling Tiles

I'm drawing a house as a basic test map to get more familiar with the systems for CC3 (DD3, in this case) and the tiles in the basic set are all too big for bathroom tile. Is there a way to scale up/down the size of a floor tile? I'm not having any luck with my usual tricks. I'm basically looking for a way to, instead of having one "tile" occupy a 5'x5' space, it's instead filled by 4, or 9. Is that a thing that can be done?

Thanks for the advice.

Comments

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy

    Yes, you can scale the fill. I am assuming here that it is a bitmap texture fill you are using.

    Click the last mini window on the bar of them across the top of the app, where it will have something that starts with "FS:".

    This will open the Fill Style Properties dialog.

    Select the Bitmap Tiles tab, and then pick the texture you want to rescale from the dropdown box called "Fill Style Name"

    Once you have the fill picked, look down a bit and you will see 3 boxes that control the scale of the fill. Make sure the first box is checked, and adjust the scale of the fill in the width and height boxes next to it. Ok and see what you've got.

    In most styles the scale is in map units, or in feet/metres depending on which template the map is based on. If you only have one tile per 5 ft square and the scale is currently "20", and you want 4 tiles per square you would need to reduce both scales to "5"

    Driechel
  • DriechelDriechel Newcomer

    Much appreciated! It looks great. As I was going through the big dropdown menu of all the textures, it looked like a lot of them weren't loading. I tried using one of them and it just pasted a big gray square with a red x in the middle. Is this a bad install, or did I forget to click on something for them to load properly?

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    The red X means that the file is missing. Could be the template that came with a few bad references, Ralf sometimes forgets to remove unneeded fills from the template. If all the drawing tools look right (All Map Drawing Tools) than that is probably the reason and nothing to worry about. If any of the actual drawing tools are missing their fill it is worth looking into.

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy

    Do you have a screen shot of the dropdown list showing which fills these are?

  • DriechelDriechel Newcomer

    That's the dropdown menu, and here's the All Drawing Tools view.

    You can't see it here, but I also have a problem where a lot of textures will look like the standard grass and dirt, like the Background Upper you see in the 2nd spot of the drawing tools menu.

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy

    Can you remember what style your map was created in?

  • DriechelDriechel Newcomer

    Originally, "Dungeon SS2A" though I think I might have borrowed the dark line walls from another source because I was having trouble making them line up with a previous draft.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    Is DD3 properly installed? All the missing bitmaps seems to be from DD3

  • DriechelDriechel Newcomer

    How would I check for that?

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    When you start a new map, in the dungeon category, do you have the "DD3 dungeon" template?

  • DriechelDriechel Newcomer

    It appears that I do not.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    Are you sure you ran the DD3 installer at all? It seems like DD3 isn't installed here, which explains the missing textures.

    Just run the DD3 installer, and make sure to re-run the latest update afterwards.

  • DriechelDriechel Newcomer

    Done and done. It looks like everything is now up to speed.

    MonsenLoopysueJimP
  • DriechelDriechel Newcomer

    Soooo

    Apparently I replaced a ton of the textures in the files I was working on with the custom bathroom tile thing that I made.

    Everything in the Dungeon Jon Roberts and Dungeon SS2B has now become bathroom tile. The floor, wall, and path textures are all marble.

    Help.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    The drawing tools will display using the currently selected fill style if the fill style they are defined with don't exist. This is typical if you have selected another drawtools style than the default for your map type, and haven't imported the required fills. I am sure that's what's happening for you.

  • DriechelDriechel Newcomer

    I drew a square with one of the textures in that other style, and it showed up as the bathroom tiles.

    I opened a new map, tried using one of the replaced textures, and it just drew an outline instead of making it into a texture.

    How do I import the files back into the styles?

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy
    edited January 4

    Hi Driechel :)

    It can be a bit confusing, so I've done a few screen shots here to try and explain how it works.

    This is a brand new DD3 Dungeon style map I've just made, and saved as DD3 Dungeon style map.

    Imagine that I have drawn some stuff on this map, but now I decide I want to add things in the Dungeons of Schley style.

    So the first thing I do is I create a second new map in the Dungeons of Schley style. I don't draw anything in it. I just create it and call it Dungeons of Schley temp map.

    And that's all I do with it. I close it then and go back to my original DD3 Dungeon style map. Once I'm there I go to the Draw menu and Insert File.

    When I get the dialog asking me which file I wish to insert I pick the Dungeons of Schley temp map and Open.

    But I don't paste the thing that appears on my crosshairs. I press ESC.

    What was the point of that? Well, the way it works is that even though I never pasted the inserted file, because it was an FCW file all the fills it contained will have been imported to the DD3 map.

    And here they are in the list of available fills in the Fill Style Properties box mixed in with the pre-existing DD3 fills. The Dungeons of Schley fills are the ones that have SS4 at the end of the name.

    I could just use those fills and draw polygons using the toolbars on the right for Polygon, Circle... you get the idea. But instead I decide I really need to draw things with the drawing tools that were made for those fills, so I open the All Drawing Tools dialog and I pick Dungeons of Schley from the dropdown list. (I think you already did this, even though it's really the second part of the process).

    The magic, though, is that because I have already primed the map by adding the Dungeons of Schley fills, all the drawing tools have their correct fills.


    This is a little bit of extra advice because I suspect you might bump into this next:

    If you click Advanced at the bottom of the drawing tools dialog and pick one of the drawing tools, then pick Properties you will see that the sheet the tool is destined to draw this fill on is named as FLOORS*

    This means the drawing tool will draw on that sheet or one that begins with FLOORS, though you can move the floor you draw if you wish once you have drawn it.

    I'm explaining this because it is important you realise that if a drawing tool names a sheet that isn't in the DD3 map a new sheet by that name will be added to the bottom of the list. You may have to move that new sheet and apply sheet effects to it. Happily, though, there is already a FLOORS sheet in the DD3 map, so I can just go ahead and start drawing my SS4 floors with my SS4 drawing tools right there in my DD3 map.

    It's a two stage process, that's all. You've already got the drawing tools. Now you just need to make that temporary map in the style with the fills you want and import it.

    I hope that helps a bit.

  • edited January 4

    I thought alternatively you could go Tools>Import Bitmaps, then go to the Bitmap>Tiles folder (eg Dungeons) and pick the folder you want (eg Dungeons of Schley), open it, Hit the first fill, and all the fills will be entered into your map, without having to create a new map. At least, that's what I do. For Drawing tools, I go to the Drawing Properties icon (to the right of the printer button on the top row of buttons) and select the drawing style from there, and Voila!

    But Sue's way does the same thing.

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy

    Yes, you can. But it is quite often easier just to create a new map if you are new to the app and don't know where everything is.

  • DriechelDriechel Newcomer
    edited January 8

    This is all excellent advice, and I look forward to using it on a map with mixed styles in the future. But, let me share some screenshots to show what's going on.

    This is what my screen shows when I pick the SS2B style on the map that started this nonsense.

    I close that, don't save, open a new dungeon map, and pick the same SS2B style, and here's what it shows then:

    For reference, I can put in other styles, but it seems I've somehow lost SS2B and Dungeon Jon Roberts. All that shows up is that blank texture, seen here applied to my map.

    When I look in Fill Style properties, I don't see anything from the SS2B styles except Default, the lone survivor of my accidental massacre.

    So...yeah. If I have to redownload or reinstall, I'd be okay with that, just wanna know if there's anything else I can do.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    If I have to redownload or reinstall, I'd be okay with that

    First of all, don't do that, it's not going to do anything for you at all.

    The problem is related to the fill styles defined in your current map. The reason those tools show up all wrong is because you don't have the required filled defined in that particular map.

    Tools are not meant to be changed on the fly like that. Every map style have it's own set of drawtools available to it, and by default, tools from other styles will not work in the map. You can work around that by importing the fill styles as Sue showed, but out of the box, it is completely normal that the tools show up there when you try to pick another style than the one belonging to the map. There's nothing wrong with the tools, it is just that the fills they requires is not defined in the open map, which makes all of them display with the currently select fill style (see top right of the CC3+ window) instead of the intended fill (since it is not defined in the map)

    If you want to use "foreign" drawtools in a map, follow the guide Sue posted above for how to import the correct fill styles into the map. Then the tools will work. And if you have deleted fills from the fill style dialog, you can just repeat the procedure to import them again.

    JimPLoopysue
Sign In or Register to comment.