Trace not selecting entity

I'm trying to make a map in DD3, and I want to trace an entity that was made with the floor tool. I used no external textures or anything to make the object.

However, when I have to select the object, it won't register as having been selected. I do not have this problem with other entities, and I can select my floor with every other tool I've tried.

Any ideas about what might be up? And if it's a bug is there an easy work around? It's for a dungeon map, and I want a snowy outside looking into an icy dungeon buried underground. The mask is to hide wall shadows on the outside of the cave (to prevent it from looking like it's on top of the snow), and to hide excess areas on the sheet with the ice effects that are overlayed over the dungeon floor.

Comments

  • MonsenMonsen 🖼️ 44 images Cartographer Administrator

    Could you be hitting another entity, such as the mask which I guess ends where the floor starts? The mask is probably a multipoly, and those can't be traced, and CC3+ isn't smart enough to try the next entity in such cases., if the first one under the cursor fails, the operation fails. Try hiding the mask and the dungeon walls.

  • Thanks, that helped, it was a multipoly. I don't think I've ever tried to trace once before, hence my confusion.

    Now I have a different problem, which is that it won't trace my shape exactly. New shapes using the same tool work fine, as does the original shape if I fractalise it. Which is an OK plan B. But as is, the cursor just makes straight lines between edges, and constructs an entirely different smooth poly.

  • One possibility is that your selection order to trace is off so the TRACE command is actually going in the wrong direction and then when you click your second point it's crossing over to create the different poly.

    A B C


    You're at point A. You select "T" to trace. When it asks which entity to trace you then click on point "B". Then your second click should be on point "C" past the point you selected to TRACE (i.e. the direction you want the TRACE to follow). This allows the tool to know which way to trace. If you click "C" then "B" then the tool traces the other way around and can draw what you are experiencing.

  • 3 months later
  • EnixineEnixine Newcomer

    I'm having this problem constantly with drawing farmland near coastlines. I'm trying to delineate a small area following the coast. Instead, the tool inevitably puts farmland down everywhere EXCEPT that area.

    Is there a certain direction favored by the program? E.g. should I be doing it clockwise? Counter clockwise? etc.

  • MonsenMonsen 🖼️ 44 images Cartographer Administrator

    The trace always goes through the point on the entity you used to select it. If it goeas around all the coast except for the section you want, it is an indication that you didn't select the entity to be traced using a place inside that area.

    LoopysueDaishoChikara
  • LoopysueLoopysue 🖼️ 24 images Cartographer ProFantasy
    edited April 2

    Enixine, if you are ending up with that situation it may be that you are clicking in the wrong place just after you hit T.

    Hit T, then click somewhere in the middle of where you want to trace, then back up to start the trace where you wanted to start it and click your second click to start tracing.

    Until you cross the point where you first clicked the section the trace will appear to be going in the wrong direction, but as soon as you cross over that point it will flip to the right direction.

    EDIT: ninjad by Remy :)

    DaishoChikara
  • EnixineEnixine Newcomer

    Hit T, then click somewhere in the middle of where you want to trace, then back up to start the trace where you wanted to start it and click your second click to start tracing.

    I got it working, though I couldn't coherently explain how. The closest explanation I can muster is:

    If the territory (of whatever shape) is approximated to a clock face (with the coastline to the north), I first click inside the territory with the Farmland tool, then tap "T", then click anywhere on the coastline to select it.

    Then I click specifically on the 2-o-clock position on the coastline to start the first point of tracing. I move the pointer to around the 10-o-clock position on the coastline and click there to end the trace.

    Now that I've completed the trace, I click through the rest of the (noncoastline) arbitrary delineations (8 o clock, 6 o clock, 3 o clock etc.). I make sure that my final few clicks are well to the east of the 2-o-clock position on the coastline, and then right click to complete the polygon.

    This works, albeit imperfectly, as there are a few vertices inside of the polygon's boundaries that appear to be non-farmland. But the important issue is that the coastline trace is successfully completed, which is what matters to me. I can always cover up the "empty slices" with trees and so forth.

    (Kludge terraforming. How government ministries of natural resources have functioned for decades!)

Sign In or Register to comment.