Help with Getting Erase to Work

I find CC3+ to be a pain in the a** but I started to watch some videos. I then realized from watching the videos at least part of the problem - the commands are not working as they should. Erase is an example of this.

For example, I make a landmass and then add some mountains or a town. I then go to erase. According to the videos and instruction manuals I have, I should click the symbol or edge of the symbol. That creates a magenta box. I can then right click and select do it. That will delete the symbol. That is not how my software works.

When I click the erase tool, it tells me to right click to select the layer. If I do that, and then click the layer and hit apply, everyone on that layer is deleted.

If I try left clicking, it displays Command [ERA]: Then nothing happens. If I click again, it goes back to the right click to select the layer.

The move command essentially operates the same. I can move everything on the layer.

I am thinking that something is set wrong. I am doing this with new maps. The style selected does not seem to matter. Any idea what is wrong and more importantly how to fix it? cc3+ is hard enough without commands working incorrectly.

Comments

  • Make sure what you want to erase isn't on a frozen layer.

  • That isn't the problem, or if it is, it is a bug.

    I just created a new map. I added land and then mountains. I then clicked on layers. I then clicked thaw all. Hit apply and ok. Erase, move, etc. all still have the same problem. I tried with cities, terrain, and roads. None of them erase, move, etc. as they should.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator
    edited November 4

    Change the settings in Tools menu -> Options -> Select Method -> Dialog or Popup. Your selection method have been changed from the default (can sometimes be caused by a macro that doesn't finish properly).

    Quicker (but less intuitive) way to fix it is to just type SELBYD on the command line and hit enter.

  • This worked. It turns out nothing was selected. Now to compile a list of other things that aren't working they should so they can be fixed as well ;)

    JimP
  • seycyrusseycyrus Traveler

    Erase has always worked perfectly fine for me.

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy

    I think that now your selection method has been sorted out, the rest should fall more or less into place unless any of the other settings have been altered.

  • There's a learning curve, but it does fall into place. Now, when I'm doing stuff with other graphics-related software, I often find myself thinking "I really wish this worked like CC".

  • Maybe it is what you start with. Everything in CC3 seems backwards and unintuitive. Too many things are hidden in right-click menus. But I know how to use other graphic programs that, while different, use the same terms, concepts, and arrangements as each other.

  • >Maybe it is what you start with. Everything in CC3 seems backwards and unintuitive.

    Yeah, what you start with is a huge factor.

    As for the backwards bit, it does feel like that because it basically is the opposite of most other software. For the most part, you select the command first and then the object(s) you want that command to do its stuff on. I thought it was weird at the beginning, but as I've mentioned I really came to appreciate it because you can do a lot of things in quick succession. Everyone is different, but if you give it some time you might have the same experience.

  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy
    edited November 5

    Well that's CAD software for you :)

    There are numerous shortcut keys once you get into it, which make life relativley easy. The most often used one for me is "D" which does the same thing as right click and Do It. (You don't have to use an upper case d. Just hit the d key)

    Other shortcut keys are mentioned in the menus, on the command line prompt and in other places too, so keep an eye out for them. There isn't a definitive list of them, since most of them are dependent on what you are doing at the time.

  • I often find it easier and faster to remember the command name and type it into the command line than to right-click the appropriate icon and select from the menu. My touch-pad mouse can get weird at times and clicking the wrong icon gets annoying. (Like when I want to Change Properties of a long list of entities and end up Erasing them instead. Sure, I can Undo it easily, but it's still annoying.)
  • LoopysueLoopysue 🖼️ 15 images Mapmaker ProFantasy

    For people who have a good mouse the buttons and menus are faster - especially if you don't have a good memory for commands.

    It depends on your circumstances.

  • I learned 3D graphics fumbling around with dkbtrace, an early ray tracing program for the Amiga computer. And, I forget the name of it, a paint program for my Amiga computer. At university we had classes in AutoCAD and a GKS ( Graphics kernal system ) written in C. We also had about five different keyboards... all claiming to be 'a standard 101 key keyboard'. The function keys, arrow keys, and the different methods for letting you know where the home row was for touch typists differed. Some had a dot, some an underline, etc. on different keys.

    But I look on the bright side of things. Back in the late 1980s, one program would use ctrl S for saving a file, another would use ctrl w for saving a file. No standardization at all. Then MS said all programs had to use the same keyboard shortcuts which was a big improvement.

Sign In or Register to comment.