Problems using Cos3 Deckplan Bitmap style

DaishoChikaraDaishoChikara Traveler
edited October 14 in Community Support

I was attempting to use the Cos3 Deckplan Bitmap style, but everything I tried to do to it acted in the following weird ways:

  • My mouse cursor disappeared from view (only while focused on the CC3+ window and over the map portion of the screen)
  • The CC3+ tooltip still showed wherever my mouse cursor was currently
  • Whatever tool or symbol I had selected seemed "stuck" at the bottom-left of the map and would not move with the mouse
  • Right-clicking during this state causes CC3+ to go into Not Responding, or just crash altogether

I did not have this issue with other styles/templates I tried. I have reinstalled Cos3 just in case, but the problem persists.

Anyone else notice this behavior before?

Tagged:

Comments

  • edited October 14

    I think snap is on. Lower right.

  • Yes, it is, but there are more grid nodes than just the one in the bottom left.

  • LoopysueLoopysue 🖼️ 10 images Mapmaker ProFantasy

    Hi Daisho :)

    What happens if you simply turn snap off?

    I have to admit that although I've had it for at least a year already, I've never had time to even open Cosmographer, so all I can suggest if no one else has any ideas is to check with you that you allowed the installer to open CC3 briefly at the end of the installation process, and that you ran the latest update again in repair mode once you had installed Cosmographer.

    It's just a stab in the dark. If you did both those things anyway I guess that unless anyone else has any ideas you might need to contact Tech Support?

  • I have no ideas beyond that. I don't think my troubleshooting skills are very good at the moment.

  • I have tried those very things, to no avail. For the meantime, I have switched to the metric style, which works fine for my purposes, but I would like to eventually have the imperial style fixed...

  • LoopysueLoopysue 🖼️ 10 images Mapmaker ProFantasy

    You could try reporting the issue to Tech Support?

  • DaishoChikaraDaishoChikara Traveler
    edited October 16

    Okay, I figured it out:

    When I first create the map after using the wizard, the grid it uses is wrong somehow. When I pull up the grid list, nothing is selected. If I select one of the grids, I can then place symbols or draw as normal. So, something bugged about the default grid settings for that style?

  • LoopysueLoopysue 🖼️ 10 images Mapmaker ProFantasy

    I don't understand what is happening there. That's why I suggested Tech Support.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    Do you have the latest update installed (and installed it AFTER you installed Cos3). I have a memory of some grid-issues being fixed in one or more of the Cos3 templates, although I don't remember which ones. But I am not able to re-produce your issue myself.

  • Remy,

    I checked all versions, and re-installed Update 25 for CC3+ just to make sure, as I couldn't remember if I'd installed that before or after Cosmographer. Sadly, no joy. It still happens.

    Just to make sure I'm providing all info about what I'm doing, I was following along with the tutorial in the Cosmographer 3 Essentials document:

    • Select "Cosmographer Deckplan Bitmap"
    • Set Dimensions to 100 Width, 80 Height
    • Enable Grid Overlay, and set the grid size to 5
    • Enable Multiple Levels and set Decks to 2

    After saving, the map opens zoomed very far out. I zoom to extents, and then try to draw the hull or place a symbol.

    What I've found is that if I right-click on Grid and pick one of the grids from the list, or make one of my own, then I can draw and place as expected. Somehow, it's got some kind of bugged grid setting by default.

  • MonsenMonsen 🖼️ 43 images Mapmaker Administrator

    I get the 'zoomed far out' behavior (looks like the zoom is set to fit the default 1000x800 map size, and don't zoom in automatically to the smaller template), but not any other issues.

    You'll probably be able to fix it by editing the actual template itself, set a snap grid there and save it.

    DaishoChikara
  • Cool. That'll give me some interesting new experience with these tools. ;-)

Sign In or Register to comment.