Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorShessar
    • CommentTimeMar 19th 2015 edited
     
    I again want to thank Mark Oliva of the Vintyri Project for allowing us to download the CSUAC art from the Vintyri website. Without his generosity the ProFantasy users would be missing a great asset of the fantasy mapping community. Thank you Mark!

    I also MUST thank the entire ProFantasy team for bringing us another wonderful program, for giving us these forums as a place to talk about mapping, and for giving us the ability to share user created content. I've never known another software company that is so supportive of their users. Thanks ProFantasy!

    --------------------------------------------------------------------------------------------
    Important Note - Working with the Data directory.

    Right now, getting the CSUAC to work with CC3+ requires a manual install into your program data folder. Different versions of windows have this folder located in different places and you may have installed it in a location of your choice. Most newer windows operating systems have it hidden. You assume all responsibility for working in this hidden folder.

    Page 7-8 of the CC3+ User Manual has a very good description on how to access the data folder. You can easily access the User Manual thought the CC3+ Help interface.

    Please become familiar with where your data folder is and how to access it before proceeding with the CSUAC installation. It isn't difficult, but it is necessary for adding all user generated content.

    --------------------------------------------------------------------------------------------

      CSUAC for CC3+ Installation Instructions


    STEP 1: Downloading all necessary files

    1. Download the file CSUAC_for_CC3+.zip from the bottom of this post and save to your Desktop or Downloads folder.

    2. Download all of the CSUAC FM8 files from the www.vintyri.org website and save to your Desktop or Downloads folder.

    The files needed are:
    BL_FM8_Fills.zip
    BL1_FM8.zip
    BL2_FM8.zip
    BL3_FM8.zip
    BL4_FM8.zip
    BL5Pt1_FM8.zip
    BL5Pt2_FM8.zip
    BL6_FM8.zip
    BL8Pt1_FM8.zip
    BL8Pt1_FM8.zip

    NOTE: There is no BL7_FM8.zip file


    STEP 2: Extract Files

    1. Unzip the CSUAC_for_CC3+.zip file.
    -Open the unzipped folder.
    - Right click the CC3Plus folder and choose copy.
    -Navigate to C:ProgramData
    -Right click on the ProFantasy folder and choose paste

    2. Unzip the file BL_FM8_Fills.zip
    -Open the unzipped folder
    -Select all of the enclosed folders then right click on them and choose Copy.
    -Navigate to C:ProgramData\ProFantasy\CC3Plus\Bitmaps
    -Right click on the CSUAC Fills folder and choose Paste.

    3. Unzip each of the files BL1_FM8.zip through BL8Pt2_FM8.zip.
    -Open each unzipped folder.
    For each folder:
    -Right click and copy all of the enclosed folders.
    -Navigate to C: ProgramData\ProFantasy\CC3Plus\Symbols
    -Right click on the CSUAC folder and select paste.



    STEP 3: Adding Menu Buttons for the CSUAC

    1. Navigate to C:ProgramData\ProFantasy\CC3Plus

    *If you don't have a fcw32.imn file in this directory

    Copy the fcw32.imn file from
    C: ProgramData\ProFantasy\CC3Plus\Menu
    Paste it into C:ProgramData\ProFantasy\CC3Plus

    * If you do have the file fcw32.imn in the root CC3 directory

    Navigate to the folder C: ProgramData\Profantasy\CC3Plus\Menu
    Open the fcw32.imn file using Notepad.
    Append (copy/paste) the contents of this file to your existing fcw32.imn file.
    Make sure you don't leave any empty lines inside the file, but do make sure there is a line break after the last line of content, or CC3 will crash on startup.

    2. Start CC3. Click the screen tools button (Hammer icon at the bottom right of the screen), and turn on "Custom icon bar 3". I have mine placed to the right.

    3. Close and restart CC3+

    The symbols are now ready for use.

    NOTE: If you have CSUAC Menu Buttons that are not showing, re-run the most recent update for CC3Plus. This should fix the issue.


    If you have any problems or questions please post below.
    • CommentAuthorJimP
    • CommentTimeMar 19th 2015
     
    Works for me. Thanks !
    • CommentAuthorShessar
    • CommentTimeMar 20th 2015
     
    Great! Thanks for testing JimP.
  1.  
    Ok, I cant do it... I think that IO am tired. Will try again later.
    • CommentAuthorseycyrus
    • CommentTimeMar 26th 2015
     
    I've done this with CC3, so I'm familiar with the gist of the procedure and just threw the files where I thought they went, so maybe I made a mistake but, I note that I do not have a C: ProgramData\ProFantasy\CC3Plus\Bitmaps\Menu. That is, I do not have a folder named "Menu" in my Bitmaps folder.

    I do have C:\ProgramData\Profantasy\CC3Plus\menu, and was able to combine the contents fcw32.imn (CC3+) with the first few lines of my old fcw32.imn (CC3) file and make it work.
    • CommentAuthorShessar
    • CommentTimeMar 27th 2015
     
    I ALWAYS mistype something and was surprised that nothing was wrong this time. Thank you for finding this mistake in my instructions seysyrus.

    The .imn file should be in C: ProgramData\ProFantasy\CC3Plus\Menu

    I've fixed this in the original instructions.

    If any other errors are found, or if something doesn't make sense, let me know.
    • CommentAuthorledge
    • CommentTimeMay 8th 2015 edited
     
    I'm having issues with these instructions. I think I have followed everything as above, but when I go into CC3+ and click on one of the new menu buttons, the symbols don't appear: My CSUAC folder looks like this: I assume it is a file path problem, but I have tried moving things around and can't seem to find the correct path. Any help would be much appreciated.
    • CommentAuthorShessar
    • CommentTimeMay 8th 2015 edited
     
    Hi ledge. I know setting this up can be a bit confusing. Your CSUAC symbol folder should look like this...
      CSUAC1.png
    • CommentAuthorledge
    • CommentTimeMay 9th 2015
     
    Brilliant, that sorted it, thanks for your help.
    • CommentAuthorlfseeney
    • CommentTimeMay 13th 2015
     
    May have caused an issue.

    I think I over wrote fcw32.imn by mistake, anyone have the base file so I do not need to reinstall it all?

    Thanks

    lfseeney at Comcast . net
    • CommentAuthorShessar
    • CommentTimeMay 13th 2015 edited
     
    Hi lfseeney!

    I don't think that any of the CC3+ add-ons have created a fcw32.imn file yet, so the CSUAC menu items should be the only thing in it. You should be OK just copying the file over.

    (Unless one of the new annuals uses it. Can someone who has this years annual check for me. I've only seen the .imn file used once before, but I'd hate to be wrong.)
    • CommentAuthorJimP
    • CommentTimeMay 13th 2015
     
    You can do a repair when you run the installer agan. If that doesn't work, put in a tech support request to Profantasy via your registration page.
    • CommentAuthorlfseeney
    • CommentTimeMay 13th 2015
     
    I think I am ok then it was a new install, just got worried when I checked and it was just the CUSAC info inside.

    Learning curve is enough without me causing more issues :)

    Thanks all!
    • CommentAuthorWarEagle
    • CommentTimeMay 14th 2015
     
    Thank you very much for the work.
    • CommentAuthorShessar
    • CommentTimeMay 22nd 2015
     
    ************************ IMPORTANT UPDATE ************************

    As ProFantasy continues their updates to the CC3+ add-ons, some of the old icons that I've used for the CSUAC Buttons no longer work. I have now updated the fcw32.imn to use all of the new icons.

    The ZIP file in my first post has been updated so if you have just downloaded it, you are fine.

    If you already have the CSUAC and notice that not all of the buttons are showing, you can just download the zip file from this post, extract and overwrite the fcw32.imn file located in:
    C:ProgramData\ProFantasy\CC3Plus.

    Not sure which version you have? If the buttons for Creatures, Animals, and People are missing then you have the old version.

    Questions? Problems? Let me know. :)
    • CommentAuthorlfseeney
    • CommentTimeMay 26th 2015
     
    Got it all working.

    If I wanted to add more stuff into say Trees bare, is there anything I need to do besides moving the new files in?

    Just want to be sure so I do not break something. As I just got it all working.

    Thanks
    Lee
    •  
      CommentAuthorMonsen
    • CommentTimeMay 27th 2015
     
    Yes, you will also need to update the Symbol Catalog files to include references to the new images. Manipulating symbol catalog files is described in the CC3 manual, and in greater depth in the Tome of Ultimate Mapping.
    • CommentAuthorlfseeney
    • CommentTimeMay 29th 2015
     
    OK off to read more.

    Thanks
    • CommentAuthorevad12
    • CommentTimeJun 1st 2015
     
    I'm getting blank spots where the symbols should be. Not sure what I did wrong. Menu appears to be working.
      cc3+ snapshot.JPG
    •  
      CommentAuthorMonsen
    • CommentTimeJun 1st 2015
     
    A blank symbol catalog window usually indicates that you tried to load a non-existing symbol catalog, most probably caused by the catalog files (*.fsc files) being in the wrong location. You should double-check that the symbol catalogs are in the right location according to the instructions. Make sure you don't have any extra folder levels or the such.
  2.  
    TYVM worked fine.
    • CommentAuthorreggatta
    • CommentTimeJun 13th 2015
     
    Awesome post. I can't believe how incredible these icons are.

    I have one question, if you could help, please: I do not have all of the menu icons available. For example, I have creatures, equipment, vehicles, vegetation, furniture, and structures; I do not have a menu icon for humanoids and animals (the human-like face and the green animal icons I can see from the above post by evad12). I copied/pasted the fcw32 file as outlined above, and opened my copy side-by-side with the one above to compare, and they are identical. If anyone has any ideas how I can get those 2 custom toolbar menu buttons to show up, I'd be most grateful.
    • CommentAuthorreggatta
    • CommentTimeJun 13th 2015
     
    As an addendum to my post a few seconds ago: I can click in the empty space on the custom toolbar number 3, and the icon menu for humanoids and animals will show up. So, it will work. However, I'm still curious what happened to the actual icons and how I may retrieve/activate them.
    • CommentAuthorseycyrus
    • CommentTimeJun 13th 2015
     
    Check this thread.

    http://forum.profantasy.com/comments.php?DiscussionID=5102&page=1#Item_3
    • CommentAuthorShessar
    • CommentTimeJun 14th 2015
     
    Posted By: reggattaAs an addendum to my post a few seconds ago: I can click in the empty space on the custom toolbar number 3, and the icon menu for humanoids and animals will show up. So, it will work. However, I'm still curious what happened to the actual icons and how I may retrieve/activate them.


    Reggatta, If you followed the link that seycyrus gave you and you still have this problem I need to know if you have all three updates (CC3+, DD3+, and CD3+)?

    If not, which do you have?
    • CommentAuthorreggatta
    • CommentTimeJun 14th 2015
     
    I checked, and the file on the thread Seycyrus gave is the same one that I have. Shessar, I have CC3+, but it looks like I only have the DD3 and CD3 files uploaded. I'll see if there are files for the "plus" versions of DD3 and CD3 that I need. Perhaps that is the underlying problem. If so, thanks for bringing it to my attention.


    Posted By: seycyrusCheck this thread.

    http://forum.profantasy.com/comments.php?DiscussionID=5102&page=1#Item_3
    • CommentAuthorHanzo
    • CommentTimeJun 16th 2015
     
    TYVM. Flawless install. Honestly, this group has impressed me with a helpfulness and patience that is rare in any circle. Well met indeed.
  3.  
    Why o why can't someone come to an agreement to work together and just come out with a Easy way to install this in a "1" click method...Spent hours trying to get them into CC3..
    Still frustrated :(

    Why can't they just make them available as free Art packs which could self install :)
    •  
      CommentAuthorVintyri
    • CommentTimeJul 11th 2015
     
    Posted By: jpstodwftexasWhy o why can't someone come to an agreement to work together and just come out with a Easy way to install this in a "1" click method...Spent hours trying to get them into CC3..
    Still frustrated :(

    Why can't they just make them available as free Art packs which could self install :)


    It's an ownership question. The owner has licensed only what is there, not anything more and not anything less. Neither ProFantasy nor we (Vintyri Project - licensee) are allowed to do anything with the CSUAC that isn't already done.

    One must take it or leave it as it is. The rest of what you want is not allowed.
    • CommentAuthorShessar
    • CommentTimeJul 11th 2015
     
    Vintyri is correct. If in the future the original owner comes back online, something may be arranged, but until that happens, this is how is has to be.

    It sounds like you are still having difficulty getting it installed. What problems are you having?
  4.  
    Well I got all the pngs in but no Catalog
    • CommentAuthorDiscoSoup
    • CommentTimeJul 15th 2015
     
    How does this work with the latest update?
    • CommentAuthorShessar
    • CommentTimeJul 15th 2015
     
    Posted By: jpstodwftexasWell I got all the pngs in but no Catalog


    I'm sorry that it has taken me a few days to get back to you on this. Life gets in the way at times. :\

    What exactly do you mean "no catalog"? Do you mean that the catalogs are blank, or that they have red x's, or....? I want to help you get these installed, but need more info.



    Posted By: DiscoSoupHow does this work with the latest update?


    Everything should work fine as is. Let me know if anything seems broken. :)
  5.  
    I need help getting the custom toolbar to appear after reinstallation of CC3+.

    I had CSUAC installed according to the instructions above and it all worked like a charm. Then, because reasons, I reinstalled CC3+ along with the DD3 and CD3 addons. When I proceeded to re-copy the CSUAC folders, the different folders and files were already in place (I guess Windows Uninstall did not remove them). Anyway, when I now add the 'custom tool bar 3' in my re-installed CC3+, no icons show up. I have tried all placement options (left/right/up/down) for what it's worth and I made sure to restart CC3+ after any changes.

    Any help is appreciated! I'm not computer-illiterate, but I am a newbie to CC3+ and I cannot think of a solution to my problem at this time.

    Thanks in advance,
    Anders
    •  
      CommentAuthorMonsen
    • CommentTimeJul 16th 2015
     
    Have you added your menu configuration back in (Step 3 in the first post in this thread). Even if the artwork and catalogs where still in place, the menu files would have been overwritten.
  6.  
    Monsen,

    Thanks for the quick reply! The fcw32.imn file was still present in my CC3Plus folder - I checked the contents and it is still identical to the one in the menu folder. (That's weird in and of itself if it should have been overwritten...) Anyway, the .imn file is in place and still no toolbar.
    •  
      CommentAuthorMonsen
    • CommentTimeJul 16th 2015
     
    That's weird. It is common that the icons doesn't show up immediately when showing the toolbar (I assume you can see the empty toolbar), but a click on the dungeon button (or any other menu button) should fix it (restarting cc3+ also works). I assume that your fcw32.imn file is located in the root of the CC3Plus folder, and not in the menu subfolder (or any other subfolder)?

    Maybe try closing down CC3+, deleting the fcw32.imn file, and then copy in a new one from the zip file attached to the first post.
  7.  
    I can indeed see the empty toolbar. Nothing happened when I clicked on the other menu buttons.

    I tried deleting and replacing the fcw32.imn file like you suggested but no results there. Maybe I should just uninstall it all again, manually delete all CC3Plus folders and start from scratch. Any other ideas before I pull the trigger? :)
    •  
      CommentAuthorMonsen
    • CommentTimeJul 16th 2015 edited
     
    I don't think reinstalling will really fix anything, as this is basically just a simple menu config issue. (Except forcing you to do everything again, which may help if you made a mistake somewhere we haven't been able to identify)

    Try adding the entries to dungeon.mnu instead (Make a backup copy of the file before editing, these files are a bit vulnerable to minor mistakes), then start cc3+ and switch to the dungeon designer menu set. Can you see the icons then?
    • CommentAuthorShessar
    • CommentTimeJul 16th 2015 edited
     
    AndersMolin, A few things that I would try.

    If you are running on a Windows OS, close out CC3+ and restart your system.

    In the Screen Tools Button (the hammer) set the icon size to small.(Checkmark at bottom) Restart CC3+. Then set the size to large icons again. Restart CC3+.

    Triple check that the .imn file is in C:ProgramData\ProFantasy\CC3Plus. Yes, I know you've checked, but check one more time.

    If it still doesn't show up, can you click where the buttons should be and get them to work?
  8.  
    Shessar, thanks for your input!

    I tried restarting Windows and all your other suggestions, including re-checking the .imn file location. Still no buttons. I tried clicking everywhere on the blank tool bar but no response.

    Monsen, I could not find any dungeon.mnu file anywhere in my ProFantasy folder. Where should it be located?

    Night falls on my time zone; I'll come back to this tomorrow with fresh eyes. Thanks to both of you so far!
    •  
      CommentAuthorMonsen
    • CommentTimeJul 16th 2015
     
    You did say you had DD3 installed for CC3+, so you should have a dungeon.mnu file. It should be located in the same place as the other menu files, like fcw32.mnu, city.mnu and fcw32.imn, by default in c:\ProgramData\ProFanatsy\CC3Plus.
    • CommentAuthorShessar
    • CommentTimeJul 16th 2015
     
    Posted By: AndersMolinNight falls on my time zone; I'll come back to this tomorrow with fresh eyes. Thanks to both of you so far!


    These are just a few more random thoughts/questions...

    Are you running both CC3 and CC3+? If you are running both, make sure that you are starting up the correct program.

    Did you run the newest update for Plus (Update 2)? Try running it again.

    Are the standard CC3+ and DD3+ catalog buttons working as expected?

    Monsen's idea of putting the .imn contents into dungeon.mnu is a good one, though it doesn't seem right that it isn't working as a stand alone file. If none of this works, then I'm stumped.
  9.  
    Ok, here's an update to my situation:

    Stuff got weird when I started to look into the mnu files. It turns out I had no dungeon.mnu, no city.mnu, and no fcw32.mnu files in my CC3Plus folder... The buttons were in place in the program though, with normal functionality.

    Also, when using Character Artist I have created a folder called 'User Portraits' for my own creation. This morning, I could not find the folder using Windows File explorer, but it showed up when using the in-software Open... dialog. I could open and save files to the folder as usual from within the program, but browsing or searching for the same files using File explorer did not turn up any results... Had my Windows Lore skill been higher, I might have figured out what was going on. Since I couldn't, I decided evil spirits have possessed my system.

    Chopping off a hand to save the arm, I uninstalled all ProFantasy software (CC3+, DD3, CD3, CC3, CA3) and manually removed all folders. Reinstalling just CC3+ and Update 2, I got the CSUAC bundle to work again with no problems. After I added CD3 and DD3, I noticed two of the icons in the custom tool bar (Animals and Creatures) are no longer showing, but they are clickable and work as they should.

    I haven't yet reinstalled CC3 and CA3, but I'm guessing they will cause no trouble with CC3+. So to sum it up, I now have a functioning software setup (minus two toolbar buttons) and I have no clue as to what was going on with my previous install...

    Anyway, thanks for taking the time to help me out! If I eventually figure out was went wrong, I'll post another update here. Otherwise, I'll just go back to actually using the software :)
    • CommentAuthorShessar
    • CommentTimeJul 18th 2015
     
    Posted By: AndersMolin After I added CD3 and DD3, I noticed two of the icons in the custom tool bar (Animals and Creatures) are no longer showing, but they are clickable and work as they should.


    You may be using an older copy of the .imn file. See THIS POST for the fix.

    I'm glad you got it working!
    • CommentAuthorHelenAA
    • CommentTimeJul 26th 2015 edited
     
    Hi, I've a problem. As can be seen in the top screenshot, though I *do* have a ProgramData folder, I can't get at it (in Win7 Home Pro it looks like it's a hidden, system file). I've got " Program Files " and " Program Files (x86) " in my C:\ drive and the ProFantasy folder is in the latter.

    Trouble comes further if you look at the second screenshot, I've got precious little in CC3Plus and I have a history of messing my ProFantasy installations to the extent that if I uninstall them, I can't reinstall them again. Please could you walk me through putting what where?

    Thanks.

    Helen

    PS Doesn't matter what computer I've had, the CC3Plus folder has always been rather empty even if I've installed CC3 after Plus.
      Untitled 1.png
      Screenshot 2015-07-26 13.54.23.png
    •  
      CommentAuthorMonsen
    • CommentTimeJul 26th 2015
     
    ProgramData is hidden by default. To access it, you can either bring up folder options and tell windows to show hidden files and folders, or you can simply type %ALLUSERSPROFILE% into the location bar in your explorer window (erase what is already there first), and it will take you to the folder.
    • CommentAuthorKaz
    • CommentTimeJul 26th 2015
     
    Posted By: Shessar
    Posted By: reggattaAs an addendum to my post a few seconds ago: I can click in the empty space on the custom toolbar number 3, and the icon menu for humanoids and animals will show up. So, it will work. However, I'm still curious what happened to the actual icons and how I may retrieve/activate them.


    Reggatta, If you followed the link that seycyrus gave you and you still have this problem I need to know if you have all three updates (CC3+, DD3+, and CD3+)?

    If not, which do you have?


    If anyone else has this same problem in the future, it was fixed for me by just upgrading to CC3+ Update 2 (3.67).

    I had a fresh install (thanks to a hard drive crash) of CC3+, DD3 and CD3 both for CC3+ Everything worked fine on the install, but I had the exact same problem as reggatta - icons for Animals and Humanoids were invisible, but would work if the blank space was clicked.

    Thanks to all involved for the resources and the info to get them into my maps. :)
    • CommentAuthorkenposan
    • CommentTimeAug 16th 2015 edited
     
    Not sure what I did wrong. I only did the CSUAS install as a test run.

    here is the error I'm getting:

     photo fig 1_zpserhrdz0x.png

    here is the file directory: it doesn't seem to match the above example.

     photo fig2_zps6jsdl8ta.png
    •  
      CommentAuthorMonsen
    • CommentTimeAug 16th 2015
     
    You have pasted the contents of the zip to the wrong directory, you have everything inside Symbols\CSUAC instead of at the root of the CC3+ data directory.. Check the first post in this thread fo the exact locations to put the content.