Bizarre river generation bug—hard to describe so I'll just post a screenshot


  • Update: experimenting with adding rivers to fresh worlds at various points in the world-generation process, it seems to be that "Fill Basins in Offset" is messing up river generation (unfortunate since without it river generation will be messed up in a different way). Maybe it's making the land too smooth? But if so, what's the standard fix? This feels so basic I feel like I need an updated version of this old tutorial:

  • jslaytonjslayton Moderator, ProFantasy Mapmaker

    It's a problem that's been cropping up once in a while. I haven't been able to pin down what causes it with any certainty, but reducing the resolution of the river finding step may help.

  • Reducing the resolution—even all the way down to Very Coarse—doesn't seem to help. And it doesn't just happen sometimes; I've never been able to generate rivers correctly after filling in the basins (though it works fine if I don't fill in the basins). Have there been prior forum discussions of this issue you could point me to? I've previously tried to find them without success, but maybe I'm just entering the wrong keywords into the search.

  • jslaytonjslayton Moderator, ProFantasy Mapmaker
    edited April 2022

    I haven't seen a discussion of this particular problem on the forum before. I will see if I can get a solid reproduction case using your suggestion, but I won't be able to take a look at the problem before next week at the earliest, unfortunately.

    Does the preview for the river finding show solid cyan coloring where the rivers will go, even when the rivers are very short (that is, does the river length slider affect the apparent rivers)?

  • Does the preview for the river finding show solid cyan coloring where the rivers will go, even when the rivers are very short (that is, does the river length slider affect the apparent rivers)?

    Yup. By default my screen becomes more less solid cyan (which makes sense because the rivers are going everywhere). I say "more or less" because sometimes the very highest mountain peaks will be visible—I think that happens more on lower resolutions, and of course it's a lot more obvious when I'm zoomed in. Sliding the slider towards shorter rivers lets me see entire mountain ranges, but lowlands (and oceans) will still be completely covered in solid cyan.

  • Added some screenshots demonstrating what the river preview screen looks like:

  • jslaytonjslayton Moderator, ProFantasy Mapmaker

    What is your world editing resolution (Map>>World Settings>>Editing)?

  • I have run into the issue on a variety of seeds and world settings, including both medium and large editing resolution, though just now I tried to replicate it on small resolution (which I'm not sure I've ever used before) and river generation worked just fine. Also while I think I have run into the issue on new worlds where filling the basins was the only thing I did before trying river generation, this morning I was trying to replicate the issue and it did not initially replicate before I filled in the "potholes" (seas not connected up to the bulk of the world's water).

    Also, here's a zoomed-out example showing just how total the coverage of the "rivers" is—basically everywhere that was cyan in the preview (medium editing resolution):

  • Here's a new one: tried to work around the river generation issues by using a small world, and got this:

  • One thing I notice is that the current Wilbur tutorial makes you add noise right after filling basins. However, the interface for global noise in Fractal Terrains, and the interface for the noise filter in Wilbur, are somewhat different. I tried using the default settings for adding noise in the offset on Fractal Terrains after filling basins on the above world (with all the unnaturally straight rivers), and it was back to a weird geometric pattern of "rivers" everywhere.

  • I have this same issue. I can load a world with rivers that was generated using FT3, but since the upgrade to FT3+ river generation is borked

  • 1 month later
  • Just to chip in and give the thread a bump - I'm also experiencing this problem :(

    Under other circumstances it would be a very interesting and pretty pattern, but not when what I'm looking for is realistically routed rivers...

  • 24 days later
  • The find rivers feature is doing they same thing for me. I was following the instructions in the One Day Worldbuilder annual and everything was working up to the step of using find rivers. Then it blotted out 80-90% of my map with geometric rivers. Any update on this @jslayton ? Really hoping this isn't going to be forgotten.

  • Do you have FT3+ Downloaded and installed ?

  • jslaytonjslayton Moderator, ProFantasy Mapmaker

    It hasn't been forgotten, @QuantumSin . It's currently #1 on the FT bug parade, but that parade is not getting a lot of attendance at the moment.

    Don Anderson Jr.JimP
  • Is it possible to take the map made in FT3+ and Wilbur (from One Day World Builder) and load the MDR file into FT3 (no Plus) to find rivers? Or are there file incompatibilities?

  • jslaytonjslayton Moderator, ProFantasy Mapmaker
    edited June 2022

    MDR files should be relatively compatible between the two. There was a coding error during a rewrite of Wilbur that caused MDR surfaces to flip vertically between the two programs. It's easy to fix in Wilbur by using Surface>>Rotate>>Flip Vertically.

  • 11 days later
  • brendanvbrendanv Newcomer

    It seems that i too have this issue.

  • 20 days later
  • DavidBDavidB Newcomer

    There was some discussion of this bug on the forum last year, and nothing has changed in the meantime.

    I created a world in FT3+, and river generation does the same thing everyone else here has mentioned. River generation works fine on that world in FT3, but since when I load the world in FT3 everything is radically different (like seriously, no visible similarity at all to the same world loaded in FT3+), that isn't a reasonable workaround.

  • 27 days later
  • hsv216hsv216 Surveyor

    Not sure if this has been resolved as of yet, but was having same issue, so assume not. Was able to reproduce by creating a world and doing the burn into surface. This created the wierd pattern. Not doing the burn into surface allowed me to generate the rivers as per normal.

    Just tested again using a synthetic randomly generated world and find rivers ok. Cleared River overlay and then Burn into surface and find rivers again now sows the wierd pattern.

    I was able to get my world with rivers by not doing the burn into surface, i.e. skipped that step in the worldbuilder annual, so not sure what that actually does, but it worked for me anyway. :) Hope it helps.

    Running FT3+ v3.5.1

  • DavidBDavidB Newcomer

    I went ahead and tried that—no such luck for my world.😞

  • I have NO intention of using the flawed FT3+ till it is fixed - and it is taking some time to be fixed. Why?

Sign In or Register to comment.