How do I change default save location

How do I change the default save location for CC3+? It always want to save the the program folder any time I make a new map. Is there an option for application preferences for things like that?

Comments

  • MonsenMonsen 🖼️ 46 images Cartographer Administrator

    There isn't a setting for a default save location, but it should be remembering the last folder used.

    For a workaround, you can also use Windows' only features, such as pinning a folder to quick access or making a library, since these are easily accessible from the save as dialog.

    Loopysue
  • I created my own folder under my user account on my desktop. I save, and load, files from there. Works for me.

  • Monsen said:

    There isn't a setting for a default save location, but it should be remembering the last folder used.

    That has never worked for me, at least not for new maps. The program always tries to save them in the installation directory first and I have to find the right one to put them in. I usually only create one new map per session however so I don't know if a second would end up in the same place. The last folder used doesn't seem to be saved between sessions.
  • MonsenMonsen 🖼️ 46 images Cartographer Administrator

    Wonder why that may be. I've never had it suggest the installation directory. I've tried a lot of things, including shutting down CC3+, deleting the last used directory and then restarting CC3+, which caused it to default to my documents directory, but I have never experienced it going to the installation directory myself.

  • Yeah, I find exactly the same as Dalton said, that wherever I've stored a map previously isn't held in memory if I want to start a new map. It insists on going only to the installation directory.

  • RalfRalf 🖼️ 16 images Mapmaker Administrator, ProFantasy

    Does it work different if you start CC3+ "as admin"? Right-click the desktop shortcut to choose that option.

  • I'll have to check mine. I don't think it goes to either of those locations. But it's 3 am and I'm half asleep. I'll check later.

    But I have my data folder c:/profantasy/cc3plus/crestar02/

    The crestar02 is where I save my maps. With folders for each website, etc.

  • jslaytonjslayton Mapmaker Moderator, ProFantasy

    Is it the installation directory where the fcw.exe file is located or the installation directory where the template .fcw file is located?

  • LoopysueLoopysue 🖼️ 28 images Cartographer ProFantasy

    Mine seems to work ok. I reinstalled the entire setup on a new PC just over a year ago. Could it be a setting that was once 'the way to do things' that isn't updating? My new installation was from newly downloaded installers acquired on the same day as the installation.

  • To clarify things,
    1. My installation directory is "C:\Program Files (x86)\ProFantasy\CC3Plus" where the executable is.
    2. My CC3Plus data directory is "E:\CC3Plus" (an external hard drive).
    3. The default directory I want to put new maps in is "D:\Maps" (a thumb drive).
    New maps always try to save to 1 first.
  • edited September 9


    Yes it does, and will let me save the file to the last place I saved an FCW as it's supposed to.

    Makes me wonder if it might be a Windows 10 thing, as I can't be sure it's always done this, or if it's just recently started. My recollection is that most of the maps I've started as new and saved from the usual templates have needed to be redirected away from that "wrong" (i.e. program) directory for at least the last half year or so. I haven't been keeping careful track though, so the actual time could be longer or shorter than that, albeit probably not shorter than since about May-June this year.

    Ralf
  • Hmmm... I had an overland map loaded. I selected Dungeons, and Annual Ancient Tombs.

    It wanted to save here: C:\Profantasy\CC3Plus\Symbols\Maps\CC3

    The second time I typed new <enter>

    I tried a Perspectives then Annual Tagkrammer Isometric, and it wanted to save in the same folder under Symbols.

Sign In or Register to comment.