Update 25 error

I decided to do fresh install and downloaded CC3+ this morning from the site and I also downloaded Update 25.

CC3+ has installed correctly and I ran it and then exited, but part way through the Update 25 tells me the Source File Fcw32.mac is missing.

Should I have it ?
Should I rename a blank text file so it can find something?
Do I choose ignore ?

Any suggestions welcome.


  • RalfRalf 🖼️ 16 images Mapmaker Administrator, ProFantasy
    Use Ignore here and you should be fine. The update tries to backup the macro file in case you've made any changes to it.

    It's a bit weird the update doesn't find it though. Is there a difference if you run the setup as admin? (Right-click and choose Run as Administrator)?
  • UKgnomeUKgnome Newcomer
    I am running as admin, and I searched for the file and it doesn't exist in the programdata folder or anywhere else, like it hasn't been created during the installation
  • UKgnomeUKgnome Newcomer
    edited May 2020
    OK so ignored that, now everytime I start I get errors about opt files not being found.

    And, it no longer opens with the splash screen I was getting.

    Now it is trying to open a map I was playing with a couple of years ago when I last used the program

    Amy suggestions
  • MonsenMonsen 🖼️ 45 images Cartographer Administrator
    The .opt files sometimes happens because some extra library files related to add-ons you don't own have been copied in (probably a product detection error for some reason), you can fix that by manually deleting

    You should be able to fix it by deleting the cc2per.dll file found in your CC3+ installation directory (c:\program files (x86)+ProFantasy\CC3Plus).

    As for the splash screen, CC3+ always loads up the last used map on startup, so you won't normally see the splash screen for more that the first start anyway. Updates and add-on installations sometimes set a new map to be displayed here to showcase it, but again, it is gone the next time you work on a map anyway, so don't worry about it.
  • UKgnomeUKgnome Newcomer
    I think I have worked out what is happening, but not why.

    I am installing on the laptop that has never had any CC3+ product on it, so I can view the TUM and it asked for the serial number.

    What I thought was a clean install, after having removed all the installed CC3+ programs, must have left info in the registry as when I re-installed it knew the serial number and hence why it is trying to load stuff that no longer exists.

    So, how to clean the registry thoroughly after an unistall ?
  • UKgnomeUKgnome Newcomer
    Ok, less speed, more haste.

    I went through the registry manually and removed all references to Profantasy, that were safe to remove (if you are uncertain what to delete, don't, and messing with your registry could mean re-installing windows)

    I downloaded the CC3plus file from the website, this is version 3.94
    I read the next file on the list which was Update 25 and this updates to version 3.94

    Ha ha, thinks I, I don't need that one.

    And installed CC3plus and it asked for the serial number etc, seemed to install OK and I was only left with the .opt errors, so I deleted the dll as Monsen suggested and all worked.

    Then, as I thought you were meant to do, I clicked on the Latest CC3Plus update link on the Downloads page, and TOTALLY missed the fact that this is Update 25.

    I installed it and got the .opt problem again as the cc2PER.dll file had returned.

    Anyway, all working, and thanks for the help Ralf and Monsen
Sign In or Register to comment.