Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorseycyrus
    • CommentTimeFeb 22nd 2020
     
    Working on a city and decided to open up an annual and follow along. Opened up 2016 Mapping Guide: City Streets and noticed a discrepancy between the choices shown in the annual and what I am shown (and is placed). Is there some other setting that I need to change to get the roof shingles?
      HouseOptionAnnual.png
    • CommentAuthorseycyrus
    • CommentTimeFeb 22nd 2020
     
    Here's what I see.
      HouseOptionReal.png
    • CommentAuthorLoopysue
    • CommentTimeFeb 22nd 2020
     
    If you didn't create the file using the annual template it may be that you just need to import the fills from that annual.
    • CommentAuthorseycyrus
    • CommentTimeFeb 23rd 2020 edited
     
    Thank you for your time.

    Striking out like a blind man in the dark, I tried to "import png" from C:\ProgramData\Profantasy\CC3Plus\Bitmaps\Tiles\City\Ca117 ... without any luck. I also tried to import from the symbol manager, but failed.

    I also tried to "import bitmap fill styles", but feel like I am trying to eat soup with a fork.

    ...
    •  
      CommentAuthorMonsen
    • CommentTimeFeb 23rd 2020
     
    The insert building dialog predates the map style system, so it unfortunately display all the buildings in a long list, instead of being style sensitive like the drawing tools are.

    Import bitmap fill styles would be the correct operation here, since it is fill styles that are missing not symbols. Generally, you never need to import symbols, except when creating a new symbol catalog, but you'll need to import fill styles every time you are working on a map based on a template from a different style than where these files belong.

    The easiest way to import the correct fill styles is to create a new map in the style that already has these (CA117 in this case), then in your real map, use Draw -> Insert File and select this new drawing. Once you have the drawing on your cursor, just hit Escape. This will cause all the fill styles to be copied intot he map, without inserting any actual entities.
    • CommentAuthorLoopysue
    • CommentTimeFeb 23rd 2020
     
    Remy - when you import like that using a ready made empty file, does the fill scaling also get imported or do you have to set that up.

    (I tend to use Import Bitmap fill styles, and it is necessary to set the scaling for them that way)
    •  
      CommentAuthorMonsen
    • CommentTimeFeb 23rd 2020
     
    The fill scaling is imported too. Of course, the scaling may not be appropriate for your new map, so you need to check it, but that is really only a concern with overland maps, city/dungeon/floorplan types maps don't vary the scaling based on map size anyway.
    • CommentAuthorLoopysue
    • CommentTimeFeb 23rd 2020
     
    Thanks, Remy. Useful to know :)
    • CommentAuthorseycyrus
    • CommentTimeFeb 23rd 2020
     
    Thank you. This works wonderfully.

    It makes me wonder if I should save a template for each style just for importing fills.

    I'll derail my own thread a bit. I'm following along the CC3+ TOUM city designer section, and it talks about the Snowport maps (@Tutorials\Tome\City). Do these maps exist anymore? Where are they located now? That file structure does not seem to be present on my machine.
    •  
      CommentAuthorMonsen
    • CommentTimeFeb 23rd 2020
     
    They should be in that location. I just checked with one of my freshly installed computers, and the files are there (13 of them). If the files are missing, you may want to to try a repair install of the Tome.
    • CommentAuthorseycyrus
    • CommentTimeFeb 23rd 2020
     
    Thanks for the verification. I must have just missed the TOUM in my last reinstall.
    • CommentAuthorseycyrus
    • CommentTimeFeb 23rd 2020 edited
     
    Another question that hopefully has another straightforward answer.

    Going back to the city map I'm drawing ...

    To provide some rationale why I am in the present dilemma. I had made a player map using the isometric Renaissance City style. Then decided to create a GM map based on the plan. I created a new map in City of Schley metric (SS5), and copied over (copy to clipboard) the roads and walls to use as a template to create new walls and roads. Things went fairly smoothly.

    I am trying to use the Random Street or Random Street Options commands to select some buildings to put on roads. Now SS5 and CA117 don't appear to have a choice for metric even though when you start a map, you can choose metric. Normally if I was placing symbols manually, I would just right click and scale them by .33 to roughly get the right size, but I do not see how to do that with the Random Street or Random Street Options command.

    Am I missing something?
    •  
      CommentAuthorRalf
    • CommentTimeFeb 24th 2020
     
    We just recently (January) fixed the random street settings for metric maps in SS5. Try reinstalling SS5 from the most recent setup, it should give you correct metric street and house settings for SS5.
    • CommentAuthorseycyrus
    • CommentTimeFeb 24th 2020 edited
     
    Thank you, that worked nicely for SS5.

    Is there anything that I can do manually to do the same for CA117 or other templates that don't have a choice for metric under "random street options"?

    Even if I start a map in CA117 metric, the random street command produces buildings that are ~ 3x too big. If I just place buildings frm the buildings on the left, they are correctly sized for metric.


    EDIT: I see where the issue is, CA117 was only intended to be used for small street scenes. Perhaps that is why it does not come with a metric version of the houses. AN oversight perhaps, but an understandable one. I guess I'd still like to know if there is a way to scale all the houses that get placed by Random Street.
    •  
      CommentAuthorRalf
    • CommentTimeFeb 26th 2020
     
    To get the metric street settings, do the following:

    1. Right-click the random street button to open the options.
    2. Select the CA117 Default setting and Save it under a new name, e.g. CA117m Default
    3. Click the "Street Settings" button.
    4. Divide all the numerical settings by 3 (roughly). See screenshot below.
    5. Save the setting again and close the dialog.

    6. Open the drawing properties dialog and click Map Notes.
    7. Open the map note OnOpenMacro
    8. Replace both instances of CA117 with CA117m. Save and close map notes and drawing properties.

    You should now be set to use the metric version of the random street tool whenever you open this map. If you want to change the template, open it in CC3+ and do steps 6-8 with both OnOpenMacro and OnNewMacro.
      Streets.jpg