Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorCulverin
    • CommentTimeFeb 13th 2020
     
    Hi guys,

    I have been using CC3 and various features for years and had no trouble. Recently, I turned on the program after a few months of inactivity and found that most of my textures are now the same default grass in various shapes (see attachments). This is true in virtually every style for City Designer 3. I was at such a loss for what to do that I just uninstalled and reinstalled all the programs, but it is still here, and even more assets are grass.

    What on Earth can I do about this?

    I thank you in advance for any help you can provide.
      Screenshot (26).png
    • CommentAuthorCulverin
    • CommentTimeFeb 13th 2020
     
    I should note that this is also happening in both CC3 and CC3+.
    •  
      CommentAuthorMonsen
    • CommentTimeFeb 13th 2020
     
    The issue here is that that is the wrong drawing tool set for that map type. As you might see, the dropdown in the top right of the dialog shows Overland CC3 Hex. Just switch the tools to the appropriate style, and they should work just fine.

    What is happening here is that your current map don't have the fill style definitions included that those tools ask for, so they just shop up with whatever fill you have currently selected instead.


    Why the map shows the wrong set of tools is another question, but CC3 saves this information with the map, so if you manually changed them and then hit save, then the map would be saved with the wrong tools selected. The style can also be set from the map load macro, so if you have copied these from another type of map, it could also load the wrong tools.

    Also, looking at your toolbar, it doesn't look like you have CD3 installed at all, which would also cause CC3+ to be unable to load the correct toolset for a city map, since it don't exist at all.
    • CommentAuthorCulverin
    • CommentTimeFeb 13th 2020
     
    Sorry, as I said, I was redownloading as I sent this message. Now I have finished downloading all the add-ons and it is still an issue. How would I go about correcting the tools?
    • CommentAuthorLoopysue
    • CommentTimeFeb 13th 2020
     
    As Monsen said - click the down arrow on that dropdown box at the top right of the dialog (where it currently reads "Overland CC3 Hex" in your screen shot above) and pick the right style.
    •  
      CommentAuthorMonsen
    • CommentTimeFeb 13th 2020 edited
     
    Just use the drop-down in the top right corner of the dialog and select the correct toolset style for the map. Most of them are sensibly named. For example, if the map is a CD3 Bitmap A style map, the tools you want will be "CD3 Bitmap A".

    The map in your image looks like a CC3 City Basic style map, so it should have the 'CC3 Basic City' set.

    Edit: Beaten by a mouse again. I need to bring my cat :)
    • CommentAuthorCulverin
    • CommentTimeFeb 13th 2020
     
    Thanks, guys! Sorry for posing such a noob question.

    I'll try to make a point of posting some of my work on this forum in the future. I'm really impressed with what a lot of you have made, and hope I can get a lot better myself.
    • CommentAuthorLoopysue
    • CommentTimeFeb 13th 2020
     
    Remy - LOL!

    Culverin - no worries. I'm looking forward to seeing your work. (and in case you're wondering my avatar name on another mapping forum is 'Mouse')
    • CommentAuthorJimP
    • CommentTimeFeb 13th 2020
     
    Don't worry, you should see my early maps... better yet, don't look at them. I have improved since then.