Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    So I'm not sure if I'm doing something wrong but I keep having this problem repeatedly. Whenever I set a user defined map for making a starship, and then set about creating the hull using the mirrored hull default tool Cosmographer freezes up forcing me to force the program to close as a result.

    What seems to happen is I click down the first point for the mirror image, but no line appears as I move the mouse away (not dragging), and then some sort of popup seems to come up, or rather an empty white block where it should show something and all the controls stop responding.

    In contrast, for some reason, if I use the pre-defined template that comes with cosmographer for star ships (bitmap one) the hull tool works fine. This is really confusing. Am I doing something wrong?? Or is this a bug? Is there some sort of patch I need to use, because I thought I had used the patches I needed already.

    Thanks for your help :)
    • CommentTimeFeb 8th 2020
    Not sure what would cause this in the first place, but I am guessing you have the same problem as here? Try follow Shessar's recommendations in that post and see if it helps you.
    Thank you Monsen! That link seemed to have solved the issue. It does seem to be linked to the grid. Because after drawing with the snap and grid off, drawing a mirrored hull worked just fine. But after doing so I turned on the gird again, and once more it just froze on me. I think as Shessar's comment seemed to be pointing out, I think it has something to do with grid being on when no gird has been set as a default grid to reference for a grid to setup on.

    I hope it gets fixed someday. :) Thank you again!
    • CommentTimeFeb 9th 2020
    Yea, you must actually set a grid (right click the grid button) before you can turn it on again.

    Are you running the latest update btw? I just remember seeing something about an updated Cosmograher template in the release notes (Obviously, If you have installed Cosmographer recently, the update must be installed AFTER installing cosmographer)