Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthormike robel
    • CommentTimeFeb 8th 2020 edited
    I started going through things with FT3 to learn to export contours to CC3+ to see if I can work out a way to display contours on the CC3 Map without having to trace hundreds of meters of contours. This is especially needed when I have many contours concentrated so as to become inseparable and/or when they are covered up by other map features. Sometimes this is related to the scale of the map or the source (paper map scanned, piecing a digital map together, or taking screenshots of online digital maps).

    I start by opening FT3, File|Save as Campaign Cartographer ... and just select 1000... contours from the available settings. Push Export world, selects a directory for the map, name it, the screen flashes, and I can load the map in CC3.

    Then I work my way through the wizard since I just want to see contour lines.

    When I get to the near final step, I assign it a name - "Mike"

    Push Save and I get the error message below. I figured its because of read/write permissions in the directory, so I type a directory structure to put it someplace else and I get the same error message.

    I reinstalled the program and tried again. Same result.

    I'm sure I am doing something stupid and reading the manual and the tome are no help. They just say, enter a file, push the button.

    1. Add an export complete message so the user is fully aware the process is complete.
    2. Allow the user to place the export file parameters where he wants.
      FT3 Error Message.JPG
      Naming the export filter.JPG
    • CommentAuthorLoopysue
    • CommentTimeFeb 8th 2020
    Not stupid.

    MS went and moved the goalposts after FT3 was written. It now prevents the user from saving anything in the programfiles (x86) folders, whereas before it never did.

    To get around this issue you need to open FT3 as the administrator, not the user. Right click the icon and pick "Run as administrator". MS, being the bully that it is will startle you by asking you if you want this app to make changes to your PC, but its all perfectly safe. Just ok it and carry on.

    With Administrator rights you should be able to save your new settings without any problem.
    Thanks, Sue. That was an obvious solution, but I thought I should be able to specify the file location as a counter-measure, but I guess FT3 doesn't like us doing that.
    • CommentAuthorjslayton
    • CommentTimeFeb 8th 2020
    MS didn't move the goalposts after FT3 was written: the original programmer (and lots of others in the late 1990s) didn't understand where the goalposts were. The MS guidelines did say not to write to the "Program Files" directory, but there was no enforcement of that guideline until later on with Windows 7. Too many programs broke outright when UAC and other security measures were implemented.

    Running as Administrator will work in the short term, but I recommend reinstalling FT3 somewhere other than Program Files if possible. Running FT3 as Administrator opens up the (very remote) possibility of certain maliciously-crafted files being able to compromise the security on your machine.
    • CommentAuthorLoopysue
    • CommentTimeFeb 8th 2020
    Oh I see.

    I interpreted historic comments the wrong way, then.

    Where would it be better installed?
    • CommentAuthorjslayton
    • CommentTimeFeb 8th 2020
    If you're going to install FT3 in a place other than program files, then pretty much anywhere that's not OS-protected is good (for example, installing into your user account is a good option, installing into ProgramData might be acceptable, or installing into a directory on another drive is the best option is you have such a thing available).

    The current security posture for Windows is to install executable code (.exe or .dll files) into Program Files and then put any data relating to the program into another, less-protected location (e.g. ProgramData). FT3 and earlier versions look at the executable's directory and use that directory as the base of the path for working files. It turns out that this behavior is what's often referred to as a Bad Thing.

    I've learned a few things over the last twenty years and future versions of FT are much more likely to keep their program and their data separate.
    • CommentAuthorLoopysue
    • CommentTimeFeb 8th 2020
    Ah! You're going to change the default location in the end. So I'm going to be lazy and leave mine exactly where it is for now. I'm used to opening as administrator anyway ;)
    • CommentTimeFeb 8th 2020
    JSL, when could we expect a FT3.1, or even FT4. I love this program, and am eager for any extra features.
    • CommentAuthorJimP
    • CommentTimeFeb 8th 2020
    I installed it as C:\FT3

    works great for me.