Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorBoneBoxer
    • CommentTimeMay 23rd 2019
     
    I'm getting the hang of Dungeon Designer Pro and coming along, but one thing is bugging the heck outta me.

    I'm drawing a complex series of caves and doing it by making frequent use of the Multipoly tool. So, I draw a very large "room" and then draw another "cave" inside it for pillar, larger intervening rock section, or whatever, then use Multipoly to join it with the larger "room." This works great...

    EXCEPT multipoly always clobbers the fill I've chosen and replaces it with the "Dirt and Grass Light" fill. So, I then always have the extra step of changing properties back to the fill I want (which happens to be "Dirt Grey 1").

    Is there some way to change this default behavior or am I just stuck with this endless tedium?
    • CommentAuthorLoopysue
    • CommentTimeMay 23rd 2019 edited
     
    I think that might be one of the little quirks that make CC3 so much fun :)

    Have you tried setting the fill and sheet first before drawing anything? I find it works better if you do that. Also, if you use the primitives (draw rectangle, draw polygon, draw circle etc) on the right hand toolbar instead of the drawing tools. The drawing tools will reset the fill to whatever fill they are set to use and scrap any personal choice you have made.
    • CommentAuthorBoneBoxer
    • CommentTimeMay 23rd 2019
     
    It's the multipoly operation that is giving the unwanted fill, not drawing using the cave tool. The cave drawing itself is working fine for me.
    •  
      CommentAuthorMonsen
    • CommentTimeMay 23rd 2019 edited
     
    When you multipoly something, the entire shape takes on the current fill, it does not use the fill of the existing shapes. So make sure to set the current fill before using the command (or just change it after the fact as you are already doing).

    Reason for this is that a multipoly can be made from shapes with different fills, so instead of ending up with more or less a random pick between them, it uses the current properties as this gives consistent behavior.
    • CommentAuthorBoneBoxer
    • CommentTimeMay 23rd 2019
     
    <blockquote><cite>Posted By: Monsen</cite>When you multipoly something, the entire shape takes on the current fill, it does not use the fill of the existing shapes. So make sure to set the current fill before using the command (or just change it after the fact as you are already doing).</blockquote>

    Thanks, that's helpful. So there is no way to set a default for whatever "current fill" is? Or at least set it once and have it stay that way while I'm drawing..? I don't see any generic "current fill" setting but maybe I'm just missing it or don't know what to look for.
    • CommentAuthorBoneBoxer
    • CommentTimeMay 23rd 2019
     
    Never mind, I see it's in the row of fields above the toolbar. This solves my problem. Thanks again!
    •  
      CommentAuthorMonsen
    • CommentTimeMay 23rd 2019 edited
     
    Note that if you already have an entity in the map with the settings you want, you can use Extract Properties on it to set the current properties equal to those of the entity before you multipoly things, this is the quickest way to get the properties right.