Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    Please help me guys. I purchased CC3+ two months ago, and I have been using it forever, working on two specific maps. I had done so much work on them until - BAM. A few days ago, every time I opened one of my map files, I got the error attached. I think the file is corrupt, and I REALLY hope there is a way of fixing this. I tried using tech support, but I'm in America, and there time zone is messed up with mine, and they reply when I'm gone. Please help. I tried updating CC3+, and THAT didn't even work.
      Screenshot (11).png
    P.S. -- here is one of the corrupted files in case anyone manages to fix it.
    • CommentAuthorLoopysue
    • CommentTimeDec 26th 2018
    That's messed up pretty badly isn't it. I discovered there were no sheets in the file, and when I added a new sheet, saved the file, then closed it and opened it again the sheet I'd made was gone.

    Unfortunately you may have to be patient and wait for tech support on this. I'm a bit confused as to why the time zone difference is a problem. Its not usually done by phone but by email.

    I say 'unfortunately', but in truth you are lucky - we all are. Tech support at Profantasy is five star ;)
    • CommentAuthorLoopysue
    • CommentTimeDec 26th 2018
    Just a thought, but if you start a new file do you get the same thing again when you save, close and reopen it?

    If a new file is working fine, what was the last thing you remember doing to the corrupted files?

    Did you perhaps decide to delete all the Layers and Sheets, or did that just happen all by itself?
    • CommentAuthorLoopysue
    • CommentTimeDec 26th 2018
    I managed to stop the file opening with an error message by adding a set of effects presets. They had also been deleted.

    Unfortunately, the file has nothing in it, so yes - it looks like a tech support job. Sorry!
    • CommentAuthorLoopysue
    • CommentTimeDec 26th 2018
    And have you tried opening the autosave file? If you are very lucky and you had the autosave on, and you haven't had anything else open for any length of time since the file was working, you might just have a copy of it saved in the autosave.

    If you have, save it immediately as a new filename somewhere safe in your Documents folder, as things get a bit awkward if you continue to draw in the autosave file when it next tries to autosave.
    Thanks Looopysue. I DID have autosave on, and here is the autosave file for you. It looked fine when I opened it ONCE, but the second time I opened it, it became corrupted.
    Unfortunately, I was foolish and didn't save it again, so it messed up too.
    The layers and sheets all deleted by themselves. The only thing I DO remember doing was removing the battery for my computer before shutting down the computer. (its a laptop). The thing is, though, when I reopened it, only ONE file was corrupted. As I continued using CC3+, more files, including the Autosave, became corrupt as well.
    • CommentAuthorLoopysue
    • CommentTimeDec 26th 2018
    Oh dear. This is beyond my scope to understand, and really is a tech question.

    Just a note about the autosave - if the file you have open when the autosave happens is corrupt, then the ok autosave file will be overwritten by the corrupt one that is currently open. That is why I suggested that if the autosave file was ok you should save it immediately under a new filename to preserve it if the main file can't be repaired. CC3 only has one autosave file, which is overwritten every time there is an autosave no matter what file you have open.

    I am assuming that when you removed the battery you were already on mains power, and that your laptop is one which can operate without a battery as long as it is plugged in to the mains. Its not a manoeuvre I would really like to risk with unsaved files or even open apps on my screen. I am just a user like you, but my instincts are telling me that the removal of the battery might have something to do with this.

    I do hope that Profantasy are able to recover your map for you.
    • CommentAuthorjslayton
    • CommentTimeDec 27th 2018 edited
    For some reason, your first map was composed entirely of 0 bytes and was unrecoverable. The second file had the first 25 bytes of the signature at the top of the file replaced by 0 bytes, but replacing the corrupted bytes with a proper signature seemed to make it work again. The repaired one is attached.
    jslayton thank you so much -- I have one other corrupted file -- can you just explain what you did. I didn't really understand. If not, could you fix this file as well?
    Also, jslayton, since you are having success, could you help me with ANOTHER problem. The tech support guy said to update CC3+. Everytime I hit the downloads button, I get this error:
    The thing is, though, that the tech support guy said that my serial number was registered, and everything worked for him. I'm really confused at this point.
    • CommentAuthorJimP
    • CommentTimeDec 27th 2018
    When that happens, I click on a different map and it loads.

    There has been a big jump in Internet use due to this being a big holiday. Have you tried downloading at different times of the day ?

    And always install as admin by right cicking on the file after downloading and click then on INstall as Administrator.
    • CommentAuthorjslayton
    • CommentTimeDec 27th 2018
    Sorry about the delay in getting back to you on the Helminore file. It had exactly the same corruption as the AUTOSAVE file (the first couple dozen bytes were all 0 values). After I fixed the header, the file looked like a blank template with nothing in it (there were the style definitions, but nothing like a line or path was to be found).

    I'm not sure how you ended up with files that have the same sort of very specific corruption. I certainly hope that it doesn't keep happening.
    No problem jslayton. Right now, I keep saving the same file multiple times in different locations so it never happens again. Honestly, the first file that you recovered for me was the most important. The Helminore file is easier to redo. I owe you a lot. Thanks for the help.
    • CommentAuthorjslayton
    • CommentTimeDec 28th 2018
    <blockquote><cite>Posted By: mandrawes</cite>Thanks for the help.</blockquote>
    I'm happy that I can help. Keep on mapping!