Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    Hi, first of all I am a novice, so this might be something really simple. I have been trying to recreate an existing paper map with CC3+, in effect tracing the map from imported BMP using freehand sketch.

    I got to the point when I wanted to convert the freehand into a poly, creating the continent. Unfortunately I am hitting a perennial problem which I cannot seem to figure out myself.

    When I do a path to poly, I get a poly alright, but in one of the areas it adds two extra lines. I explode the whole poly, examine the points where the lines terminate, and I can see nothing special about them.

    I have tried to delete portions of the path and replace the part with "trim to intersection" but the end result is the same. After half a day of wondering about this getting progressively more frustrated, I decided to ask for help.

    Any suggestions on what to try would be highly appreciated.
      two lines high view.JPG
    Here is a close up
      two lines close view (north).JPG
    • CommentTimeNov 18th 2018
    Did you join the paths first? If you use path to poly on a set of lines, it closes each one of them individually, it doesn't merge them into a single shape (and thus lines will be drawn between the endpoints of the paths, since polys are closed things)
    • CommentAuthorLoopysue
    • CommentTimeNov 18th 2018
    Its in the same right click menu as path to poly, and called "Combine Paths".

    Keep your eye on the command line as you do it, though, since it will tell you how to switch ends if the wrong end of a line joins up to the end of where you are working.
    Hi Monsen,

    Thanks for your response. I have used "lines to paths" and then "path to poly" directly. So no, I have not used "combine path" prior to going into poly.

    I did a bit of more studying while trying to do this and there is something wrong with the two paths. For one reason or another there are two separate paths which refure to connect. I have deleted now a few small lines, and tried to use "trim to intersection", this fails to do anything. I get to choose the first entity normally, but the trying to click on the second entity yield no results (no line being drawn between the two paths).

    Do you have an idea what could be causing this? I am fairly certain that fixing this would enable me to successfully create a poly out of the paths.
      Cant trim to intersection.JPG
    And to add insult to injury, close the gap with freehand and trying to "combine path" crashes the software, every single time...
    • CommentTimeNov 18th 2018
    Line to Path on multiple lines only combines them if their endpoints match up perfectly, otherwise they are left as separate entities.

    With Combine Path, you don't need to close the gap first, it automatically closes the gaps between lines.

    Unsure about the crash. How many nodes does your paths have? Are they extremely complex?
    @Loopysue & Monsen, reading your comments few times and trying them out n practise helped me to figure it out. And yes Monsen, I think it was the amount of nodes that caused the creash. I simplified it and crashing disappeared. Thanks to both of you!
    • CommentTimeNov 18th 2018
    Glad you got it sorted.

    Happy mapping :)