Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthortomponzi
    • CommentTimeSep 19th 2018
    I started to create a new map using the Traveller Subsector template from Cos 3+.

    I found that some symbols were sized correctly for this template and some were impossibly small.

    For example, using the Cosmo bitmap A Traveller Systems catalog, when I selected any of the 8 Cos A Planet life symbols to place on the map, the symbol was so tiny you could not see it.

    When I drilled down, there was nothing I could do to expand it. I went through the process of clicking the scale button, highlighting the symbol in pink, "doing it", and then dragging the symbol out and left to expand (as I have done many times before), but nothing happened. I was able to copy and move the itty, bitty planet, I just could not resize it. I have tried to use the control button when placing the symbol to get it to scale, but this seems not to work either.

    This behaviour was repeated for all water planet symbols, dry planet symbols and ice planet symbols, but hostile planets and alien planets seemed fine (which would make for a rather PC unfriendly subsector!)

    I have also found that symbols from the Cosmo bitmap A Traveller Symbols catalog (starports and planetary names I'm looking at you) were also impossibly small.

    I then went to a saved sector file I had made previously, and tried to place a new planet symbol from the Cosmo bitmap A Traveller Systems catalog. This time the default symbol covered a whole sector? Luckily the control button would allow me to resize it. The symbols from the Cosmo bitmap A Traveller Symbols catalog did seem to be behaving as I would expect when I tried these out.

    My computer's system disc died recently, so I have just reinstalled Win7 home, CC3+, DD3+, CD3+ and Cos3+ along with the latest update (17a).

    Any advice on how to restore my catlogs to 'default' sizes would be greatly appreciated. I have had a look at the CC3+ manual but could not seem to find the answer in there (unfortunatley I'm not very good at RTFM and so may have missed the obvious).

    Cheers Alan
    • CommentTimeSep 19th 2018
    After digging a bit, I found the reason for this behaviour.
    First of all, the sector templates operate on a default symbol scale of 0.025. This makes the planets and other symbols fit perfectly. However, there is an issue, because some of the symbols are already defined in the template at a much smaller scale. (They're scaled so that when placed with a symbol scale of 1, they are correct). When CC3+ encoutners a symbol in a catalog that is already in the map, the one in the map will be re-used, but because the on in the map was already a reduced in scale, applying the default scale (0.025) on it makes it tiny.
    For the giant size symbol, the opposite happens. For some reason, the symbol scale is not defined correctly in that map, and when the symbols are placed using symbol scale of 1, they get huge.

    The short term fix here is to manually set symbol scale to 0.025 when placing the gigantic symbols, and manually set it to 1 in the cases where you get the tiny ones. To set the scale on the fly, just right click in the map with the symbol on the cursor ready to place and type in the value in the scale field.
    • CommentAuthorJimP
    • CommentTimeSep 19th 2018
    Yeah, the symbols for the capitals, x-boat bases, etc. are tiny. I use a scale of 1.5 on them.

    Like Base Other 2 C15 The CosA_All.fsc shows a size of 0.0.

    Same for Base Navv 2 C15 in CosA_Traveller.fsc, which has a large number of 0.0 size symbols. Some are white letters, soe are vari-color letters, the rest are basic shapes.
    • CommentAuthortomponzi
    • CommentTimeSep 19th 2018
    Many thanks for the work around guys, it worked a treat.

    Now to plan that subsector of hostile and alien worlds .......