Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorPeteF
    • CommentTimeApr 22nd 2018 edited
     
    When I draw lines such as roads with dotted or dashed line styles I get intermittent parts where the style breaks down. See attached screenshots I have played around with the line style editor and cannot get them to go away. Any ideas what is going on?
      roads.png
    • CommentAuthorPeteF
    • CommentTimeApr 22nd 2018
     
    Another example here
      roads2.png
    • CommentAuthorSaito S
    • CommentTimeApr 22nd 2018
     
    I have encountered this as well, it seems to be a bit of a quirk with CC3 when it needs to render a segmented line like that.

    As far as I know, there is no way to change the line style or drawing tool properties to prevent it from happening in the first place, but it can be fixed after the fact with the "stretch" tool. You can find this tool by right-clicking the "move" icon.

    Of course, you don't actually want to move your road too much, so I've found it's best to make the stretch window as small as possible while still catching nodes (where to put the stretch window to catch nodes can be hard to see on a smooth path, so you may have to try this a few times), and then stretch that section just a bit. In most cases, you don't have to move it very far to eliminate those "block" portions.

    Note that sometimes, stretching the path can eliminate one "block" and create a new one elsewhere in the path. I've found this to be very uncommon, but it CAN happen, and then it turns into a bit of a whack-a-mole game as you keep stretching it and new ones pop up as old ones disappear, and it can take several stretch operations in total to get them all gone. Hopefully that won't happen to you, but it's something to be aware of.
    •  
      CommentAuthorOldGuy
    • CommentTimeApr 22nd 2018
     
    I've had this pop up from time to time. In my case it seemed to be related to clicking too closely together along the intended path. It doesn't appear to be the case in your drawing but it is one more thing to check.
    •  
      CommentAuthorRalf
    • CommentTimeApr 23rd 2018
     
    Yes, that is indeed a problem that plagues paths with dashed line styles. The problem becomes more pronounced when nodes are close together, so deleting some nodes helps. You can also just move some nodes around a bit, that can help as well.
    • CommentAuthorPeteF
    • CommentTimeApr 23rd 2018
     
    Thanks for all of your comments and advice. I may end up doing a little post processing - we'll see. I am a little surprised that this bug occurs in what is essentially a very mature CAD engine.
    • CommentAuthorWyvern
    • CommentTimeApr 27th 2018
     
    It's particularly irritating, because it also happens with circles - on which you can't reduce or move the nodes, or alter their separation, of course.

    Is it a facet of the CAD engine? It doesn't seem to occur in other types of graphics program, as far as I'm aware.