Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
  1.  
    So I followed the instructions here; http://forum.profantasy.com/comments.php?DiscussionID=7955

    It worked a couple of times, but now is failing.

    I installed the Q8 64 bit version with the legacy option. Moved all the files into the CC3Plus image magic folder like instructed.

    When I do a Save As not in CC3+, I can see the file.PNG.BMP being created, the export window does it stuff, but as soon as it finishes, the window goes away, the file is gone and no PNG or JPG file is in the folder.

    I also notice the sheets status window in CC3+ shows the file name (attached).

    I'm at a loss of how to troubleshoot this.

    Thanks.
      Screen Shot 03-27-18 at 08.44 PM.PNG
    •  
      CommentAuthorMonsen
    • CommentTimeMar 28th 2018
     
    Try adding the debug code from my first post in this thread: http://forum.profantasy.com/comments.php?DiscussionID=8000. Should prevent the window from closing so you can ready any error messages that might show up. (Note that the debug only works properly for the first export after starting CC3+, so restart CC3+ between each attempt)

    The status bar glitch is a know problem, and unrelated.
  2.  
    Thanks Monsen. I'll try that at lunch and post back.
  3.  
    I put in the debug code (tried putting it in here, but won't show up)

    Attached is a screen shot of the export. I'm trying to export (in this case) a rectangular JPG of 2800x5800 (@600dpi)

    Everything seems ok, except no file is created. I'm using ESET A/V, but I've checked the log files and nothing there.
      Screen Shot 03-28-18 at 12.03 PM.PNG
    •  
      CommentAuthorMonsen
    • CommentTimeMar 28th 2018
     
    hmm. Weird.
    Looks like something is preventing the file from being written. If convert.exe couldn't be started at all, CC3+ should show a dialog with an error message. Just for testing purposes, can you try save the image in a completely different location.
    Also, have you turned on any folder protection systems, such as the (relatively) new built-in 'Controlled Folder Access'

    You can also try that command line manually just to see what happens. When you have debug on, the temporary file shouldn't be deleted untill you follow the prompt and hit that key, so before doing that, open a command prompt, change to c:\program files (x86)+ProFantasy\CC3Plus\ImageMagic and then run convert.exe followed by the exact command line you see in the export status window. I am curious if that would provide additional information.
  4.  
    So running the command line gave a lot more clues (great idea there). See attachment.

    So, after I installed IM Q8 64, I moved everything into the CC3Plus folder (renamed the current ImageMagick folder and moved int he new one). I wonder if the new version or the evnironement variables or registry is trying to have the 64 bit executable trying to point to the original install location.

    I'll look into those things and let you know. But if anyone knows for sure if that's the problem, let me know :)
      Screen Shot 03-28-18 at 07.52 PM.PNG
    •  
      CommentAuthorMonsen
    • CommentTimeMar 28th 2018
     
    It shouldn't care about the original install location, but it is clear that it is missing the library for dealing with .bmp files. Unless you have a static compiled build, this should be one of the .dll files accompanying convert.exe.
  5.  
    Ok, so either I misunderstood or installed the wrong version of image magick.

    I copied the files back to the install location (environment path and registry had numerous entries). I then just copied the files convert.exe and vcomp120.dll into the C:\Program Files (x86)\ProFantasy\CC3Plus\ImageMagick folder.

    All is working now.