Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    So I've got two issues when turning on effects.

    The first one has been happening for awhile, but I have a work around for. I suspect it's the size of the map and number of entities, but not sure. When I turn on effects, CC3+ always goes to a green background and every 20-30 seconds the map image flashes and returns to green. This seems to continue indefinitely (at least 10+ minutes) unless I right click on the Sheets icon and select Effects On a second time. In which case it then flashes one more time and then renders the map with effects on. Any ideas on if their is a way to solve it?

    Number two just happened (same map). When I turn on effects, the whole screen (beyond the map borders if I zoomed out) gets a blue-green tint to it. I don't think I have any effect that would do this, but it might be an issue with a Glow effect. But, I've tried hiding all sheets to see if I can isolate it. But the issue persists. I went back to an autosave map and it does not have this issue. Have tried exiting CC3+ and re-opening the map, but it still appears when I turn on effects (using workaround above). Any ideas?
      Screen Shot 03-17-18 at 01.28 PM.PNG
      Screen Shot 03-17-18 at 01.18 PM.PNG
    • CommentTimeMar 17th 2018 edited
    For the green rectangle, check for glows that are expressed in percentage of view width. Also remember to check for "entire drawing" effects. One of those may be the cause.

    I don't have a fix for the first issue unfortunately, happens to me too sometimes on complex maps.
    Thanks, I can't find it. Just going to go back to a previous save. Will lose less time than spending anymore time looking for it :(
    • CommentAuthorLoopysue
    • CommentTimeMar 18th 2018 edited
    It may be as Remy says, and not that difficult to put right.

    Sometimes effects go in the wrong place - especially when you have just created a new sheet and there's nothing drawn on it yet.

    Effects should by default be added to the Selected Sheet. If you click the Whole Drawing radio button there shouldn't be anything there. If there is, then delete it.
      wrong place.png
    • CommentAuthorScottA
    • CommentTimeMar 18th 2018
    Yes, I have found that every now and then for some reason effects go onto the Whole Drawing button instead of my Selected Sheet. Don't know why that happens, but once I figured it out its an easy fix to remove errant effects from the Whole Drawing button (and I restart CC3+ and that misplaced effects issue stops).
    Thanks, I will double check the Whole Drawing setting again. Maybe I missed it first time through.

    I have also thought about deleting the most recently added sheet and seeing if that helps.
    • CommentAuthorScottA
    • CommentTimeMar 19th 2018
    I had some issue once where I went through and tuned every sheet off and then turned them on and off one at a time until I found the culprit. A bit tedious, but its better than chucking out a map you've already put time into.
    Ok, so I've played this with some more and hoping someone might have an idea...
    I can delete every sheet but one, and the effect remains. I've tried leaving behind several different sheets as the last one, and the effect is still there. But, as soon as I delete the last sheet it goes away. I've also added a new sheet, and deleted all the others and it goes away.

    I'm going to keep exploring, but if anyone has any ideas, it would be appreciated :)
    What I did find out is if I load another set of preset effects (like Dungeons of Schley, etc), the issue goes away. I saved the effects that are causing problems, and apparently it creates an fcw file. I've attached it, but opening in a text editor or CC doesn't tell me anything. Maybe something means something to someone else?
    • CommentTimeMar 26th 2018 edited
    When I load this setting into a new map, I get a whole bunch of effects on the "Whole Drawing" list, causing the green tint. See the attached screenshot. Deleting these fixes the strange appearance. Can you do that on your map? I.e. just reapply the Bad Effects setting, then delete the entries from the Whole Drawing list?

    If that does not help, please post your original drawing FCW file so we can take a look at it.
    • CommentAuthorLoopysue
    • CommentTimeMar 26th 2018
    It can happen that even though you have the 'Selected Sheet' radio button selected when you add a new effect, the effect seems to slip across to the 'Whole Drawing' panel without your say-so.

    If when you add a sheet effect and it doesn't appear in the Selected Sheets panel, don't just assume it hasn't worked and try adding it again. You need to check that it hasn't sneaked off to the Whole Drawing panel.

    If you find it on the Whole Drawing panel delete the effect (not the sheet).

    If you are having trouble trying to make an effect 'stick' to the Selected Sheet its quite likely because there is nothing drawn on that sheet (that's when it always seems to happen to me). What I do to get around this problem is create the sheet without any effects, close the dialog by clicking OK, then go and draw or paste something on the new sheet. Once there is something on the sheet I go back to the Drawing Sheets and Effects dialog and start adding effects.
    Thanks Ralf and Sue.

    I feel ... almost stupid :)

    So, I thought the "Whole Drawing" radio button was per sheet. So, I had looked through each sheet to make sure the "Whole Drawing" button wasn't checked. Which I now know isn't the way it works. Instead, I just needed to toggle on "Whole Drawing" and check the effects there (those that are not related to a sheet).

    Thanks everyone, sorry for taking your time :)
    • CommentAuthorLoopysue
    • CommentTimeMar 26th 2018 edited
    Not stupid - just mildly confused. And... well, lets face it... we all start out a bit confused because CC3 is VERY different :P
    I come from a CAD background, so it's not too different for me *G*
    Anyway, PEBKAC was the problem. I'm a big boy, I can admit it :)
    • CommentAuthorLoopysue
    • CommentTimeMar 26th 2018

    I get that ALL the time :P