Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    Hey there, I'm in the process of installing all of my components on my laptop and am following the installation guide but wanted to address a concern before I go any further. When I just tried to install Cosmographer for CC3+, a message indicates my version of CC3+ is too old. The installation order on the site indicates I need to install all my components first and then apply the update. Apologies if I'm missing something or if this question has been answered elsewhere on the forum (I did a search and got no hits, just general info about installation order).

    Essentially my question is can I safely install all of my components like Perspectives and the Annuals, apply the latest update and then install Cosmographer 3+? Is it safe to apply the patch and then add upgrades later without having to uninstall and reinstall everything?

    Does that make sense?

    Happy 2018 everyone!
    • CommentTimeDec 29th 2017 edited
    Yes, you can do that. The easiest thing for you to do, I think, is to install the update, install whatever else you have left, and then reinstall the update. Just be sure to install the update after installing anything else (even if you already installed it).

    Happy New Year!