Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorAltheric
    • CommentTimeDec 9th 2017
     
    Hi,

    Ive only recently come back to CC mapping after many years and have encountered an issue with the two commands Bring Infront of and Send Behind, I dont know if its just my system and I need to reinstall or if its a config or a wider issue, or how Im using them.

    Essentially when I select the command from the side bar it looks as if its is ready to go but as soon as I click on the map more often then not nothing happens, no selection area will appear etc, its like a dead command. Maybe once in 20-30 frustrating clicks will I get things to be selected and even then I cant seem to get things to work how I want them to function, so this may be entirely user error.
    However if I was to use the Bring to Front in the same way, a selection field box does appear and items can be selected.

    Any insight or ideas would be greatly appreciated.

    Thanks
    Altheric
    •  
      CommentAuthorMonsen
    • CommentTimeDec 9th 2017 edited
     
    Remember that Bring Infront of and Send Behind both requires you to first select a single entity that your selection will be sent infront/behind, and then you get to select the actual entities. Since the selection of the 'target' entity is a single entity select, it means that you must select an entity directly (by clicking on the edge of the entity [or baseline for text]) or the command will abort, it will not give a selection rectangle like you would have for a normal selection when clicking in the map, either you click on the edge of an entity to target it, or the command ends if you didn't click on a valid entity. If you look at the command line while working, you'll see that it first asks you to pick the entity to move above/behind, and only when that is done, it will transition to the familiar 'select entities' prompt.

    Bring to front/send to back on the other hand brings entity all the way to the front/back instead of relative to a target entity, so these will start out with the regular selection process.

    Also remember that these commands only works within the current sheet, if you want something to be in front of something on a different sheet, you must move the entity to that sheet, or a later sheet in the draw order.
    • CommentAuthorAltheric
    • CommentTimeDec 9th 2017
     
    Ok Thanks.

    In that case then, is there a way to be able to see (turn on) the edges of the entities so they are easily selected, else it seems to be pot luck to be able to select it.

    Thanks
    •  
      CommentAuthorMonsen
    • CommentTimeDec 9th 2017 edited
     
    There are no special command to do that, but edges should be quiet clear unless you have enabled effects on them with edge fade/glow/blur type effects, in which case I recommend you turn off effects temporary, or if you have multiple entities with the same fill overlapping each other.
    You can also increase the aperture size of the pick cursor from Tools -> Options, this also makes picking easier.
    • CommentAuthorAltheric
    • CommentTimeDec 9th 2017
     
    Ok, thanks again.

    Yeah I was using it for altering some symbols I had added after the fact, finding the "edge" of those was what I meant, found that if I selected them with a different option first it would highlight them, then I would just need to remember where the edge was :)

    Thanks for all the help, cleared up alot of my miss understandings about the use of the command

    Thanks
    Altheric