Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorspkruegs
    • CommentTimeDec 8th 2017
     
    Hi, guys! I'm new to ProFantasy and the boards. After perusing the forums and trying all the answers to the questions that resembled mine, I had no luck. So here I am to gain some insight as to why FT3 Demo won't work and how to fix it.

    I downloaded the Demo this morning. The install process went well. But as soon as I tried to launch it, I got the error, "THE CODE EXECUTIONCANNOT PROCEED BECAUSE mfc140.dll WAS NOT FOUND. REINSTALLING THE PROGRAM MAY FIX THIS PROBLEM."

    I've uninstalled and reinstalled. I've tried repairing. I've tried dropping MFC140.DLL into the app's download folder and into the C:\WINDOWS\SYSWOW64 folder. When I do either of those, the error I get is, "THE APPLICATION WAS UNABLE TO START CORRECTLY (0XC000007B)." I've also installed VISUAL STUDIO 2017.

    None of this has worked. I'm currently running a new Lenovo Flex 5, 64-Bit. Any Ideas? Please help!
    • CommentAuthorpool7
    • CommentTimeDec 8th 2017
     
    Although it was common back in the day, nowadays it's unsual and not really recommended to just copy files to c:\windows or its subfolders.
    A quick search seems to indicate mfc140.dll belongs to Visual C++ 2015; I'd suggest you install the latest redist package for that:
    https://www.microsoft.com/en-US/download/details.aspx?id=52685

    I'm not 100% sure if FT3 is 32 or 64 bits (or both), and I'm not sure if the 64 bits VC 2015 redist supports 32 bits, so you may want to try installing both 32 and 64 bits of the redist package.
    •  
      CommentAuthorMonsen
    • CommentTimeDec 8th 2017
     
    FT3 is 32-bit.

    Also, if the files you copied in manually were 64-bit versions, make sure to remove them before proceeding as well, as a 64-bit dll in the FT directory can very easily make problems even if the correct dll is installed on the system, because dll's in the program directory tends to override system installs. You'll probably want to remove them no matter what versions they were though, to make sure noting interferes with the files from the C++ instaler.
    • CommentAuthorspkruegs
    • CommentTimeDec 8th 2017
     
    Wow!

    Downloading the 32-bit redist worked 100%. I did not realize x86 was synonymous with 32-bit, so I was lost for a little bit. Thanks again for the quick and detailed answers! I'm excited to use this program.
    • CommentAuthorJimP
    • CommentTimeMar 1st 2018
     
    And worked for me to.

    The errors I was getting are: missing mfc140.dll, MSVCP140.dll, and vcruntime140.dll