Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
  1.  
    Hi All,

    I've used CC3 a lot but just started playing with City Designer 3. See the attached image. Why does my paved road look like it does on the right instead of the cobblestone look on the left from the sample image you get from CD3? I have sheet effects on, all layers, and have redraw the screen countless times.

    Thanks, Rand
      Paved.png
  2.  
    I don't know if I can explain this correctly, and if I do this wrong, I know Monsen or someone will set us both straight! But what you are seeing on the right, is what happens in the fcw when you enlarge the tile size of the bitmap fills. However, if you were to turn your fcw into a bitmap, jpeg or png, you would see the detail that you are looking for.

    If you were to look at the bitmap fills for cc3+, cd3, dd3 or any of the other profantasy programs, you may notice that some bitmap fills have preset scaling (looking at the bitmap fills window in cd3 it's down at the bottom and will have a check mark in it)... usually set to about 54... I believe that's tiles per square. The smaller the number, the smaller the tile. The problem is, every tile has a pattern on it, and depending on how many tiles you need to fill a space you are working on, that pattern repeats. Now, on something like your cobblestone, that might not be a big deal... but on things like grass, floor patterns, stone bitmaps... it becomes too redundant, meaning you get a lot of little tiles and the pattern doesn't look natural. So what most of us do, is we enlarge the width, and height of the tile, so that when we render it out (changing the fcw to jpeg, png or bitmap) it looks natural. The fcw can't handle the higher sizing, so it looks like it's pixelated. But once you render it out, it looks like it's supposed to.

    I hope that helps! :)
    •  
      CommentAuthorMonsen
    • CommentTimeOct 9th 2017
     
    To add a little bit to the above.
    It seems like CC3 is rendering the low-res version of the fill for some reason. Normally, it should render a higher quality when you zoom in.

    - Is this CC3 or CC3+. If it is CC3+, make sure that you have the latest update installed (Currently update 13a [and it is important that you install it AFTER CD3, so simply install it again if you installed it before CD3]. Then type the FFIX command on the CC3+ command line.
    - If this is CC3 (not +) or CC3+ AFTER you have done the step above, you can also manually select the quality from the Display speed dialog (button in leftmost toolbar). This shouldn't be required in most cases though, as CC3(+) will normally pick the appropriate quality based on your zoom level.
  3.  
    Thanks guys! That fixed it Monsen. Never would've figured that out :)
    • CommentAuthorKendall-DM
    • CommentTimeNov 7th 2017 edited
     
    So, I'm having this same issue. I created a multiple level castle, but the fills on floors 2 and 3 are pixelated and nothing I do seems to be able to undo that. I was using DD3 (I have CC3+ with CD3 addon as well, but I've recently re-installed this and have only designed this one castle so far).

    I've re-installed it again, but no love. I ran the update 13a (even after CD3) and still do not have a resolution outside of the pixelated version. The first level of my castle is not pixelated, just floors 2 and 3. When I created the multiple level castle through the wizard, I chose the background as dry grass (or something akin to it) and this was applied when the map was created through the wizard. That is, when I switched to level 2 and 3, the grass was already pixelated. I assumed that was for blurring higher up areas, but found out that it was being applied to all fills outside of level 1.

    Any idea how I can resolve this? Help?
    •  
      CommentAuthorMonsen
    • CommentTimeNov 8th 2017
     
    Did you try to run the FFIX command in the map as I outlined above?
    • CommentAuthorKendall-DM
    • CommentTimeNov 10th 2017
     
    Yes, I've done that. That map just won't let go of the pixelated floors and background, and even after running the command (and even rebooting to make sure changes are taking place) the new fills are still pixelated. Nothing has changed from before to after (all work was done in DD3 Pro for the CC3+ software, made a castle with multiple levels, first floor is fine, 2nd and 3rd floors are pixelated). I just can't seem to find the right setting to "fix" this. This was part of a re-install of CC3 (to CC3+).

    The current machine I'm working on has CC3.

    Since CC3+ was an independent install, I didn't remove CC3, but installed CC3+ and it's components as follows:

    Installed CC3+
    Installed update 13a
    Installed DD3 for CC3+
    Installed DD3 update for Shessar's fireplaces
    Installed CD3 for CC3+
    Installed CD3 update for random city command
    Installed Annuals

    Then, after read your instructions above, I re-installed update 13a (but this was after everything was pixelated and I came here and found this post).

    Ran FFIX command.

    No change from previous behavior, still pixelated.

    Could something in my install have been out of order beside just the update 13a for CC3+?
    •  
      CommentAuthorMonsen
    • CommentTimeNov 10th 2017
     
    Since you say this only happens on floor 2 & 3, can you check the fill style resolutions used in the map (Click display settings button, then click the fill style resolutions button. The values show in the resulting dialog should be similar between the first floor and other maps. If they are not, change them so they match the settings from the first floor map.)
    While you are in the display speed dialog, also make sure that the settings are set for automatic bitmap quality -> High. (You can temporarily override it by setting it to manual -> Very high, but I don't recommend keeping it on that setting.))
    • CommentAuthorKendall-DM
    • CommentTimeNov 10th 2017
     
    I thought I had checked that as well, but I don't recall if I was only looking at the first level or the other levels now that I think back. I'll take a look and let you know what I find out. Thanks for the help dude!
    • CommentAuthorKendall-DM
    • CommentTimeNov 11th 2017 edited
     
    Ok, I did this, but the setting were all the same in regards to what you had mentioned (I did already check this before). However, I never compared between levels, that I'm pretty sure of. All the levels had the same setting EXCEPT for Use Memory Cache for Bitmap, all of them were checked BUT the first level was set to Currently in Use of 24 while the other levels were set to 2. Not sure what caused that to happen, but when I un-checked Use Memory Cache everything worked again after running FFIX. Weirdness...

    UPDATE: And now everything is drawing very slowly on zooms and scrolls. Sigh...
    •  
      CommentAuthorMonsen
    • CommentTimeNov 11th 2017
     
    Without memory cache, it means the files needs to be loaded from disk each time the map is redrawn, such as when you zoom or scroll, so slowness in this case is certainly expected.
    But instead of turning it off, leave it on, then click the clear cache button, and finally force a redraw.
    • CommentAuthorKendall-DM
    • CommentTimeNov 11th 2017
     
    So, just clear the cache when I change between levels? I can do that, but I tend to switch between levels quite a bit, just have to remember to do this each time. Thanks for the help Monsen!
    •  
      CommentAuthorMonsen
    • CommentTimeNov 11th 2017
     
    It shouldn't be necessary to clear it each time, but if that seems to do it, I guess...

    One note though, if you switch between them often while working, I would really consider just having all the drawings open at the same time. It is faster to just switch to a different CC3+ window rather than load in a new map in the existing one all the time.