Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    Is anyone else having problems getting the right symbol catalogs in CC3+ using the annuals? I also seem to have symbols ending up on the wrong sheets periodically. I know it helps to be specific but this problem seems to occur in at least a few annuals and I haven't been keeping track. I will note specifics from now on but I was just wondering if anyone else had noticed a problem.
    • CommentAuthorTopdecker
    • CommentTimeAug 14th 2017
    If you mean that when you change to a particular group of symbols and anticipate the layer changing when the symbol is placed, but it remains on the current layer, yes, I have noticed that. I've not thought much of it since I really don't know the rules about layers automatically changing, but I remember being a bit annoyed since it seemed like it worked with some symbols but not with others.
    • CommentAuthorJimP
    • CommentTimeAug 14th 2017
    We had a big dicussion when sheets were abut to come out, and we requested that symbols go on the correct sheets.

    I don't remember a similar one for layers. I typically forget to check the layer...

    I know that most vegetation goes on the vegetation layer. But structures don't always go on the structures layer, they might go on building layers. I have to select some of the others, or they go on whatever layer i have active.

    But if you select the up and down icon, the up and down layer becomes active, etc.
    Okay, I finally have a definite example of the problem.

    I have CC3+ installed with all the annuals. I have updated to 13a. When I use style CA128 (parchment maps), I keep getting the Mercator symbols (CA01). All my tools seem to be okay (terrain, rivers, land, etc.), but I get CA101 effects presets on sheets (the classic parchment map annual). I think these kind of mix-ups are happening on other annuals. I just hope I don't have to reinstall the whole shebang.
    • CommentTimeAug 24th 2017 edited
    Yeah, it looks like there's a typo on the OnNew and OnOpen macros for the Wizard, and the wrong preset was accidentally saved as the default in the Wizard template as well.

    I've given the details to the ProFantasy folks but, in the meantime, you can easily correct them on your system while we wait for the official fix.

    For the symbols:
    1. Select Symbols>Master Settings Filters from the menu bar.
      The Master Filters dialog displays.
    2. Click Load.
      The Load master filter settings dialog displays.
    3. Select CA128 from the list and click Load.
      The Load master filter settings dialog closes and the correct master filter loads.
    4. Click OK.
      The Master Filters dialog closes.

    That will set the catalog buttons (Coast, Mountains, Structures, etc.) to use the correct symbol catalogs.

    To make this automatic for the current map:
    1. Type Notes and then press Enter.
      The Select note (Map Notes) dialog opens.
    2. Click OnOpenMacro from the list and then click Edit.
      The Edit Text dialog opens and displays the macro.
    3. Change CA28 to CA128 (insert a 1 ) and then click OK.
    4. Save the map.

    That changes the OnOpenMacro so it always loads the right master filter whenever you open the map.

    For the Effects, pick CA128 from the list of effects presets in the Drawing Sheets and Effects dialog and click OK. If prompted to save, click No. Then click OK to close the dialog.

    I hope that helps.

    • CommentTimeAug 25th 2017
    The problem should now be fixed in the installer for the Annual 128.
    • CommentTimeAug 25th 2017
    That was fast! Thanks Ralf.
    • CommentAuthorBarliman
    • CommentTimeAug 25th 2017
    Should we then download a new copy, or simply run the installer again?
    • CommentTimeAug 25th 2017 edited
    You'll need to download and run the new setup file. As always, right-click and select "Run as Administrator," if possible.
    • CommentAuthorBarliman
    • CommentTimeAug 25th 2017