Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorRobertF
    • CommentTimeAug 5th 2017
     
    I've carefully read through the posts on lighting in the forum, plus Joachim de Ravenbel's paper on light effects, but I still can't get the light effects to work properly in DD3.

    I end up with a completely black dungeon map except for the torch sconces.

    My Sheets are arranged as follows:

    LIGHT
    FLOORS
    WALLS
    SYMBOLS TORCHES
    LIGHTS FINALIZE

    with Wall Shadow, Point Light Setup activated in each sheet and Wall Shadow, Point Light Finalize in the last sheet.

    What am I doing wrong?
    • CommentAuthorjslayton
    • CommentTimeAug 5th 2017
     
    There are many, many things that can go wrong. Have you added lights to your map? If so, have you placed the lights on a sheet other than the one that your symbols are placed on? Placing a light inside of a symbol (e.g. putting a light inside of a torch) will cause the light to be occluded by the symbol.

    If you could upload your map (or one that displays similar problems), it would be much easier to diagnose the problem.
    • CommentAuthorRobertF
    • CommentTimeAug 5th 2017
     
    Ah, I think I just figured it out - the trick seems to be adding the light effects (via Dungeon > Lights > Add Light) *after* you apply the Wall Shadow, Point Light Setup and Wall Shadow, Point Light Finalize to the sheets under the LIGHT sheet.

    If you add the light effects *first*, then apply the Wall Shadows to the sheets, the whole dungeon ends up dark.
    • CommentAuthorRobertF
    • CommentTime7 days ago
     
    Wait, I'm running into the same problem again. The map turns black except for the torches once I turn on the shadow effects in the sheets.
      DD3_LIGHTING_TEST.jpg
    • CommentAuthorRobertF
    • CommentTime7 days ago edited
     
    Here is the Light menu, which I open in the LIGHT sheet.
      DD3_LIGHTING_TEST2.jpg
    • CommentAuthorRobertF
    • CommentTime7 days ago edited
     
    This is very strange - I'm duplicating the same steps I did last week, except now the lighting effects don't appear.

    Here's the room with shadow effects turned off.
      DD3_LIGHTING_TEST3.jpg
    •  
      CommentAuthorMonsen
    • CommentTime7 days ago
     
    Could you post your .fcw file? It is easier to identify any mistakes that way.
    • CommentAuthorRobertF
    • CommentTime6 days ago
     
    Here it is - thanks for your help Monsen!
    •  
      CommentAuthorMonsen
    • CommentTime6 days ago edited
     
    Your problem was that you had set the lights to be varicolor. Just as for symbols, this means they take on the color of the entity itself in stead of the color you define for the light, and the color of your light entities were black, making them basically invisible. Your lights are also very weak, you'll probably want to increase the radius a bit, and possibly the intensity. Also, you wouldn't normally need a wall shadow effect on your floors, you normally don't want those to block light and cast shadows.
    • CommentAuthorRobertF
    • CommentTime4 days ago
     
    Fantastic, - thank you, Monsen! Yea, I was blindly following the advice in Joachim de Ravenbel's Light Effects article, where he checked off the varicolor box.

    You ought to do a tutorial on light effects in DD3 and post on YouTube!
    •  
      CommentAuthorMonsen
    • CommentTime4 days ago edited
     
    Videos ain't my thing, I prefer the written word. And my written tutorial on the subject can be found in the tome :)