Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
  1.  
    I am a fairly basic user of CC3+, and I am trying to create a map from scratch, but I have encountered a couple of problems. I can't see them mentioned in any of the many videos I have watched, and a search of these discussions hasn't given me the answers - though I am sure that's just because I haven't happened on the right search terms.

    The first problem happens when I am creating roads or rivers using the normal tools. I create the wiggly line, and that's all fine, but when it draws I sometimes get, apparently at random, an extra artefact. It is usually a long thin triangle, connecting three points on my road or river, though sometimes it's just a line connecting two points. It is the same colour as the object, and if it happens to overlap the object at some point I get a "reverse" effect - so my river appears as a clear stripe through the blue triangle. The bug persists if I redraw the map, if I zoom in then the relevant parts appear, and it is still there if I save and reload.

    The other oddity also concerns roads. I have drawn a path (say) which is in its default brown. I want to make it into a road, so I select change properties, click on the road and change the colour to a suitable grey. When I clock OK the road turns grey, very nice thank you. However next time I redraw - either by a deliberate redraw or by zooming - the object reverts to the brown it started out as. I have tried several different times, with the same result.

    I am sure both of these are because of some simple setting or parameter I am misusing, but I have run out of things to try, so I would be grateful for any hints or tips.

    Thanks.
    •  
      CommentAuthorMonsen
    • CommentTimeJul 7th 2017
     
    The first usually happens because nodes are close together, combined with a sharp angle. Use Delete Node and remove one or more of the close nodes.

    For the second, is the road using a bitmap fill? You can't change color on an entity using a bitmap fill, the bitmap fill takes priority. To have solid colored entities, you also need to change the fill style to Solid.