Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorTopdecker
    • CommentTimeJul 4th 2017 edited
     
    Having some downtime, I thought that I would explore City Designer 3 and started with the first tutorial in the CD3_Essentials.pdf documentation.

    Step 5 asks you to draw a crossroads as shown:

    No pic

    Even though it is zoomed out, note the crisp cobblestones.

    I follow the instructions, but my road looks like some crap-ass video game from the late 80s. Looking at the properties suggest that it isn't going to improve for me:

    No pic

    I kind of expect my stuff to look almost exactly like the tutorial. So is my install borked or do the instructions not match how it will work by default?

    Thanks!

    Tim
    • CommentAuthorTopdecker
    • CommentTimeJul 4th 2017
     
    Ok, I pretty much figured it out. It was using the lowest resolution bitmap by default. In this case, CD3A_Cobbles_VL.png. Changing it to CD3A_Cobbles_VH.png corrected it.

    Is there some global setting I can toss to insure that I never, ever use anything but the highest quality graphics? I have an upper end system and don't need further grief.

    Thanks!

    Tim
    •  
      CommentAuthorDogtag
    • CommentTimeJul 4th 2017 edited
     
    Click the Display Speed Settings [button: Display Speed Settings] button (on the left) and check the settings. They should default to Automatic bitmap quality and High (normal).

    If those are the settings and you're still seeing low res bitmaps, you can select a Fixed bitmap quality instead. Be aware, however, that changing to a fixed high or very high resolution can affect speed and responsiveness. Normally, it's a lot better to let CC3+ handle resolution automatically so it uses the appropriate high resolution when you're zoomed in far enough to notice the difference. However, for a small map at a medium scale, like the one you're making for the tutorial, it may be fine. Believe it or not, when you're zoomed out, lower resolutions often actually look better but that may not be the case here because of the scale of the map (just a guess).

    I hope that helps.

    Cheers,
    ~Dogtag
    • CommentAuthorTopdecker
    • CommentTimeJul 4th 2017
     
    Thanks, Dogtag!

    I checked the display speed settings and they were as you had suggested. So I tossed them over to FIXED - VERY HIGH and nothing changes.

    I have to go in and assign the texture by hand. (Tools --> Set Properties --> Fill Style). When I get there, the texture is set to #Bitmaps\Tiles\City\CD3\Bitmap A\CD3A_Cobbles_VL.PNG.

    When I restart a new drawing, the settings are retained (FIXED - VERY HIGH) but the bitmap assignment has returned to the lowest res. It also renders with the VL texture.

    Tim
    •  
      CommentAuthorMonsen
    • CommentTimeJul 4th 2017
     
    Run the FFIX command on the map, that will replace all the #-references with @-references.


    As for the technical explanation why this fixes it:
    - CC3+ normally selects the resolution automatically, changing the _VL to _VH or similar actually has no effect whatsoever, because it will pick the appropriate one for the set.
    - However, when CC3+ was released, a new directory reference, @, was added, that point to the data directory where resources now are stored, instead of # (the installation directory) where CC3+ kept everything.
    - To not break old maps, CC3+ automatically redirects #-references to @-references if the file isn't found, but this DOES NOT work with the automatic resolution
    - FFIX replaces all # with @, thus restoring automatic resolution functionality.
    •  
      CommentAuthorDogtag
    • CommentTimeJul 4th 2017 edited
     
    Cool. I was going to suggest FFIX next, but I wasn't sure if it would fix the auto-res issue. It would've just been an educated guess.  :D
    • CommentAuthorTopdecker
    • CommentTimeJul 4th 2017
     
    This did fix it, thank you!

    So basically, because they did not update the templates to match the version of the software, it requires the FFIX command. If I had not used the template, I'd have experienced no problems.

    The simple solution, and the one that I will adhere to, is to never use a Profantasy templates again, especially since it is now clear to me that they don't maintain them. (There is no good excuse for beginner level tutorials to result in hours of troubleshooting, especially when it is glaringly obvious that someone just needs to open each template, run FFIX against it, and package it with the software.)

    Tim
    •  
      CommentAuthorMonsen
    • CommentTimeJul 4th 2017
     
    Sometimes errors slips through, like a file that was forgotten, or the wrong file made it into the final installer. That's why it is important that people report errors they experience to ProFantasy so they can be fixed in a later update.
    •  
      CommentAuthorRalf
    • CommentTimeJul 5th 2017
     
    I've just double-checked our installation files, and the template "CD3A 500'x400' Village.FCT" (as given in the Essentials Guide) should have the corrected bitmap fills (with the @ reference) as of January 2016. It was indeed a bug in the original release, but has been fixed for quite a while.

    May I ask when you downloaded and installed the setup for CD3 for CC3+? I'm just wondering why the bugged template turned up for you - we do try to maintain everything properly working with the latest versions, but of course sometimes problems slip through.
    • CommentAuthorTopdecker
    • CommentTimeJul 5th 2017
     
    It was downloaded around March of 2017, I think, right after I purchased everything. I have cached all of the installers.

    FWIW, I uninstalled and reinstalled everything and have the same behavior. I also have CC3+ installed on a Windows 10 tablet and have the same thing happening there. Everything is using the same install source and I can get you the particulars on those if you want the info.

    Tim
    •  
      CommentAuthorRalf
    • CommentTimeJul 6th 2017
     
    I'll double-check all these and we'll be doing a new update soon, where I'll try fix this issue not being properly corrected. I'll get back to you if I need particulars about your setup, thanks!