Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
  1.  
    EDIT: I got the Copy to Sheet working using Layers hiding rather than Sheet hiding. However, this was using a CC3 template (at first) rather than the DD3 template. Then I tried making a new blank DD3 template (which the Tome map below is based on), and the difference was that the TEMPLATE layer was frozen. So I unclicked Frozen, and I got it to work with a simple map I made. Still haven't managed to do it completely successfully with the Tome map (I did copy the background and walls over but other stuff I haven't conquered yet), so I think the TEMPLATE layer being frozen has something to do with.

    But if someone with more knowledge could chime in with their thoughts after reading below, that would be great. I can't quite understand why it worked with hiding layers but not sheets.

    EDIT 2: No one will be surprised that Monsen had the answer. Scroll down for his comment.

    ----------------------------------------------------

    Hi there. First post after a decent lurk.

    I'm working through various parts of the TOUM, and am especially interested in floor masks for that great dug-out look.

    I've seen this post, but it's not helping me.

    Specifically, in the Tome it says to start the process by copying the map background to the FLOORS MASK sheet and then do the same with the walls. I can't seem to do either.

    The steps I've tried are (using Chapel Mandina Catacombs 14.FCW that comes with the Tome package):

    1. I Autohide all but the Background sheet, and then try Copy to Sheet with a right click of the Copy button, clicking on the edge of the background to select it.

    Screenshot 2017-05-13 15.02.45.png

    2. I right click and Do It, and then select FLOORS MASK in the dialogue box that pops up and hit ok.

    Screenshot 2017-05-13 15.12.30.png

    3. The screen goes blank, and even after clicking redraw, nothing shows. The Autohide is still on, but I have FLOORS MASK as the current sheet, so by my thinking it should show the background that was copied. If I try a List and hit A (for Select All) and the Do It, no background entity comes up in the list, just the following:

    Screenshot 2017-05-13 15.17.50.png

    The same goes if I try Copy to Sheeting the walls.

    I've tried doing it by entity tag which DOES seem to work on the background, but not the walls.

    Also,

    Anyone have any clues? I can get Copy to Sheet working with, say, a box I draw -- but not a background or the walls. (And the walls are a polygon when I check with List command).

    Thanks in advance.
    •  
      CommentAuthorMonsen
    • CommentTimeMay 13th 2017
     
    Don't make the FLOORS MASK the active sheet when copying to it. What happens when you do this with auto hide on is that the sheet the background was on gets hidden (before the copy takes place), and entities on hidden sheets cannot be selected, so you will loose the selection, and nothing will be copied. You should take care to only select the sheet in that box, NOT click the checkbox to make it active.
  2.  
    *Facepalms*.

    Many thanks. Seems so obvious now.