Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorTriphos
    • CommentTimeJul 30th 2016 edited
     
    Hi,

    I just picked up Perspectives 3 and I'm having trouble with the grid and snap settings. The dots of the grid, that the floor and wall tools are snapping to, is about an 8th of a square off of the isometric grid overlay. It's not enough to make the program unusable, but it's really throwing me off. Any suggestions on how to line the two grids up, or have the tools snap to the lines instead of the dots?

    I've included a picture that will hopefully illustrate what I'm talking about, you can see that the grid dots aren't at the corners of the drawn grid.

    Thanks for your time.
      Capture10.PNG
    • CommentAuthorjslayton
    • CommentTimeJul 30th 2016
     
    If you save the file, exit CC3+, and then restart CC3+, does the grid align then?
    • CommentAuthorTriphos
    • CommentTimeJul 31st 2016
     
    No, nothing changes.
    •  
      CommentAuthorDogtag
    • CommentTimeJul 31st 2016 edited
     
    I ran into the same problem. They mostly went away when I right-clicked the Grid button and chose the Isometric 5' grid option. Also, when you set up your grid overlay, do you make sure the Draw options for the snap settings are selected? Checking those options [should] make the drawing grid (the dots) line up with the grid overlay.

    (Click the images for larger versions)






     

    I'm unclear why "Centers" seems to line up with both the center and the corner of the grid overlay. It's just what seems to happen right now. It may be a bug or it may simply be because of the isometric grid — I haven't really looked into it on a normal square grid. But, there you have it.

    I hope that helps,
    ~Dogtag
    • CommentAuthorTriphos
    • CommentTimeJul 31st 2016
     
    Whenever I create a new map, the "set snap grid" options that fixed it in your case are greyed out and unable to be toggled. Is there some other setting that prevents me from changing those options?

    Thank you for the help, btw, it looks like it will fix my problems once I can access the setting.
      Capture11.PNG
    •  
      CommentAuthorDogtag
    • CommentTimeJul 31st 2016
     
    Okay, that seems weird. When you create a new map, are you using a pre-defined template, or are you choosing the settings for yourself? Perhaps that has something to do with it. I rarely use pre-defined templates.
    • CommentAuthorTriphos
    • CommentTimeJul 31st 2016
     
    I just use File > New and then select Perspectives > Decide settings myself > Pick a map style (I've tried several different styles and get the same issue with all of them) > Set the size.

    When I get to the next screen, grid overlay is off by default so I turn it on. This enables the "Grid setting" button, and I attached a screenshot of the default settings it gives me when it pops up.

    On the grid setting screen I change the option to Isometric, the spacing to 5, and that's all I can select.

    I've tried going through the Overland and Dungeon map types and the grid settings window always gives me these exact same defaults.
      Capture22.PNG
    •  
      CommentAuthorDogtag
    • CommentTimeJul 31st 2016 edited
     
    Ah. Ignore the grid options in the New Map Wizard. When you finish the wizard and the new map loads, select Draw>Hex or Square Overlay from the menu bar.
    • CommentAuthorTriphos
    • CommentTimeJul 31st 2016
     
    It works! Thank you so much, that was insanely frustrating.
    •  
      CommentAuthorDogtag
    • CommentTimeJul 31st 2016 edited
     
    Woo-hoo!   I'm glad I could help.

    Cheers,
    ~Dogtag
  1.  
    Hi peeps, I hope this is not a dead thread but I am having the same issue with perspectives and I cannot get it to straighten up and work. see attached.
      wonky grid.png
    •  
      CommentAuthorMonsen
    • CommentTimeNov 8th 2018
     
    Seems like a genuine bug. The snap grid is actually fine, but the visual grid draw on the screen isn't. You can see that the top corner of each grid "square" doesn't align with the bottom corner, they should be right above each other.

    I've reported this to ProFantasy so they can look into it.
  2.  
    Thank you monsen, I thought I was going crazy!
  3.  
    Monsen, did profantsy give any idea on timings. Just that I really want to dig in but the grid throws me off too much and my brain doesn't like not having the grid 😭
    •  
      CommentAuthorMonsen
    • CommentTimeNov 9th 2018
     
    No. Timing is always difficult, too many variable affecting it.

    In the mean time, you can draw the grid manually. If you first create the grid the regular way, then delete the grid drawn on the screen. This will leave just the snap grid, which does work fine. Then, set the GRID sheet and HEX/SQUARE GRID layer active, and draw each grid line using the line tool. The snap grid should help you do this quickly. Just freeze the HEX/SQUARE GRID layer when done.
  4.  
    Thank you so much for the work around, now all I need is for my 8 month old baby to go to sleep so I can play 😂
    • CommentAuthorJaume
    • CommentTimeNov 18th 2018
     
    Hello,

    I am having same "Bug" problem as @Kieronwilliams80 :(

    Did Profrantasy staf say anything about? because is really hard ( to not say impossible ) to draw without perspective grid.

    I could not fix the grid, and if I see i am not the only one... would be nice to have some solution... or at least an answer from the admins or staff support.

    Regards,
      GridBug.jpg
  5.  
    @Jaume I did as Monsen suggested and did it manually. Helps in the short term but it is a little time consuming
    • CommentAuthorLoopysue
    • CommentTimeNov 18th 2018
     
    I have a blank FCW where I've drawn the grid. I just open that one up each time and save it as a new name before I start work so I've always got it again for the next time.
    • CommentAuthorJaume
    • CommentTimeNov 19th 2018 edited
     
    Thank you guys.

    I have spoken with ProFantasy and it looks they ve ready a new update to fix this Bug.

    @Loopysue is there an option to share your grid?
    • CommentAuthorLoopysue
    • CommentTimeNov 19th 2018
     
    I would share it now, but if the fix is just around the corner I might unnecessarily clutter and confuse the issue.

    Any idea when this update is due?
    • CommentAuthorJaume
    • CommentTimeNov 20th 2018
     
    Actually They just wrote me, I have the update that fix it.

    Do you?
    • CommentAuthorLoopysue
    • CommentTimeNov 20th 2018 edited
     
    Not yet, Jaume, but I'm a bit busy doing something else right now, so I can wait until the official release.
    • CommentAuthorJaume
    • CommentTimeNov 20th 2018 edited
     
    I can share it to you I guess. I cannot share a picture with the succes... WTF xD

    mmm I am afraid to share the link, maybe I am not allowed... Well they didnt tell me about it... so...

    Here is the update that fix the bug.
    • CommentAuthorLoopysue
    • CommentTimeNov 20th 2018 edited
     
    Thanks Jaume, but I already have my own solution at this end.

    I am quite happy to wait for the official update :)
  6.  
    I haven't had the fix, is it worth contacting Ralf?
    • CommentAuthorLoopysue
    • CommentTimeNov 20th 2018 edited
     
    Unless your need for it is immediate, it might be best to wait for the update with the rest of us. Beta versions are usually ok, but they are only beta versions.

    Besides - Profantasy isn't like other software companies. It doesn't take them 2 years to respond to things like this, so it won't be a very long wait, I'm sure :)

    In case you are wondering, I didn't go chasing it because I knew it was only a beta version. I've been given a similar emergency fix in the past for something else when I was working on a set of symbols. The fix was incorporated into the very next update that happened to come out a fortnight later.
  7.  
    Realizing that this thread is extremely old, I ran into the same challenge as the OP. For the life of me, I could not get the visual grid to align with the snap grid. This makes the Essentials Guide UNUSABLE until that setting change is stumbled upon. Is it possible that the EG could be updated to include this information?
    •  
      CommentAuthorMonsen
    • CommentTimeMar 16th 2019 edited
     
    Have you installed the latest CC3+ update? This was fixed long ago.
  8.  
    <blockquote><cite>Posted By: Monsen</cite>Have you installed the latest CC3+ update? This was fixed long ago.</blockquote> I installed Perspectives 3 within the past week. I am specifically referring to the lack of documentation in the Essentials Guide, NOT an actual glitch in the software - just to be clear. Has the Essentials Guide been updated?

    More context: I am going through the essentials guide now, and on the version I have, there is absolutely no discussion of specific grid settings and no reference to any of the steps listed here by Dogtag. The EG simply assumes that the proper grid settings are in place, when in fact, they were not for me. I spent at least forty minutes using trial/error before searching the forum, where I found this thread.