Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthornhajek
    • CommentTimeOct 14th 2008
     
    Hi all,

    I just downloaded SS3. I have CC3 and CD3 installed on my computer. I have some issues with CD3 also, but I've figured out a work around with that so I'll stick with this for now.

    When I try to select any of the first eight tools on the top left it gives me the error saying that:

    No matching draw tool
    There is no draw tool matching your selection in the current draw tool style.

    What confuses me is that the header for the error says CC2. (You can see all this in a file I am attaching) I get the same error sometimes in CD3.

    I'm assuming I should be able to access these tools as they look different than the others for CC3 and CD3. This may be related to some other problems I have in CC3 and CD3 where when I switch symbol styles and it suddenly can't find any symbols at all. So I have to go through the files manually looking for what I want. It's like the program doesn't always know where stuff is or gets lost as it tries to navigate it's way around.

    Any thoughts or solutions?
    Thanks,
      Error.jpg
    •  
      CommentAuthorRalf
    • CommentTimeOct 16th 2008
     
    Did you install the SS3 compatibility upgrade? See the rehgistration page for the download. If you mistakenly installed SS3 for CC2 Pro in the CC3 folder, your installation might be messed up, and you'd need to reinstall.

    For the drawing tools to work, you need to load the correct template. Start a map from any CD3 template, load the correct menu and the drawing tool buttons should work.

    The "CC2" heading in the error message is a legacy piece of text in the code, which we'll fix in one of the upcoming patches. Nothing to worry about, it's just that little heading name and doesn't affect anything.
    • CommentAuthorbravefaces
    • CommentTimeOct 21st 2008
     
    Ralf,

    I get the same error when I try to create an overland map and then switch to DD3. I only have CC3, DD3, and CD3 installed. I'm trying to design a hut on a coastline. I tried changing the drawtools style under drawing properties- but the only thing that shows up for floors is flat color, none of the nice cobblestone, or marble etc. How do I get past this?
    •  
      CommentAuthorMonsen
    • CommentTimeOct 22nd 2008
     
    The overland maps doesn't have the same fill styles available.

    To make these available in the map, use the Draw -> Insert menu to insert a dungeon map (The .fcw file) into your overland drawing. Then use undo to remove it again. All the fill styles from that map should now be available. Just make sure the map you inserted is the correct one for the draw tools set you are going to use.
    • CommentAuthorbravefaces
    • CommentTimeOct 23rd 2008
     
    So are you saying I need to have the floorplan done first and then insert it? Or is this inserting a working area for for the dungeon where I can do the work in the complete map?
    •  
      CommentAuthorMonsen
    • CommentTimeOct 23rd 2008
     
    No. You just have to insert ANY dungeon map (That contains the appropriate fill styles)
    The insert procedure in itself will copy the fill style definitions you need into the overland map, so you can use them. Just use UNDO immediately after inserting the dungeon map. This will completely remove the map you inserted, but the fill styles will remain.
    • CommentAuthorbravefaces
    • CommentTimeOct 24th 2008
     
    Oh, ok.- that makes sense. Will try to do this tonight. Thanks for the tips!!!
    • CommentAuthorbravefaces
    • CommentTimeNov 10th 2008
     
    I tried inserting a CD3 map, and then clicking undo, and the tools and fill styles still showed up as unavailable.
    • CommentAuthorwigwam
    • CommentTimeNov 22nd 2008 edited
     
    This happened to me too.

    "Darnit CC3, you're so darn complicated. There isn't a learning "curve" it's a sheer-face! I don't know how many times I've given up on you...."
    • CommentAuthorwigwam
    • CommentTimeNov 22nd 2008
     
    Here's the thing - I create a new map with my own settings but based on the DD3 te,plate. I create a floor area using the "Floor" button.
    Everything's fine and dandy. OK.
    I then select the "Add Corridor" button. Cancel it and reselect the "Floor" button.

    The error returns! Why?
    • CommentAuthorNeonKnight
    • CommentTimeNov 22nd 2008
     
    Possible issues could start with:

    Incorrect updates/compatabilities installed.

    Also, ensure you are running version 3.24 (current version).

    I have tried to replicate the error, but it is not happening :(

    Another thought is this: Right Click on the FLOOR TOOL button. The pop-up should display Floor Samples and state it's STYLE is Dungeon DD3 Color.

    If not, then likely something is happening when you click on the ADD CORRIDOR button to deselect the DD3 styles.
    • CommentAuthorwigwam
    • CommentTimeNov 30th 2008
     
    OK I think I've sorted it. I was selecting Starship Floor styles from the 2007 Annual but DON'T have Cosmographer. When I reset the Drawing Style it seems to be behaving correctly.
    • CommentAuthorprobstette
    • CommentTimeNov 30th 2008
     
    I too am having this problem. I have CC3 and DD3, and CC2 in the same folder with CD2 and DD2 add-ons. I also have SS1v3. All were the complete product instead of the upgrade. All were just the download version.

    When I select the Dungeon Menu, I get the choices, but I can't use the DD3 drawing tools, on a map I created before I had DD3 downloaded. (In CC3\ExampleszES-Tutorial01.FCW I can make rooms and corridors, but not Floors and Default walls. I assume this is the same behaviour, but with part of it obliterated by the map I have chosen.)
    • CommentAuthorRob
    • CommentTimeDec 2nd 2008
     
    If you want multipul styles avalible and tools then all you need to do is the following, which was covered some time ago but obviously needs to be brought back up ;) hehe..

    If you go to File: Drawing Properties, you can set the actual Toolset that is being used.

    HOWEVER this may not include all the bitmap files, so the other thing to do is:

    Convert CC2 - CC3

    you'll notice that there are some which are 'just add drawing tools' these just do that... the tools will all work properly.

    If that fails then the way mentioned before works, create a blank file of the type your trying to use, insert it and bang everything works.. I've got 1 or two templates I use that just have everything on them so 1 insert = all the tools etc avalible.