Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
  1.  
    Hi guys, I am a new member and bought the 3 softs bundles last week. I am currently reading manual etc but just found something odd. I have the Menu buttons (Map Menu, City Menu, Dungeon Menu etc) in my interface. If I click on Map Menu, the interface switches to the CC3 default interface but all the other menu buttons disappear (except Map Menu) and I find no way to have them reappear. Is this normal ? How do I get back to a CD3 interface then ?
    • CommentAuthorJimP
    • CommentTimeSep 10th 2014
     
    Close CC3, and go into your CC3 folder and run the program CC3MenuConfig and that should fix it.
  2.  
    Thanks I'll check it though I'm not sure I can easily do this as I'm running it on a Mac.
    • CommentAuthorSkaran
    • CommentTimeMar 19th 2016
     
    I had this problem as well and running CC3MenuConfig did not fix it. If I load the Symbol Set 4 Menu all the buttons are restored but again clicking on them removes several of them.
    Should I copy this menu file under the names of all the other menu files or the FCW32 menu file?
    • CommentAuthorJimP
    • CommentTimeMar 19th 2016
     
    When you move from map type to map type, I mean the add-ons, sometimes the icons for other add-ons go away. To see all of them, click on the CC3 Map Menu button on the top of CC3. If that doesn't work, I would suggest contacting tech support.
    •  
      CommentAuthorMonsen
    • CommentTimeMar 20th 2016
     
    Posted By: SkaranShould I copy this menu file under the names of all the other menu files or the FCW32 menu file?
    Don't do that, there are many differences between the various menu files,. overwriting them all with the SS4 one would cause a lot of havoc.

    Try reinstalling the latest update, then manually run CC3MenuConfig again. Also make sure to right click on it and select 'run as administrator'
    • CommentAuthorSkaran
    • CommentTimeMar 28th 2016
     
    Did all of that no effect. I'll be tring a reinstall to see if that fixes it.
    • CommentAuthorMrBildo
    • CommentTimeJul 6th 2018 edited
     
    I had this same issue after messing around with my installations to fix an unrelated issue.

    In your CC3Plus folder there are menu folders for each add-on plus the main application. For example I have FCW32.mnu, dungeon.mnu, city.mnu and ss4.mnu. In my case, ss4 button was working (meaning the other buttons didn't disappear). When I opened the file I noticed this:

    #419,CC2:[Map Menu]{~|CMENU @SYSTEM\MAP.mnc;}~|LOADCC3;MENUDM @fcw32.mnu;
    #420,DD2:[Dungeon Menu]{~|CMENU @system\dungeon.mnc;}~|LOADDD3;MENUDM @dungeon.mnu;
    #421,CD2:[City Menu]{~|CMENU @system\city.mnc;}~|LOADCD3;MENUDM @city.mnu;
    #427,SS4:[SS4 Menu]{~|CMENU @SYSTEM\ss4.mnc;}~|SYMICONMR;SYMICONFLOAD SS4;MENUDM @SS4.MNU;

    When I opened fcw32.mnu, #420-#427 were missing. The same was true of dungeon and city menu files. So I just added the missing lines to each file and now it works as intended.

    Hope that helps.
    • CommentAuthorJosh.P.
    • CommentTimeJul 7th 2018
     
    I've just gone through the reinstall process and found the menu's to be quite dodgy. I'm missing quite a few of them and the CC3MenuConfig file does not appear to be fixing anything. If i click on CC3+ then all menus are hidden except the CC3+ one.
    • CommentAuthorJimP
    • CommentTimeJul 7th 2018
     
    Doesn't do that on my CC3+ ver 3.84. What version do you have ?
    • CommentAuthorLoopysue
    • CommentTimeJul 7th 2018
     
    Has anyone noticed how old this thread is?

    Never mind...

    I never have any menu problems at all.... well, maybe once, but that was back in the days when I had the CSUAC - which coincidentally is about the same time period as this thread started up. Never had any trouble with any of the native CC3 menus at all.

    Do you have anything other than CC3 menus installed? Just thinking here of the sheer number and complexity of the menu files. Does that affect the way it all works together? I mean, does having all that third party stuff installed perhaps confuse the CC3MenuConfig file?

    Also, the personalisation some of you do - like home-made buttons and so on. Does that affect the menus? (I wouldn't know, since I've never felt the need to do anything like that)

    Ok . You can all fire me down in flames now. I'm just doing my 'thinking outside the box' bit here :)
    • CommentAuthorJimP
    • CommentTimeJul 7th 2018
     
    But I agree with you Sue. I seem to remember one of the updates dealing with menu problems, but I could be mistaken.

    Back in CC2 days there were folks, yahoo groups, who did make their own buttons. But I don't think this is the same goings on.
    • CommentAuthorMrBildo
    • CommentTimeJul 8th 2018 edited
     
    Posted By: Josh.P.I've just gone through the reinstall process and found the menu's to be quite dodgy. I'm missing quite a few of them and the CC3MenuConfig file does not appear to be fixing anything. If i click on CC3+ then all menus are hidden except the CC3+ one.


    Did you read my solution above your post? I had the same issue and was able to fix it by manually adding the menus back in.
    • CommentAuthorJosh.P.
    • CommentTimeJul 8th 2018
     
    If i need to do it I will. I know how the menus work now so I can fix it. I'm rather interesting in just bashing it with the official installers to see if i can figure out how to fix it that way as that will allow me to help new people in the future.