Not signed in (Sign In)

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome Guest!
Want to take part in these discussions? If you have an account, sign in now.
If you don't have an account, apply for one now.
    • CommentAuthorHelenAA
    • CommentTimeJul 25th 2020
     
    I think I've messed up my installation of Cosmographer. The artwork files ended up in my Download folder - not a good place to put them as you'll agree. How do I move them? I'm asking as there's a warning during installation that where the files are installed must be where they stay.
    • CommentAuthorLoopysue
    • CommentTimeJul 25th 2020
     
    Hi Helen :)

    When you say they ended up in the download folder is that where you accidentally directed Cosmographer itself to install?
    •  
      CommentAuthorMonsen
    • CommentTimeJul 25th 2020
     
    Hi Helen,

    I am guessing this artwork folder you have in the downloads is the separate artwork folder CC3+. The Cos installer gives you the option to do this in case you wish to use the artwork with other software, and not just CC3+. This artwork folder is completely independent of your CC3+ folder and can be moved or deleted as you please without affecting CC3+ (I recommend NOT moving it into your CC3+ folder, since CC3+'s own copies of the artwork lives there.)

    You can easily confirm that this is the case by going in and looking at the images in that folder. CC3+'s own artwork folders have 4 copies of every file in different sizes, while the separate artwork folder only have 1 of each.
    • CommentAuthorHelenAA
    • CommentTimeJul 25th 2020
     
    [
    Posted By: LoopysueHi Helen :)

    When you say they ended up in the download folder is that where you accidentally directed Cosmographer itself to install?

    No, Sue, the install I'm talking about is the "additional artwork" that Remy says is a duplicate copy of the copies that CC3+ generates. So in terms of my OP I'm good now..

    Posted By: MonsenHi Helen,

    I am guessing this artwork folder you have in the downloads is the separate artwork folder CC3+. The Cos installer gives you the option to do this in case you wish to use the artwork with other software, and not just CC3+. This artwork folder is completely independent of your CC3+ folder and can be moved or deleted as you please without affecting CC3+ (I recommend NOT moving it into your CC3+ folder, since CC3+'s own copies of the artwork lives there.)

    You can easily confirm that this is the case by going in and looking at the images in that folder. CC3+'s own artwork folders have 4 copies of every file in different sizes, while the separate artwork folder only have 1 of each.


    If you look at the attached screenshot I'm not sure if I have another problem as I left-clicked the Hull drawing tool I get given Terrain tools! I checked the list of sheets and no Terrain sheets to be seen! Clicking Fill Style gives me the path that Cos tells me the scalable hatching symbols are. Problem is that nothing's there. Please don't worry - Cos is looking outside the Windows tree, and in a temporary empty folder, I've not yet copied the additional artwork over.
      Untitled.png
    •  
      CommentAuthorMonsen
    • CommentTimeJul 25th 2020
     
    That certainly sounds weird. There are terrain tools in there, the button right next to the hull button is the terrain button, but they shouldn't show when clicking the hull button.

    Anyway, you have started a map in an old vector style, which is probably not what you want to use. Could you start a new map in the Cosmographer Deckplan Bitmap style instead, and see if things looks better there?
    • CommentAuthorHelenAA
    • CommentTimeJul 25th 2020
     
    I'll try.

    Another incidental issue is I have no idea how to make a map with more than one layer. Previously I've drawn the outline of a house with its stairs, saved it and then exported it to get the first floor. I've been through the UM endless times but it's no help at all. I'd love to do it properly but first things first!
    • CommentAuthorJimP
    • CommentTimeJul 25th 2020
     
    I make a basic map for a level of a ship or dungeon. I save as that as level01_001.

    For level 2, I then save that same map, so the levels line up, as level02_002.

    For level 3, I save as level03_001.

    That way I can modify and work on each level separately.

    There is a way to setup the template for multi-levels in the same fcw file, just go one next button after you get to choose the background color/fill.
    • CommentAuthorHelenAA
    • CommentTimeJul 25th 2020
     
    Posted By: Monsen
      Untitled.png
    • CommentAuthorMonsen
    • CommentTime1 hour ago
    whisp


    here's a rough ship - no worrying abt scale
      OLOGTH,.JPG
    •  
      CommentAuthorMonsen
    • CommentTimeJul 25th 2020
     
    So the tools seems to work correctly in this style?
    • CommentAuthorHelenAA
    • CommentTimeJul 26th 2020
     
    it is apart from Snap not snapping! The button's on but it isn't working. I have to zoom right in close to align symbols to walls. :( And I can't name the ship either. I've tried to click the hyperlink but nothing happens after I've typed the name.

    Told you I thought I'd broken it. LOL
    •  
      CommentAuthorMonsen
    • CommentTimeJul 26th 2020
     
    Have you checked what size the snap grid is set to? If it is to small, it will feel like it isn't snapping, because the snapps come to close. I believe it is 2 snaps every 5 feet in that template, and since you say you are not worrying about scale, you seem to be mapping much larger than the intended scale for that template, mening the divisions will be really tiny.

    For the ship name, you should get the text you type in on the cursor, and need to actually place it where the placeholder text is (the placeholder text should be deleted, but it won't vanish properly until a redraw.)

    I really recommend you make your maps using the wizard templates (decide settings myself) rather than use these pre-made templates.
    • CommentAuthorLoopysue
    • CommentTimeJul 26th 2020
     
    Also worth checking is that the "Cursor snap" box is checked in the grid setup. Some of the older templates seem to have grids that don't have this checked.
    • CommentAuthorHelenAA
    • CommentTimeJul 27th 2020
     
    Posted By: MonsenHave you checked what size the snap grid is set to? If it is to small, it will feel like it isn't snapping, because the snapps come to close. I believe it is 2 snaps every 5 feet in that template, and since you say you are not worrying about scale, you seem to be mapping much larger than the intended scale for that template, mening the divisions will be really tiny.

    For the ship name, you should get the text you type in on the cursor, and need to actually place it where the placeholder text is (the placeholder text should be deleted, but it won't vanish properly until a redraw.)

    I really recommend you make your maps using the wizard templates (decide settings myself) rather than use these pre-made templates.


    I'm learning 2 or 3 apps at the same time and it's as steep a learning curve as when I bought CC3+ back in 2015. I'm like a kid let loose in {insert preference}, rushing from one sparkling toy to another at the moment, Remy. I'll calm down soon! :D